Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 79381 - MPlayer 1.0pre6-3.3.4 freezes while playing from playlist
Summary: MPlayer 1.0pre6-3.3.4 freezes while playing from playlist
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-24 13:39 UTC by Dominic Finke
Modified: 2009-03-29 17:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic Finke 2005-01-24 13:39:35 UTC
3. bug, but i'll keep it short this time:
when i watch movie files from playlist, mplayer plays the first one and hangs up while trying to load the second one.
i don't actually know, if this is a bug or my fault.


Reproducible: Always
Steps to Reproduce:
1.fill playlist (in my case with .avi files)
2. start playing from playlist
3. watch the 1. or skip right to the 2. and see mplayer freezing

Actual Results:  
i get the following error on console:

Seek failed
[ws] Error in display.
[ws]  Error code: 14 ( BadIDChoice (invalid resource ID chosen for this
connection) )
[ws]  Request code: 1
[ws]  Minor code: 0
[ws]  Modules: demux_open
[ws] Error in display.
[ws]  Error code: 14 ( BadIDChoice (invalid resource ID chosen for this
connection) )
[ws]  Request code: 55
[ws]  Minor code: 0
[ws]  Modules: demux_open

Expected Results:  
i should see the 2. avi file, then the 3. and so on...

im trying out mplayer-1.0_pre5-r5 to see, if the error occurs there as well.

[root@hoyakasu]# emerge info
Portage 2.0.51-r14 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20040808-r1
                                               , 2.6.10 i686)
=================================================================
System uname: 2.6.10 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Nov 24 2004, 18:51:07)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r5
sys-devel/automake:  1.8.5-r1
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.2-r7
virtual/os-headers:  2.4.21-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3
                                               /env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3/share/config /us                              
                 r/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.snt.utwent
                                               e.nl/pub/os/linux/gentoo
ftp://ftp.easynet.nl/mirror/gentoo/ ftp://sunsite.infor                        
                       matik.rwth-aachen.de/pub/Linux/gentoo
http://ftp.easynet.nl/mirror/gentoo/"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d aalib acl acpi alsa apache2 arts avi berkdb bitmap-fonts bonobo cdr
                                                crypt cups dga directfb doc dvd
dvdr encode esd ethereal f77 fam fbcon flac fon                                
               t-server foomaticdb fortran gdbm gif gnome gphoto2 gpm gstreamer
gtk gtk2 gtkhtm                                                l imagemagick
imap imlib ipv6 jabber java jpeg junit kde libg++ libwww mad maild             
                                  ir mbox mikmod mmx motif mpeg msn ncurses nls
nocd oggvorbis opengl oscar oss pa                                             
  m pdflib perl png python qt quicktime readline samba sdl speex spell sse ssl
svg                                                a tcltk tcpd tiff truetype
truetype-fonts type1-fonts usb videos wmf wxwindows x                          
                     86 xface xinerama xml xml2 xmms xv yahoo zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LDFLAGS
Comment 1 Dominic Finke 2005-01-24 13:46:46 UTC
ok, emerged mplayer-1.0_pre5-r5. got the same problem so i guess it's my fault an no program bug.
any suggestions how i get rid of that? what could cause this problem?
thx in advance...
Comment 2 Dominic Finke 2005-01-26 00:57:51 UTC
Hahahaaa.... got the problem. the .avi file seems to be corrupted. sorry for the bug post :) oh boy...
Comment 3 Dominic Finke 2005-01-26 00:58:53 UTC
closing bug...
Comment 4 todd bailey 2009-03-29 17:34:09 UTC
 mplayer Traitor.avi
MPlayer SVN-r28951-snapshot-4.3.2 (C) 2000-2009 MPlayer Team
137 audio & 296 video codecs
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Traitor.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [DX50]  604x328  12bpp  23.976 fps  751.7 kbps (91.8 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.5.10.2 (build 2540/release)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 112.0 kbit/7.94% (ratio: 14000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4 @ 0x89cc600]Invalid and inefficient vfw-avi packed B frames detected
VDec: vo config request - 604 x 328 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.84:1 - prescaling to correct movie aspect.
VO: [xv] 604x328 => 604x328 Planar YV12 
A:  88.4 V:  88.6 A-V: -0.165 ct: -0.012 2125/2125  2%  1%  0.6% 0 0
Comment 5 todd bailey 2009-03-29 17:35:14 UTC
Creating new bug entry same issues as previous poster, but occuring on any .avi file