Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 793746 - >=net-misc/networkmanager-1.28 with USE="dhcpcd" crashes X
Summary: >=net-misc/networkmanager-1.28 with USE="dhcpcd" crashes X
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-01 19:22 UTC by cazzantonio
Modified: 2024-07-17 12:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cazzantonio 2021-06-01 19:22:25 UTC
Networkmanager build with USE="dhcpcd" crashes X as soon as the wifi tries to connect to an AP.

I run and amd564 stable system with Xfce on an intel i7-9750H laptop with an ath9k wifi card (AR9462).
More details here: https://forums.gentoo.org/viewtopic-p-8616852.html

If I rebuild without dhcpcd it works fine.

I don't even know what dhcpcd use flag do, it was simply there since long ago. Anyway, if it's available, it should generate crashes like that. Please either remove the flag or fix it.

Reproducible: Always
Comment 1 Roy Marples 2021-07-29 10:40:25 UTC
Here's part of the referenced forum post:

May 30 14:03:25 heavensdoor NetworkManager[3805]: <info>  [1622376205.1687] device (wlp8s0): supplicant interface state: completed -> authenticating
May 30 14:03:25 heavensdoor NetworkManager[3805]: <info>  [1622376205.1694] device (wlp8s0): DHCPv4 lease renewal requested
May 30 14:03:25 heavensdoor syslog-ng[3228]: syslog-ng shutting down; version='3.30.1'
May 30 14:03:25 heavensdoor elogind-daemon[3261]: Received signal 15 [TERM]
May 30 14:03:25 heavensdoor NetworkManager[3805]: <info>  [1622376205.1699] dhcp4 (wlp8s0): canceled DHCP transaction
May 30 14:03:25 heavensdoor NetworkManager[3805]: <info>  [1622376205.1701] dhcp4 (wlp8s0): activation: beginning transaction (timeout in 45 seconds)
May 30 14:03:25 heavensdoor ntpd[4074]: ntpd exiting on signal 15 (Terminated)
May 30 14:03:25 heavensdoor ntpd[4074]: 52.0.56.137 local addr 192.168.1.21 -> <null>
May 30 14:03:25 heavensdoor ntpd[4074]: 162.159.200.1 local addr 192.168.1.21 -> <null>
May 30 14:03:25 heavensdoor ntpd[4074]: 51.255.142.175 local addr 192.168.1.21 -> <null>
May 30 14:03:25 heavensdoor ntpd[4074]: 142.4.213.77 local addr 192.168.1.21 -> <null>
May 30 14:03:25 heavensdoor ntfs-3g[2860]: Unmounting /dev/sda4 ()
May 30 14:03:25 heavensdoor NetworkManager[3805]: <info>  [1622376205.1718] dhcp4 (wlp8s0): dhcpcd started with pid 25585
May 30 14:03:25 heavensdoor dhcpcd[25585]: dhcpcd-9.4.0 starting
May 30 14:03:25 heavensdoor dhcpcd[25585]: DUID 00:01:00:01:1e:46:8b:ba:00:15:61:20:16:0b
May 30 14:03:25 heavensdoor pulseaudio[4401]: [pulseaudio] module-x11-publish.c: PulseAudio information vanished from X11!
May 30 14:03:25 heavensdoor dhcpcd[25585]: wlp8s0: connected to Access Point:
May 30 14:03:25 heavensdoor dhcpcd[25585]: wlp8s0: IAID db:b5:c4:f7

As we can see, syslog-ng reports it's shutting down when NM decides to renew the DHCP lease but *after* it starts anything dhcpcd related.
Comment 3 Pacho Ramos gentoo-dev 2024-07-17 12:02:15 UTC
Please retry with newer NM versions

Thanks