Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 792054 - dev-qt/qtwebengine-5.15.2_p20210521: Could not find all necessary libraries for qpa-xcb support in QtWebEngine.
Summary: dev-qt/qtwebengine-5.15.2_p20210521: Could not find all necessary libraries f...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
: 796608 (view as bug list)
Depends on: 800181
Blocks:
  Show dependency tree
 
Reported: 2021-05-25 16:04 UTC by Vasco Gervasi
Modified: 2021-07-03 14:26 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,16.04 KB, text/plain)
2021-05-25 16:04 UTC, Vasco Gervasi
Details
build.log (build.log,12.20 KB, text/plain)
2021-05-25 16:04 UTC, Vasco Gervasi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vasco Gervasi 2021-05-25 16:04:09 UTC
Hi,
I am trying to build dev-qt/qtwebengine-5.15.2_p20210521, I get the following error:

cd core/ && ( test -e Makefile || /usr/lib64/qt5/bin/qmake -o Makefile /tmp/portage/dev-qt/qtwebengine-5.15.2_p20210521/work/qtwebengine-5.15.2_p20210521/src/core/core.pro CONFIG+=release CONFIG-=debug 'QMAKE_AR=x86_64-pc-linux-gnu-ar cqs' QMAKE_CC=x86_64-pc-linux-gnu-gcc QMAKE_LINK_C=x86_64-pc-linux-gnu-gcc QMAKE_LINK_C_SHLIB=x86_64-pc-linux-gnu-gcc QMAKE_CXX=x86_64-pc-linux-gnu-g++ QMAKE_LINK=x86_64-pc-linux-gnu-g++ QMAKE_LINK_SHLIB=x86_64-pc-linux-gnu-g++ QMAKE_OBJCOPY=x86_64-pc-linux-gnu-objcopy QMAKE_RANLIB= QMAKE_STRIP=x86_64-pc-linux-gnu-strip 'QMAKE_CFLAGS=-march=haswell -mabm -maes --param=l1-cache-line-size=64 --param=l1-cache-size=32 --param=l2-cache-size=6144 -O2 -pipe' QMAKE_CFLAGS_RELEASE= QMAKE_CFLAGS_DEBUG= 'QMAKE_CXXFLAGS=-march=haswell -mabm -maes --param=l1-cache-line-size=64 --param=l1-cache-size=32 --param=l2-cache-size=6144 -O2 -pipe' QMAKE_CXXFLAGS_RELEASE= QMAKE_CXXFLAGS_DEBUG= 'QMAKE_LFLAGS=-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu' QMAKE_LFLAGS_RELEASE= QMAKE_LFLAGS_DEBUG= ) && make -f Makefile 
make[2]: Entering directory '/tmp/portage/dev-qt/qtwebengine-5.15.2_p20210521/work/qtwebengine-5.15.2_p20210521_build/src/core'
QtWebEngineCore module will not be built. Could not find all necessary libraries for qpa-xcb support in QtWebEngine.
make[2]: Leaving directory '/tmp/portage/dev-qt/qtwebengine-5.15.2_p20210521/work/qtwebengine-5.15.2_p20210521_build/src/core'
make[1]: Leaving directory '/tmp/portage/dev-qt/qtwebengine-5.15.2_p20210521/work/qtwebengine-5.15.2_p20210521_build/src'
>>> Source compiled.

Thanks


Reproducible: Always

Steps to Reproduce:
1. emerge -a qtwebengine
2.
3.
Comment 1 Vasco Gervasi 2021-05-25 16:04:28 UTC
Created attachment 711183 [details]
emerge --info
Comment 2 Vasco Gervasi 2021-05-25 16:04:39 UTC
Created attachment 711186 [details]
build.log
Comment 3 Nexion Kind 2021-05-27 01:55:25 UTC
Looks like qtwebengine ebuild should also have x11-libs/libxkbfile in its dependencies.
Comment 4 Vasco Gervasi 2021-06-03 12:54:59 UTC
I have just tried to emerge x11-libs/libxkbfile first and qtwebengine build correctly.
Could you update the ebuild?

Thanks
Comment 5 Bernd 2021-06-09 14:59:50 UTC
I can confirm the issue with only USE="jumbo-build widgets" being enabled on my test host. Can also confirm that the issue can be fixed by installing x11-libs/libxkbfile before emerging this version.
Comment 6 Andreas Sturmlechner gentoo-dev 2021-06-18 15:17:01 UTC
*** Bug 796608 has been marked as a duplicate of this bug. ***
Comment 7 Agostino Sarubbo gentoo-dev 2021-06-23 08:17:08 UTC
(In reply to Bernd from comment #5)
> I can confirm the issue with only USE="jumbo-build widgets" being enabled on
> my test host. Can also confirm that the issue can be fixed by installing
> x11-libs/libxkbfile before emerging this version.

I can confirm that x11-libs/libxkbfile fixes the issue for me
Comment 8 Larry the Git Cow gentoo-dev 2021-07-02 18:53:06 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2b6bfff4302a3c4f8ccdc19d76add554441012bc

commit 2b6bfff4302a3c4f8ccdc19d76add554441012bc
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-07-02 17:57:45 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-07-02 18:51:16 +0000

    dev-qt/qtwebengine: 5.15.2_p20210625 snapshot bump
    
    Snapshotted at:
    Branch: 5.15
    Commit: 7b9e9c92286aec8102ab221434e785a1def0af87
    
    Submodule qtwebengine-chromium.git:
    Branch: 87-based
    Commit: 0b959ee26c9e4098744021d949d0fc67cc0316d8
    
    Closes: https://bugs.gentoo.org/792054
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 dev-qt/qtwebengine/Manifest                        |   1 +
 .../qtwebengine-5.15.2_p20210625.ebuild            | 212 +++++++++++++++++++++
 2 files changed, 213 insertions(+)