Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 791943 - net-analyzer/tracebox-0.4.4-r100 fails to compile
Summary: net-analyzer/tracebox-0.4.4-r100 fails to compile
Status: RESOLVED DUPLICATE of bug 786687
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-05-25 09:55 UTC by Agostino Sarubbo
Modified: 2021-08-01 18:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,75.15 KB, text/plain)
2021-05-25 09:55 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-05-25 09:55:27 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-analyzer/tracebox-0.4.4-r100 fails to compile.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
This machine uses GCC-11: https://gcc.gnu.org/gcc-11/porting_to.html
If you think this is a GCC-11 related issue, please block bug 732706.
Comment 1 Agostino Sarubbo gentoo-dev 2021-05-25 09:55:29 UTC
Created attachment 711129 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-05-25 09:55:30 UTC
Possible context of error(s):

lua/lua_crafter.hpp:65:9: error: parse error in template argument list
Comment 3 David Seifert gentoo-dev 2021-08-01 18:58:43 UTC

*** This bug has been marked as a duplicate of bug 786687 ***