Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 79175 - desklet-calendar is missing a sensor dependency
Summary: desklet-calendar is missing a sensor dependency
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: gDesklets packages
Depends on:
Reported: 2005-01-22 22:13 UTC by Joseph Garvin
Modified: 2005-08-27 13:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Garvin 2005-01-22 22:13:49 UTC
Although desklet-calendar depends on psisensors, I'm still getting an error suggesting that a sensor it needs isn't installed. when I try to run it:

Traceback (most recent call last):
  File "/usr/lib/gdesklets/factory/", line 59, in create_sensor
    module = __import__(name)
  File "./Calendar/", line 5, in ?
    from main import admin
ImportError: cannot import name admin

Reproducible: Always
Steps to Reproduce:
1. Open gdesklets shell
2. Run the calendar
3. Look at error

Actual Results:  
Got an error.

Expected Results:  
Calendar display.

Portage 2.0.51-r14 (default-linux/x86/2004.2, gcc-3.3.5,
glibc-, 2.6.10-gentoo-r4 i686)
System uname: 2.6.10-gentoo-r4 i686 AMD Athlon(tm) XP 3000+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Jan  3 2005, 23:26:23)]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r5
sys-devel/automake:  1.8.5-r1
sys-devel/libtool:   1.5.2-r7
CFLAGS="-O2 -march=athlon-xp -mcpu=i686 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -mcpu=i686 -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="x86 3dnow X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups dga encode
esd f77 fam flac font-server foomaticdb fortran gdbm gif gpm gtk gtk2
imagemagick imlib ipv6 java jpeg junit kde libg++ libwww mad mikmod mmx motif
mpeg ncurses nls nptl oggvorbis opengl oss pam pdflib perl png python qt
quicktime readline samba sdl slang spell sse ssl svga tcltk tcpd tiff tk
truetype truetype-fonts type1-fonts xml2 xmms xv zlib"

(and no it's not my use flags ;)
Comment 1 Joseph Garvin 2005-01-22 22:15:51 UTC
P.S. I'm using gdesklets 0.33.1
Comment 2 Mike Gardiner (RETIRED) gentoo-dev 2005-01-23 00:23:07 UTC
I'd guess it's something to do with the psi desklets using libdesklets which is now deprecated.

Looks like we'll have issues with psi+0.33.1
Comment 3 Jacob Braun 2005-02-03 15:07:54 UTC
I found that if you comment out the line that reads "from main import admin" in /usr/share/gdesklets/Sensors/Calendar/ then the calendar loads and displays normally. Not sure if it's a real fix, but it works...
Comment 4 Joseph Garvin 2005-02-03 17:06:55 UTC
That fix didn't work for me. Now I just get a different error =)

Traceback (most recent call last):
  File "/usr/lib/gdesklets/factory/", line 86, in create_sensor
    sensor = module.new_sensor(args)
  File "./Theme/", line 112, in new_sensor
    def new_sensor(args): return apply(Theme, args)
  File "./Theme/", line 31, in __init__
    for a in output[0].split():
IndexError: list index out of range

The weather desklet I found runs, but it says "Retrieval failed." Not sure if that's because a sensor is missing or if because whatever server it tries to talk to is always down.
Comment 5 Jacob Braun 2005-02-03 23:09:03 UTC
Have you emerged desklet-psisensors?
Comment 6 Joseph Garvin 2005-02-04 10:32:23 UTC
Yup. I've had it since I first tried gdesklets.

xxxxxx@citadel ~ $ emerge -p desklet-psisensors

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] x11-plugins/desklet-psisensors-20040420 
Comment 7 Jacob Braun 2005-02-04 11:03:48 UTC
And it should be as it's listed in the dependencies. Should have looked at the ebuild. ;-) Try emerging psidisplays as well. I think this should be a dependency as well. IIRC it worked for me once that was installed as well. Let me know if it works after merging that.
Comment 8 Joe Sapp (RETIRED) gentoo-dev 2005-03-08 07:58:45 UTC
Many people were having this issue a while back, but I guess since this is fixed by any of the latest versions of Calendar, as soon as this ebuild is removed from portage this bug can be closed.
Comment 9 Joe Sapp (RETIRED) gentoo-dev 2005-08-27 13:33:52 UTC
Getting rid of the old Calendar soon...when I do, I'll put in the new version.