Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 79167 - undeclared install conflict media-video/drip media-libs/libmpeg2 over libmpeg2
Summary: undeclared install conflict media-video/drip media-libs/libmpeg2 over libmpeg2
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-22 18:57 UTC by Phil Pennock
Modified: 2005-11-04 05:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Pennock 2005-01-22 18:57:24 UTC
# qpkg -I -f /usr/lib/libmpeg2.so
media-libs/libmpeg2 *
media-video/drip *

Whilst installing a game which depends upon games-engines/scummvm, the build of that failed because of missing symbols starting "mpeg_"; those symbols weren't in libmpeg2.a, according to nm(1).  Using qpkg(1), saw the double ownership.

Unmerged drip, re-emerged libmpeg2, emerged the game again and this time everything worked.

So, to my inexperienced eye, it looks as though drip is installing a much more minimal libmpeg2, which breaks other ebuilds, with no conflict declared against the more full-featured libmpeg2 ebuild.

Reproducible: Always
Steps to Reproduce:
1. emerge media-libs/libmpeg2
2. emerge media-video/drip
3. emerge games-engines/scummvm

Actual Results:  
emerge of games-engines/scummvm failed

Expected Results:  
emerged the engine which depended upon libmpeg2 successfully
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-10-30 11:06:35 UTC
Is this still an issue with drip-0.9.0 ? 
 
Comment 2 Phil Pennock 2005-10-30 12:49:02 UTC
Sorry, don't know; the current drip is ~x86 and I run x86 and don't want to
break my mpeg setup again at the moment, not having a spare test system.

I guess the question is whether or not drip-0.9.0 installs a libmpeg2 in
/usr/lib/; if so, then yes it's still a problem.

Sorry that I can't help any further.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2005-11-04 05:01:02 UTC
drip masked and pending removal.