Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 790350 - media-gfx/openvdb-7.1.0-r1 fails to compile (Unable to find boost_python310, boost_python3 or boost_python)
Summary: media-gfx/openvdb-7.1.0-r1 fails to compile (Unable to find boost_python310, ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Adrian
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-15 12:23 UTC by Alessandro Barbieri
Modified: 2021-05-15 17:06 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge_info (emerge_info,42.21 KB, text/plain)
2021-05-15 12:23 UTC, Alessandro Barbieri
Details
openvdb-7.1.0-r1:20210515-115119.log (openvdb-7.1.0-r1:20210515-115119.log,10.49 KB, text/plain)
2021-05-15 12:23 UTC, Alessandro Barbieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Barbieri 2021-05-15 12:23:18 UTC
This package fails to compile on an unstable system. Attached relevant logs and emerge --info
Comment 1 Alessandro Barbieri 2021-05-15 12:23:32 UTC
Created attachment 708750 [details]
emerge_info

emerge --info
Comment 2 Alessandro Barbieri 2021-05-15 12:23:33 UTC
Created attachment 708753 [details]
openvdb-7.1.0-r1:20210515-115119.log

build log
Comment 3 Sam James archtester gentoo-dev Security 2021-05-15 12:42:04 UTC
I thought we masked Python on it for this reason? Boost’s Python support is broken
Comment 4 Ionen Wolkens gentoo-dev 2021-05-15 13:42:08 UTC
(In reply to Sam James from comment #3)
> I thought we masked Python on it for this reason? Boost’s Python support is
> broken
fwiw it's only a stable mask

But both openvdb[python] and even openvdb[python,numpy] built fine for me, haven't looked further into what might've happened.

dev-libs/boost-1.76.0::gentoo was built with the following:
USE="icu numpy python threads zlib zstd -bzip2 -context -debug -doc -lzma -mpi -nls -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_9 -python3_7 -python3_8"

media-gfx/openvdb-7.1.0-r1::gentoo was built with the following:
USE="abi7-compat numpy python utils -abi6-compat -doc -static-libs -test" ABI_X86="(64)" CPU_FLAGS_X86="avx sse4_2" PYTHON_SINGLE_TARGET="python3_9 -python3_7 -python3_8"
Comment 5 Bernd 2021-05-15 16:12:23 UTC
The problem seems to be
-- Found Python: /usr/include/python3.10) (found suitable version "3.10.0", minimum required is "2.7")
although python3_8 is requested.

Changing -DPython_EXECUTABLE= to -DPython3_EXECUTABLE= might solve this issue. 

Python_EXECUTABLE is accepted by the first interpreter found, while Python3_EXECUTABLE also eventually finds another version than the requested first, but in the end get's the passed parameter correct.
Comment 6 Ionen Wolkens gentoo-dev 2021-05-15 16:54:10 UTC
Ah thanks, I can reproduce now.

I'll start keeping python3.10 around by default in my test env to catch these.
Comment 7 Bernd 2021-05-15 17:06:46 UTC
(In reply to Ionen Wolkens from comment #6)
> Ah thanks, I can reproduce now.
> 
> I'll start keeping python3.10 around by default in my test env to catch
> these.

Note, it's not specific to python-3.10 but can happen anytime, as soon as more than one python version is installed.