Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 789372 - dev-db/mysql-8.0.23 fails to compile
Summary: dev-db/mysql-8.0.23 fails to compile
Status: RESOLVED DUPLICATE of bug 786402
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-10 22:38 UTC by Markus Giese
Modified: 2021-05-10 23:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log.zip,49.96 KB, application/zip)
2021-05-10 22:42 UTC, Markus Giese
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Giese 2021-05-10 22:38:43 UTC
dev-db/mysql-8.0.23 fails to compile, i dont see any error

Reproducible: Always

Steps to Reproduce:
1.emerge sync
2.emerge =dev-db/mysql-8.0.23
3.
Actual Results:  
stops

Expected Results:  
should run through
Comment 1 Markus Giese 2021-05-10 22:39:12 UTC
# emerge --info '=dev-db/mysql-8.0.23::gentoo'
Portage 3.0.18 (python 3.8.9-final-0, default/linux/amd64/17.1/desktop, gcc-11.1.0, glibc-2.32-r7, 5.11.3-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.11.3-gentoo-x86_64-AMD_Ryzen_7_3700X_8-Core_Processor-with-glibc2.2.5
KiB Mem:    16330924 total,   2665520 free
KiB Swap:   17292556 total,  17291020 free
Timestamp of repository gentoo: Mon, 10 May 2021 20:30:01 +0000
Head commit of repository gentoo: 711a9668d68e45b3beda2b0df843e0845e979792
sh bash 5.0_p18
ld GNU ld (Gentoo 2.34 p6) 2.34.0
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
ccache version 4.2.1 [disabled]
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.18_p9::gentoo, 3.7.9-r1::gentoo, 3.8.9_p2::gentoo, 3.9.4_p1::gentoo
dev-lang/rust:            1.51.0-r2::gentoo
dev-util/ccache:          4.2.1::gentoo
dev-util/cmake:           3.18.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1-r1::gentoo
sys-apps/sandbox:         2.22::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2-r1::gentoo
sys-devel/binutils:       2.34-r2::gentoo, 2.35.2::gentoo
sys-devel/gcc:            7.5.0-r1::gentoo, 9.3.0-r2::gentoo, 10.3.0::gentoo, 11.1.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r7::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=znver2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=znver2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="https://ftp.halifax.rwth-aachen.de/gentoo/ https://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 avi berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cuda cups dbus dri dts dvd dvdr elogind emboss encode exif flac flv fortran gdbm gif gpm gstreamer gtk gui iconv icu ipv6 jpeg jpg lcms libglvnd libnotify libtirpc lm_sensors mad mkv mng mp2 mp3 mp4 mpeg mplayer mtp multilib ncurses nls nptl ogg opengl openmp pam pango pcm pcre pdf png policykit ppds pulseaudio qt5 readline sdl seccomp speech spell split-usr ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="32 64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS

=================================================================
                        Package Settings
=================================================================

dev-db/mysql-8.0.23::gentoo was built with the following:
USE="perl server -cjk -cracklib -debug -jemalloc -latin1 -libressl -numa -profiling -router (-selinux) -tcmalloc -test" ABI_X86="(64)"
CFLAGS="-O2 -march=znver2 -pipe -fno-strict-aliasing"
CXXFLAGS="-O2 -march=znver2 -pipe -felide-constructors -fno-strict-aliasing"
FEATURES="fixlafiles binpkg-dostrip userpriv parallel-fetch merge-sync binpkg-docompress multilib-strict distlocks strict qa-unresolved-soname-deps sfperms ipc-sandbox assume-digests unmerge-orphans news preserve-libs usersync usersandbox unknown-features-warn pid-sandbox sandbox network-sandbox config-protect-if-modified protect-owned userfetch binpkg-logs xattr unmerge-logs ebuild-locks"
Comment 2 Markus Giese 2021-05-10 22:42:45 UTC
Created attachment 706851 [details]
build.log

none
Comment 3 Markus Giese 2021-05-10 22:43:24 UTC
# emerge -pqv '=dev-db/mysql-8.0.23::gentoo'
[ebuild   R   ] dev-db/mysql-8.0.23  USE="perl server -cjk -cracklib -debug -jemalloc -latin1 -numa -profiling -router (-selinux) -tcmalloc -test (-libressl%)"
Comment 4 Jonas Stein gentoo-dev 2021-05-10 23:01:55 UTC
if you scroll a bit up, you see error messages:
error: unnamed scoped enum is not allowed
Comment 5 Thomas Deutschmann gentoo-dev Security 2021-05-10 23:17:40 UTC
It's not compatible with gcc-11 which is not stable. Use ~arch package of dev-db/mysql where it is addressed.

*** This bug has been marked as a duplicate of bug 786402 ***
Comment 6 Markus Giese 2021-05-10 23:22:51 UTC
ok i see. 

i updated the first time in 3 months and lots of packages fail atm. i saw my system switched to gcc-11 without my accordance.... maybe gcc-11 has been set to default much too early ? just a guess, as i am no developer nor a very good coder...
Comment 7 Markus Giese 2021-05-10 23:24:08 UTC
(In reply to Thomas Deutschmann from comment #5)
> It's not compatible with gcc-11 which is not stable. Use ~arch package of
> dev-db/mysql where it is addressed.
> 
> *** This bug has been marked as a duplicate of bug 786402 ***

-arch package ? what do you mean, a keyword "arch" or just an unstable version ?
Comment 8 Thomas Deutschmann gentoo-dev Security 2021-05-10 23:28:56 UTC
If your system switched to gcc-11, you have told your system to do that. GCC:11 never hit Gentoo stable yet. So you must have it manually keyworded in /etc/portage.

Anyway, what I am saying is that if you use gcc:11 from unstable, you also need to use dev-db/mysql from unstable, i.e. =dev-db/mysql-8.0.24 builds with gcc:11.
Comment 9 Markus Giese 2021-05-10 23:42:11 UTC
(In reply to Markus Giese from comment #7)
> (In reply to Thomas Deutschmann from comment #5)
> > It's not compatible with gcc-11 which is not stable. Use ~arch package of
> > dev-db/mysql where it is addressed.
> > 
> > *** This bug has been marked as a duplicate of bug 786402 ***
> 
> -arch package ? what do you mean, a keyword "arch" or just an unstable
> version ?

nevermind mysql-8.0.24 (unstable) does fix it indeed
Comment 10 Markus Giese 2021-05-10 23:42:31 UTC
(In reply to Thomas Deutschmann from comment #8)
> If your system switched to gcc-11, you have told your system to do that.
> GCC:11 never hit Gentoo stable yet. So you must have it manually keyworded
> in /etc/portage.
> 
> Anyway, what I am saying is that if you use gcc:11 from unstable, you also
> need to use dev-db/mysql from unstable, i.e. =dev-db/mysql-8.0.24 builds
> with gcc:11.

thanks