Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 789366 - sys-fs/cryfs-0.10.3: stabilisation (was: does not compile with GCC 11)
Summary: sys-fs/cryfs-0.10.3: stabilisation (was: does not compile with GCC 11)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Nick
URL:
Whiteboard:
Keywords: CC-ARCHES
: 808162 (view as bug list)
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-05-10 21:21 UTC by Markus Giese
Modified: 2021-10-13 20:32 UTC (History)
8 users (show)

See Also:
Package list:
sys-fs/cryfs-0.10.3-r1
Runtime testing required: ---
nattka: sanity-check+


Attachments
build.log (build.log,290.51 KB, text/x-log)
2021-05-10 21:23 UTC, Markus Giese
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Giese 2021-05-10 21:21:07 UTC
compiling stops, can not make out what the issue is

Reproducible: Always

Steps to Reproduce:
1.emerge sync
2.emerge =sys-fs/cryfs-0.10.2
3.
Actual Results:  
does not compile

Expected Results:  
should compile
Comment 1 Markus Giese 2021-05-10 21:22:05 UTC
# emerge --info '=sys-fs/cryfs-0.10.2::gentoo'
Portage 3.0.18 (python 3.8.9-final-0, default/linux/amd64/17.1/desktop, gcc-11.1.0, glibc-2.32-r7, 5.11.3-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.11.3-gentoo-x86_64-AMD_Ryzen_7_3700X_8-Core_Processor-with-glibc2.2.5
KiB Mem:    16330920 total,  12493440 free
KiB Swap:   17292556 total,  17292556 free
Timestamp of repository gentoo: Mon, 10 May 2021 20:30:01 +0000
Head commit of repository gentoo: 711a9668d68e45b3beda2b0df843e0845e979792
sh bash 5.0_p18
ld GNU ld (Gentoo 2.34 p6) 2.34.0
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
ccache version 4.2.1 [disabled]
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          2.7.18_p9::gentoo, 3.7.9-r1::gentoo, 3.8.9_p2::gentoo, 3.9.4_p1::gentoo
dev-lang/rust:            1.51.0-r2::gentoo
dev-util/ccache:          4.2.1::gentoo
dev-util/cmake:           3.18.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1-r1::gentoo
sys-apps/sandbox:         2.22::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2-r1::gentoo
sys-devel/binutils:       2.34-r2::gentoo, 2.35.2::gentoo
sys-devel/gcc:            7.5.0-r1::gentoo, 9.3.0-r2::gentoo, 10.3.0::gentoo, 11.1.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r7::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=znver2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=znver2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="https://ftp.halifax.rwth-aachen.de/gentoo/ https://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 avi berkdb bluetooth branding bzip2 cairo cdda cdr cli crypt cuda cups dbus dri dts dvd dvdr elogind emboss encode exif flac flv fortran gdbm gif gpm gstreamer gtk gui iconv icu ipv6 jpeg jpg lcms libglvnd libnotify libtirpc lm_sensors mad mkv mng mp2 mp3 mp4 mpeg mplayer mtp multilib ncurses nls nptl ogg opengl openmp pam pango pcm pcre pdf png policykit ppds pulseaudio qt5 readline sdl seccomp speech spell split-usr ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="32 64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS

=================================================================
                        Package Settings
=================================================================

sys-fs/cryfs-0.10.2::gentoo was built with the following:
USE="-custom-optimization -debug -libressl -test" ABI_X86="(64)"
CFLAGS="-O2 -march=znver2 -pipe -O3 -DNDEBUG"
CXXFLAGS="-O2 -march=znver2 -pipe -O3 -DNDEBUG"
FEATURES="unmerge-logs binpkg-dostrip sandbox unknown-features-warn userfetch usersandbox pid-sandbox protect-owned config-protect-if-modified binpkg-docompress network-sandbox parallel-fetch merge-sync assume-digests sfperms distlocks multilib-strict fixlafiles preserve-libs usersync ebuild-locks ipc-sandbox strict userpriv unmerge-orphans binpkg-logs xattr qa-unresolved-soname-deps news"
Comment 2 Markus Giese 2021-05-10 21:22:49 UTC
# emerge -pqv '=sys-fs/cryfs-0.10.2::gentoo'
[ebuild   R   ] sys-fs/cryfs-0.10.2  USE="-custom-optimization -debug -test (-libressl%)" 

 * IMPORTANT: 46 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.
Comment 3 Markus Giese 2021-05-10 21:23:18 UTC
Created attachment 706848 [details]
build.log

none
Comment 4 Ionen Wolkens gentoo-dev 2021-05-11 03:54:54 UTC
DataNodeView.h:70:95: error: macro "_serialize" passed 5 arguments, but takes just 0

I don't recommend to use gcc-11.1.0 on a stable system.

This issue is only fixed in ~testing's cryfs-1.10.3 (bug #786459), similar applies to the fixes for several other packages.

Unrelated, but I also advise against global -DNDEBUG that I see in your *FLAGS. For some packages this can introduce runtime issues where it's scarcely tested (see man 3 assert).
Comment 5 Sam James archtester gentoo-dev Security 2021-08-13 18:34:36 UTC
(In reply to Ionen Wolkens from comment #4)
> DataNodeView.h:70:95: error: macro "_serialize" passed 5 arguments, but
> takes just 0
> 
> I don't recommend to use gcc-11.1.0 on a stable system.
> 
> This issue is only fixed in ~testing's cryfs-1.10.3 (bug #786459), similar
> applies to the fixes for several other packages.
> 
> Unrelated, but I also advise against global -DNDEBUG that I see in your
> *FLAGS. For some packages this can introduce runtime issues where it's
> scarcely tested (see man 3 assert).

That's USE=debug in the ebuild, I think?

Anyway, indeed.
Comment 6 NATTkA bot gentoo-dev 2021-08-13 18:36:32 UTC Comment hidden (obsolete)
Comment 7 Andreas Sturmlechner gentoo-dev 2021-08-26 14:43:40 UTC
*** Bug 808162 has been marked as a duplicate of this bug. ***
Comment 8 Agostino Sarubbo gentoo-dev 2021-08-29 10:02:50 UTC
x86 stable
Comment 9 Sam James archtester gentoo-dev Security 2021-09-04 21:35:44 UTC
arm64 done
Comment 10 Andreas K. Hüttel archtester gentoo-dev 2021-09-18 18:12:38 UTC
All done here, no reason to keep it open.
Comment 11 Andreas K. Hüttel archtester gentoo-dev 2021-09-19 12:45:47 UTC
Seems like amd64 was missing still. Please stabilize.
Comment 12 Andreas K. Hüttel archtester gentoo-dev 2021-09-27 19:04:18 UTC
@amd64: ping
Comment 13 Andreas K. Hüttel archtester gentoo-dev 2021-10-05 23:04:07 UTC
@amd64: ping! anyone home? ago?
Comment 14 Toralf Förster gentoo-dev 2021-10-13 09:50:47 UTC
now it affects stable too
Comment 15 John Plesmid 2021-10-13 11:08:28 UTC
sys-fs/cryfs-0.10.2-r1 failed to compile.
sys-devel/gcc-11.2.0 went stable on 12 October (Yesterday EDT) and I did upgrade without apparent issue. I sync and upgrade my system everyday @ ~7AM EDT.
Today (13 October EDT) I did my normal sync and upgrade and sys-fs/cryfs-0.10.2-r1 failed to compile.
I will be happy to provide any additional information requested
Comment 16 David C. Bryant 2021-10-13 14:35:32 UTC
What John Plesmid said. I also update my Gentoo system every day, and today the update died on this module (sys-fs/cryfs). I don't even use an encrypted file system, and I can probably get along without this mocule. But it's required by plasma-vault, which is pulled in by plasma-meta. And it messes up "depclean", etc.

I did notice a couple of things. One of the comments mentions a compiler version. I last built this package (successfully) on 14 August, 2021. Since then my gcc compiler has been upgraded, from 11.1.0 to 11.2.0. I also see that this bug is supposedly fixed in version sys-fs/cryfs-0.10.3-r1. So I guess I'll try installing the "testing" package to get around this problem.
Comment 17 David C. Bryant 2021-10-13 14:48:37 UTC
So I just installed the "testing" version of cryfs, and it compiles cleanly. Plus "depclean" has stopped complaining.

emerge --ask --oneshot --autounmask=y =sys-fs/cryfs-0.10.3-r1

This told me to run "etc-update", which I did, accepting the proposed changes (unmask this package for ~AMD64 flag). Running the same command a second time produced a new version of sys-fs/cryfs. Right now, everything looks copacetic on my end.
Comment 18 Bob Johnson 2021-10-13 19:29:16 UTC
I have two nearly identical stable amd64 Gentoo systems (identical world files), one an older Intel i5-3570 and one a newer AMD Ryzen 9 3950X. Both systems are updated daily; both are running yesterdays gcc-11.2.0 compiler update. On the Intel system sys-fs/0.10.2 compiles fine, while on the AMD system I get the same '_serialize' compiler fail noted above. Unmasking sys-fs/cryfs-0.10.3-r1 on the AMD system allows cryfs to compile. Not sure if it's actually CPU-related or not, and since 0.10.3-r1 works it's probably a moot issue anyway, but thought I'd add another data point if anyone cares.
Comment 19 Sam James archtester gentoo-dev Security 2021-10-13 20:32:59 UTC
amd64 done

all arches done