Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 787908 - net-libs/srt-1.4.2 - /.../sync.h: error: numeric_limits was not declared in this scope (maybe gcc-11 related)
Summary: net-libs/srt-1.4.2 - /.../sync.h: error: numeric_limits was not declared in t...
Status: RESOLVED DUPLICATE of bug 787023
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-05-03 14:12 UTC by Toralf Förster
Modified: 2021-05-04 22:47 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.55 KB, text/plain)
2021-05-03 14:12 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,363.40 KB, text/plain)
2021-05-03 14:12 UTC, Toralf Förster
Details
environment (environment,108.12 KB, text/plain)
2021-05-03 14:12 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,21.55 KB, application/x-bzip)
2021-05-03 14:12 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,5.29 KB, application/x-bzip)
2021-05-03 14:12 UTC, Toralf Förster
Details
net-libs:srt-1.4.2:20210503-134105.log (net-libs:srt-1.4.2:20210503-134105.log,26.09 KB, text/plain)
2021-05-03 14:12 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,28.98 KB, application/x-bzip)
2021-05-03 14:12 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-05-03 14:12:29 UTC
                 from /var/tmp/portage/net-libs/srt-1.4.2/work/srt-1.4.2/srtcore/api.cpp:64:
/var/tmp/portage/net-libs/srt-1.4.2/work/srt-1.4.2/srtcore/sync.h: In static member function ‘static constexpr srt::sync::TimePoint<Clock> srt::sync::TimePoint<Clock>::min()’:
/var/tmp/portage/net-libs/srt-1.4.2/work/srt-1.4.2/srtcore/sync.h:182:68: error: ‘numeric_limits’ was not declared in this scope
  182 |     static inline ATR_CONSTEXPR TimePoint min() { return TimePoint(numeric_limits<uint64_t>::min()); }
      |                                                                    ^~~~~~~~~~~~~~
/var/tmp/portage/net-libs/srt-1.4.2/work/srt-1.4.2/srtcore/sync.h:182:94: error: ‘::min’ has not been declared; did you mean ‘std::min’?
  182 |     static inline ATR_CONSTEXPR TimePoint min() { return TimePoint(numeric_limits<uint64_t>::min()); }

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib-20210423-202814

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-8.3.1
 [3] x86_64-pc-linux-gnu-11.1.0 *
clang version 12.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.0
Python 3.8.9
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.51.0 *
The Glorious Glasgow Haskell Compilation System, version 8.10.4
  [1]   php7.3 *
  [2]   php7.4
  [3]   php8.0

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Mon May  3 13:05:13 UTC 2021

emerge -qpvO net-libs/srt
[ebuild  N    ] net-libs/srt-1.4.2  USE="-gnutls"
Comment 1 Toralf Förster gentoo-dev 2021-05-03 14:12:30 UTC
Created attachment 705738 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-05-03 14:12:32 UTC
Created attachment 705741 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-05-03 14:12:33 UTC
Created attachment 705744 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-05-03 14:12:35 UTC
Created attachment 705747 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-05-03 14:12:35 UTC
Created attachment 705750 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-05-03 14:12:36 UTC
Created attachment 705753 [details]
net-libs:srt-1.4.2:20210503-134105.log
Comment 7 Toralf Förster gentoo-dev 2021-05-03 14:12:38 UTC
Created attachment 705756 [details]
temp.tar.bz2
Comment 8 Christian Bricart 2021-05-04 07:46:13 UTC
patch from Bug #787023 fixes this
Comment 9 Sam James archtester gentoo-dev Security 2021-05-04 22:47:14 UTC

*** This bug has been marked as a duplicate of bug 787023 ***