Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 787395 - media-plugins/vdr-zappilot-0.0.5-r1 fails to compile with gcc-11
Summary: media-plugins/vdr-zappilot-0.0.5-r1 fails to compile with gcc-11
Status: RESOLVED DUPLICATE of bug 787392
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-05-01 12:58 UTC by Agostino Sarubbo
Modified: 2021-05-02 18:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,16.98 KB, text/plain)
2021-05-01 12:58 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-05-01 12:58:37 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: media-plugins/vdr-zappilot-0.0.5-r1 fails to compile with gcc-11.
Discovered on: amd64 (internal ref: ci)

NOTE:
This machine uses GCC-11: https://gcc.gnu.org/gcc-11/porting_to.html
Comment 1 Agostino Sarubbo gentoo-dev 2021-05-01 12:58:40 UTC
Created attachment 704967 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-05-01 12:58:42 UTC
Possible context of error(s):

/var/tmp/portage/media-plugins/vdr-zappilot-0.0.5-r1/temp/environment: line 1866: epatch: command not found
zappilotosd.c:175:4: error: ‘cSchedulesLock’ was not declared in this scope; did you mean ‘cSchedules_Lock’?
Comment 3 Joerg Bornkessel gentoo-dev 2021-05-02 18:02:28 UTC
sorry, my fault
Sam@g.o has fixed already..

*** This bug has been marked as a duplicate of bug 787392 ***