Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 787170 - mail-client/thunderbird-78.10.0 www-client/firefox-88.0-r1 : build stalls with net-libs/nodejs-16.0.0-r1
Summary: mail-client/thunderbird-78.10.0 www-client/firefox-88.0-r1 : build stalls wit...
Status: RESOLVED DUPLICATE of bug 787158
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-30 16:35 UTC by Petronio Coelho
Modified: 2021-05-01 01:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mail-client/thunderbird-78.10.0 build.log (build.log.xz,426.05 KB, application/x-xz)
2021-04-30 16:38 UTC, Petronio Coelho
Details
top -u portage screenshot (Screenshot from 2021-04-30 13-25-07.png,129.53 KB, image/png)
2021-04-30 16:39 UTC, Petronio Coelho
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petronio Coelho 2021-04-30 16:35:50 UTC
Both mail-client/thunderbird-78.10.0 and www-client/firefox-88.0-r1 builds stall when net-libs/nodejs-16.0.0-r1 is installed. Neither package encounters the problem when built with net-libs/nodejs-14.16.1-r1 .

Reproducible: Always




emerge --info
Portage 3.0.18 (python 3.9.4-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-11.1.0, glibc-2.33, 5.12.0-gentoo x86_64)
=================================================================
System uname: Linux-5.12.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700HQ_CPU_@_2.80GHz-with-glibc2.33
KiB Mem:    32720504 total,   8722868 free
KiB Swap:   16359420 total,  16359420 free
Timestamp of repository gentoo: Fri, 30 Apr 2021 06:50:13 +0000
Head commit of repository gentoo: e95106b3e2aba011f42d2d6e988ac0cc6943fb52

sh bash 5.1_p4
ld GNU ld (Gentoo 2.36.1 p3) 2.36.1
app-shells/bash:          5.1_p4::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.32.1::gentoo
dev-lang/python:          3.8.9::gentoo, 3.9.4::gentoo
dev-lang/rust:            1.51.0-r2::gentoo
dev-util/cmake:           3.20.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7-r2::gentoo
sys-apps/sandbox:         2.23::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.3-r1::gentoo
sys-devel/binutils:       2.36.1-r1::gentoo
sys-devel/gcc:            11.1.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo.git
    priority: -1000
    sync-git-verify-commit-signature: true

localrepo
    location: /usr/local/portage
    masters: gentoo

calculate
    location: /var/lib/layman/calculate
    masters: gentoo
    priority: 50

jorgicio
    location: /var/lib/layman/jorgicio
    masters: gentoo
    priority: 50

laurentb
    location: /var/lib/layman/laurentb
    masters: gentoo
    priority: 50

lto-overlay
    location: /var/lib/layman/lto-overlay
    masters: gentoo mv
    priority: 50

mv
    location: /var/lib/layman/mv
    masters: gentoo
    priority: 50

pentoo
    location: /var/lib/layman/pentoo
    masters: gentoo
    priority: 50

sakaki-tools
    location: /var/lib/layman/sakaki-tools
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 9 --load-average 8 --with-bdeps=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
FEATURES="assume-digests binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg cgroup clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync mount-sandbox multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms split-elog split-log strict strict-keepdir unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu -march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
LINGUAS="en"
MAKEOPTS="-j9 -l8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacs acl acpi alsa amd64 amr aom audit avif bcrypt bdplus berkdb blake2 bluetooth bluray branding brotli btrfs bzip2 cairo caps cdda cdr cli colord corefonts crypt cups curl custom-cflags daap dbus djvu dri dts dvb dvd dvdr dvi ed25519 emboss encode evo exif faad fam fdk ffmpeg filecaps firewalld flac fontconfig fontforge fortran fpx fuse gdbm gif gme gmp gnome gnome-keyring gnome-online-accounts gpm graphviz gsf gsm gstreamer gtk gtk3 gui hdri heif iconv icu idn inotify introspection iproute2 iptc ipv6 jbig jit jpeg jpeg2k lcms lensfun libaom libass libdrm libglvnd libidn2 libnotify libsecret libtirpc libva live lm_sensors lto lz4 lzma lzo mad matroska mms mng modplug mp3 mp4 mpeg mtp multilib musepack nautilus ncurses networkmanager nftables nls nptl oauth ogg openexr opengl openh264 openmp openssl opus orc pam pango pcre pdf pgo plymouth png policykit postscript ppds pulseaudio qt5 raw readline samba sctp sdl seccomp sftp sha3 shout smp speex spell split-usr srt ssl startup-notification svg sysprof system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-llvm system-zlib systemd t1lib taglib tcpd theora threads tiff tracker truetype udev udisks unicode unwind upnp upnp-av upower usb v4l vaapi vorbis vpx wavpack wayland webp wmf x264 x265 xattr xcb xcrypt xml xmp xpm xps xv xvid xxhash xz zeroconf zlib zsh-completion zstd zvbi" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="BPF WebAssembly" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_10 python3_9" PYTHON_TARGETS="python3_8 python3_10 python3_9" RUBY_TARGETS="ruby26 ruby27 ruby30" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 1 Petronio Coelho 2021-04-30 16:38:01 UTC
Created attachment 704598 [details]
mail-client/thunderbird-78.10.0 build.log
Comment 2 Petronio Coelho 2021-04-30 16:39:35 UTC
Created attachment 704601 [details]
top -u portage screenshot
Comment 3 Petronio Coelho 2021-04-30 16:40:40 UTC
(In reply to Petronio Coelho from comment #2)
> Created attachment 704601 [details]
> top -u portage screenshot

Last two commands that are cropped are as follows:

/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird_build/_virtualenvs/init_py3/bin/python -m mozbuild.action.file_generate /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/python/mozbuild/mozbuild/action/node.py generate node.stub .deps/node.stub.pp .deps/node.stub.stub /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/main.development.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/main.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/vendors.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird_build/dist/bin/chrome/devtools/modules/devtools/client/debugger/src

/usr/bin/node /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/main.development.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/main.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/vendors.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird_build/dist/bin/chrome/devtools/modules/devtools/client/debugger/src
Comment 4 Petronio Coelho 2021-04-30 16:43:53 UTC
Attempting to run the last command manually with NODE_DEBUG results in the below. Like in the build, it doesn't exit.

# NODE_DEBUG=cluster,net,http,fs,tls,module,timers /usr/bin/node /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/main.development.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/main.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/vendors.js /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird_build/dist/bin/chrome/devtools/modules/devtools/client/debugger/src
MODULE 426877: looking for "/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build.js" in ["/root/.node_modules","/root/.node_libraries","/usr/lib/node"]
MODULE 426877: load "/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build.js" for module "."
MODULE 426877: Module._load REQUEST ./babel parent: .
MODULE 426877: RELATIVE: requested: ./babel from parent.id .
MODULE 426877: looking for ["/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build"]
MODULE 426877: load "/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/babel.js" for module "/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/babel.js"
MODULE 426877: Module._load REQUEST fs parent: .
MODULE 426877: load native module fs
MODULE 426877: Module._load REQUEST path parent: .
MODULE 426877: load native module path
MODULE 426877: Module._load REQUEST ./build-debugger parent: .
MODULE 426877: RELATIVE: requested: ./build-debugger from parent.id .
MODULE 426877: looking for ["/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build"]
MODULE 426877: load "/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build-debugger.js" for module "/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build-debugger.js"
MODULE 426877: Module._load REQUEST ./babel parent: /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build-debugger.js
MODULE 426877: Module._load REQUEST fs parent: /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build-debugger.js
MODULE 426877: load native module fs
MODULE 426877: Module._load REQUEST path parent: /var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build-debugger.js
MODULE 426877: load native module path
MODULE 426877: Module._load REQUEST ./build-debugger parent: .
MODULE 426877: Module._load REQUEST ./build-debugger parent: .
dep:/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/build.js
dep:/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/shared/build/babel.js
dep:/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/main.development.js
dep:/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/main.js
dep:/var/tmp/portage/mail-client/thunderbird-78.10.0/work/thunderbird-78.10.0/devtools/client/debugger/src/vendors.js
Comment 5 Thomas Deutschmann gentoo-dev Security 2021-05-01 00:36:15 UTC
I cannot reproduce. Please show us `emerge --info net-libs/nodejs`.
Comment 6 Petronio Coelho 2021-05-01 00:46:11 UTC
I'll try rebuilding nodejs-16 with more limited CFLAGS and re-try thunderbird after that to verify. I'll let you know.

emerge --info net-libs/nodejs
Portage 3.0.18 (python 3.9.4-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-11.1.0, glibc-2.33, 5.12.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.12.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-7700HQ_CPU_@_2.80GHz-with-glibc2.33
KiB Mem:    32720532 total,   9695536 free
KiB Swap:   16359420 total,  16359420 free
Timestamp of repository gentoo: Fri, 30 Apr 2021 21:41:06 +0000
Head commit of repository gentoo: 1b2445fa83ee4dc746f9540047e0077004ae2ad4

sh bash 5.1_p4
ld GNU ld (Gentoo 2.36.1 p3) 2.36.1
app-shells/bash:          5.1_p4::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.32.1::gentoo
dev-lang/python:          3.8.9::gentoo, 3.9.4::gentoo
dev-lang/rust:            1.51.0-r2::gentoo
dev-util/cmake:           3.20.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7-r2::gentoo
sys-apps/sandbox:         2.23::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.3-r1::gentoo
sys-devel/binutils:       2.36.1-r1::gentoo
sys-devel/gcc:            11.1.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo.git
    priority: -1000
    sync-git-verify-commit-signature: true

localrepo
    location: /usr/local/portage
    masters: gentoo

calculate
    location: /var/lib/layman/calculate
    masters: gentoo
    priority: 50

jorgicio
    location: /var/lib/layman/jorgicio
    masters: gentoo
    priority: 50

laurentb
    location: /var/lib/layman/laurentb
    masters: gentoo
    priority: 50

lto-overlay
    location: /var/lib/layman/lto-overlay
    masters: gentoo mv
    priority: 50

mv
    location: /var/lib/layman/mv
    masters: gentoo
    priority: 50

pentoo
    location: /var/lib/layman/pentoo
    masters: gentoo
    priority: 50

sakaki-tools
    location: /var/lib/layman/sakaki-tools
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 9 --load-average 8 --with-bdeps=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
FEATURES="assume-digests binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg cgroup clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync mount-sandbox multilib-strict network-sandbox news parallel-fetch parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms split-elog split-log strict strict-keepdir unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu -march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -flto=8 -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline"
LINGUAS="en"
MAKEOPTS="-j9 -l8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacs acl acpi alsa amd64 amr aom audit avif bcrypt bdplus berkdb blake2 bluetooth bluray branding brotli btrfs bzip2 cairo caps cdda cdr cli colord corefonts crypt cups curl custom-cflags daap dbus djvu dri dts dvb dvd dvdr dvi ed25519 emboss encode evo exif faad fam fdk ffmpeg filecaps firewalld flac fontconfig fontforge fortran fpx fuse gdbm gif gme gmp gnome gnome-keyring gnome-online-accounts gpm graphviz gsf gsm gstreamer gtk gtk3 gui hdri heif iconv icu idn inotify introspection iproute2 iptc ipv6 jbig jit jpeg jpeg2k lcms lensfun libaom libass libdrm libglvnd libidn2 libnotify libsecret libtirpc libva live lm_sensors lto lz4 lzma lzo mad matroska mms mng modplug mp3 mp4 mpeg mtp multilib musepack nautilus ncurses networkmanager nftables nls nptl oauth ogg openexr opengl openh264 openmp openssl opus orc pam pango pcre pdf pgo plymouth png policykit postscript ppds pulseaudio qt5 raw readline samba sctp sdl seccomp sftp sha3 shout smp speex spell split-usr srt ssl startup-notification svg sysprof system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-llvm system-zlib systemd t1lib taglib tcpd theora threads tiff tracker truetype udev udisks unicode unwind upnp upnp-av upower usb v4l vaapi vorbis vpx wavpack wayland webp wmf x264 x265 xattr xcb xcrypt xml xmp xpm xps xv xvid xxhash xz zeroconf zlib zsh-completion zstd zvbi" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="BPF WebAssembly" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_10 python3_9" PYTHON_TARGETS="python3_8 python3_10 python3_9" RUBY_TARGETS="ruby26 ruby27 ruby30" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS

=================================================================
                        Package Settings
=================================================================

net-libs/nodejs-16.0.0-r1::gentoo was built with the following:
USE="icu inspector lto npm snapshot ssl system-icu system-ssl -debug -doc -pax_kernel -systemtap -test" ABI_X86="(64)" CPU_FLAGS_X86="sse2"
CFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline -fno-finite-math-only -Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu"
CXXFLAGS="-march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline -fno-finite-math-only -Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu"
FEATURES="unknown-features-warn split-log network-sandbox parallel-fetch qa-unresolved-soname-deps xattr sandbox protect-owned cgroup userfetch unmerge-orphans ebuild-locks preserve-libs config-protect-if-modified unmerge-logs ipc-sandbox buildpkg userpriv binpkg-logs fixlafiles usersandbox split-elog mount-sandbox distlocks binpkg-multi-instance binpkg-dostrip strict clean-logs news multilib-strict pid-sandbox merge-sync sfperms parallel-install strict-keepdir usersync assume-digests"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu -march=native -pipe -O3 -fgraphite-identity -floop-nest-optimize -fdevirtualize-at-ltrans -fipa-pta -fno-semantic-interposition -fuse-linker-plugin -fno-plt -mtls-dialect=gnu2 -falign-functions=32 -flimit-function-alignment -malign-data=cacheline -fno-finite-math-only"
Comment 7 Thomas Deutschmann gentoo-dev Security 2021-05-01 00:59:49 UTC
You are using nodejs[lto] which I believe is broken, see bug 787158.

*** This bug has been marked as a duplicate of bug 787158 ***
Comment 8 Petronio Coelho 2021-05-01 01:03:25 UTC
(In reply to Thomas Deutschmann from comment #7)
> You are using nodejs[lto] which I believe is broken, see bug 787158.
> 
> *** This bug has been marked as a duplicate of bug 787158 ***

Ah, looks like I just barely missed that bug as I was working on writing this one. Sorry for the trouble.