Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 786687 - net-analyzer/tracebox-0.4.4-r100 - PacketModification.cc: error: reference to byte is ambiguous
Summary: net-analyzer/tracebox-0.4.4-r100 - PacketModification.cc: error: reference to...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 791943 (view as bug list)
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-04-29 07:25 UTC by Toralf Förster
Modified: 2021-08-01 19:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.92 KB, text/plain)
2021-04-29 07:25 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,317.31 KB, text/plain)
2021-04-29 07:25 UTC, Toralf Förster
Details
environment (environment,83.81 KB, text/plain)
2021-04-29 07:25 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,30.63 KB, application/x-bzip)
2021-04-29 07:25 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,11.42 KB, application/x-bzip)
2021-04-29 07:25 UTC, Toralf Förster
Details
net-analyzer:tracebox-0.4.4-r100:20210429-051431.log (net-analyzer:tracebox-0.4.4-r100:20210429-051431.log,18.70 KB, text/plain)
2021-04-29 07:25 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,140.72 KB, application/x-bzip)
2021-04-29 07:25 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-04-29 07:25:28 UTC
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../..  -I/usr/include/lua5.1    -fno-omit-frame-pointer -Wall    -pipe -march=native -fno-diagnostics-color  -O2 -c -o tracebox-PacketModification.o `test -f 'PacketModification.cc' || echo './'`PacketModification.cc
PacketModification.cc: In function ‘void ComputeDifferences(PacketModifications*, const Crafter::Layer*, const Crafter::Layer*)’:
PacketModification.cc:44:9: error: reference to ‘byte’ is ambiguous
   44 |         byte* this_layer = new byte[l1->GetSize()];
      |         ^~~~
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/include/g++-v11/bits/stl_algobase.h:61,
                 from /usr/lib/gcc/x86_64-pc-linux-gnu/11.1.0/include/g++-v11/algorithm:61,

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma-20210420-165442

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.1.0 *
clang version 12.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.0
Python 3.8.9
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.51.0
  [2]   rust-1.51.0 *
The Glorious Glasgow Haskell Compilation System, version 8.10.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed Apr 28 23:50:13 UTC 2021

emerge -qpvO net-analyzer/tracebox
[ebuild  N    ] net-analyzer/tracebox-0.4.4-r100  USE="curl -sniffer" LUA_SINGLE_TARGET="lua5-1 -lua5-2 -lua5-3 -lua5-4 -luajit"
Comment 1 Toralf Förster gentoo-dev 2021-04-29 07:25:30 UTC
Created attachment 703728 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-04-29 07:25:31 UTC
Created attachment 703731 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-04-29 07:25:33 UTC
Created attachment 703734 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-04-29 07:25:34 UTC
Created attachment 703737 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-04-29 07:25:35 UTC
Created attachment 703740 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-04-29 07:25:37 UTC
Created attachment 703743 [details]
net-analyzer:tracebox-0.4.4-r100:20210429-051431.log
Comment 7 Toralf Förster gentoo-dev 2021-04-29 07:25:38 UTC
Created attachment 703746 [details]
temp.tar.bz2
Comment 8 David Seifert gentoo-dev 2021-08-01 18:58:43 UTC
*** Bug 791943 has been marked as a duplicate of this bug. ***
Comment 9 Larry the Git Cow gentoo-dev 2021-08-01 19:29:02 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=96b03e9e2115af0468c8487cd488e2eb54f33397

commit 96b03e9e2115af0468c8487cd488e2eb54f33397
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2021-08-01 19:28:54 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2021-08-01 19:28:54 +0000

    net-analyzer/tracebox: Fix build with GCC 11
    
    Closes: https://bugs.gentoo.org/786687
    Signed-off-by: David Seifert <soap@gentoo.org>

 ...4-deps.patch => tracebox-0.4.4-autotools.patch} | 57 ++++++++++++++++++++++
 .../files/tracebox-0.4.4-include-crafter.patch     | 44 +++++++++++++++++
 net-analyzer/tracebox/tracebox-0.4.4-r100.ebuild   | 50 +++++++------------
 3 files changed, 119 insertions(+), 32 deletions(-)