Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 7866 - /scripts/bootstrap.sh and all emerges whereafter do not finish
Summary: /scripts/bootstrap.sh and all emerges whereafter do not finish
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 All
: High critical (vote)
Assignee: Ulf Bartelt (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-13 03:19 UTC by nathan.james.g
Modified: 2005-03-25 11:25 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nathan.james.g 2002-09-13 03:19:01 UTC
i follow the installation just fine until the "/scripts/bootstrap.sh."  which 
seems to run fine for a long time, but always exists saying something is wrong 
and then displays the following:

"!!!ERROR: The ebuild did not complete successfully
!!!Function src.compile, Line 7 Exitcode 1
!!!(no error message)"

The first time i came to this message i just thought it might be okay if i keep 
with the install.txt.  However the next two emerges fail saying something about 
the C++ compiler not working correctly and then the same message above 
(different line numbers and exitcodes).

This is the first time i have tried to install any linux-type environments 
(though i occationally use both unix and linux, so i kind of know what i am 
doing :).

Thank you, 
nathan.james.g
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2002-09-13 05:52:58 UTC
which architecture, and which stage tarball specifically were you using?
Comment 2 nathan.james.g 2002-09-13 15:21:17 UTC
sorry.  i was extremely tired when i wrote that.

gentoo-ix86-1.2.iso  it is a stage 1 tarball

basically i booted from the iso-cd and then openned the /install.txt and
followed that down, executing all the commands.  it seems to work fine up until
the "Code listing 19," the "/scripts/bootstrap.sh" will continue for a long
while and then then error message will come up.
Comment 3 Ulf Bartelt (RETIRED) gentoo-dev 2002-09-13 17:16:51 UTC
At the moment i really have no idea...

bootstrap.sh should (to my knowledge) not compile anything needing a c++
compiler.  if i remember it right, groff in the stage2->stage3 phase of the
install is the first build that needs c++.

I know the following stuff sounds hard: I need more info!  Which ebuilds failed?
 Can you redo that stuff and capture more of the output?  Maybe like:

scripts/bootstrap.sh 2>&1 | tee /tmp/my.log
Comment 4 ganfset 2002-09-13 19:48:28 UTC
I've a similar bug with stage1 of 1.4_rc1_20020908-1208 : 
c++ not being compiled in bootstrap

Error is found in "emerge system" while compiling sys-lis/db-3.2.9-r1 :

checking for c++... no
checking for g++... no
checking for gcc... gcc
checking whether the C++ compiler (gcc -O2 -mcpu=i686 -pipe ) works... no
configure: error: installation or configuration problem: C++ compiler cannot
create executables.

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 8, Exitcode 1
!!! (no error message)


My system is an athlon, my USE in make.conf are :
"3dnow aalib alsa artsavi berkdb bonobo cdr crypt cups dga directfb doc dvd
encode esd evo fbcon flash gb gd gdbm ggi gif gnome gnome-libs gpm gtk gtk2
gtkhtml imap imlib innodb java jpeg kde lcms ldap libg++ libgda libwww maildir
mmx motif mozilla mpeg mysql nas ncurses nls oggvorbis opengl oss pam pdflib
perl plotutils png pnp postgres python qt qtmt quicktime readline samba sasl
scanner sdl slp snmp socks5 spell sse ssl svga tcltk tcpd tetex tiff truetype X
xml xml2 xmms xv zlib"
(I know too much thing but it's for test)

My /var/db/pkg/sys-devel/gcc-3.2-r1/USE contains only : "build bootstrap"

c++ is not present in the system after boostrap
Comment 5 nathan.james.g 2002-09-14 18:15:56 UTC
totally sorry to waste everyone's time,
though thank you for the help.
the problem was in the make.conf i did not
set it up proberly <feels extremely silly>
everything seems to work fine now.
Comment 6 Ulf Bartelt (RETIRED) gentoo-dev 2002-09-14 18:25:42 UTC
...to comment #5:

Fine!

Could you please describe what was the reason?  We are looking for a maybe
similar problem other users have seen too in 1.2 and 1.4_rc1.  Perhaps it is a
comparable misconfiguration, then the docs need to be clearer or if not, your
description will help to border the different things from another...

Thanks!
Comment 7 nathan.james.g 2002-09-16 13:54:06 UTC
sorry, i did not mean to be so vague on purpose.
the first time i tried to run the bootstrap i did not
edit "make.conf".  i looked at it but was unsure of
how it worked.  which meant that the bootstrap did
not ever compile .. uh.. whatever it compiles.  and
i think it compiles to installs (sorry i do not know
a whole lot about the process) the c++ compiler, which
means that the next to emerges will complete 
successfully.

then i setup the make.conf to use my k6 processor
(deleted the #'s infront of three lines, and i 
think that is all i did) and everything worked
after that.

that is all i know, currently.  i hope that
helps anyone.  if anyone has questions just
post a question and i will be glad to help

~nathan.james.g
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2005-03-25 11:25:05 UTC
Moving these so we can remove the "Install CD" component from "Gentoo Linux".

I apologize to everyone for this spam, but according to the bugzilla developers,
this is the only reasonable way to do this.