Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 786540 - gnome-base/nautilus-40.0 fails to build (error: passing 'typeof (*(&gtype_id)) *' (aka 'volatile unsigned long *') to parameter of type 'gsize *' (aka 'unsigned long *') discards qualifiers [-Werror,-Wincompatible-pointer-types-discards-qualifiers])
Summary: gnome-base/nautilus-40.0 fails to build (error: passing 'typeof (*(&gtype_id)...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-04-28 19:44 UTC by Alexander Julian Moch
Modified: 2021-05-27 03:22 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,60.85 KB, text/x-log)
2021-04-28 19:45 UTC, Alexander Julian Moch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Julian Moch 2021-04-28 19:44:13 UTC
When I try to build gnome-base/nautilus-40.0, the process exits with the following error:

libnautilus-extension/nautilus-extension-enum-types.c:22:7: error: passing 'typeof (*(&gtype_id)) *' (aka 'volatile unsigned long *') to parameter of type 'gsize *' (aka 'unsigned long *') discards qualifiers [-Werror,-Wincompatible-pointer-types-discards-qualifiers]
  if (g_once_init_enter (&gtype_id)) {
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/include/glib-2.0/glib/gthread.h:260:7: note: expanded from macro 'g_once_init_enter'
    (!g_atomic_pointer_get (location) &&                             \
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/include/glib-2.0/glib/gatomic.h:117:38: note: expanded from macro 'g_atomic_pointer_get'
    __atomic_load (gapg_temp_atomic, &gapg_temp_newval, __ATOMIC_SEQ_CST); \
                                     ^~~~~~~~~~~~~~~~~
1 error generated.

Reproducible: Always




> emerge --info
Portage 3.0.18 (python 3.8.8-final-0, default/linux/amd64/17.1/no-multilib, gcc-11.1.0, glibc-2.33, 5.12.0 x86_64)
=================================================================
System uname: Linux-5.12.0-x86_64-Intel-R-_Core-TM-_i5-6600_CPU_@_3.30GHz-with-glibc2.2.5
KiB Mem:    32762876 total,  28234056 free
KiB Swap:   12462260 total,  12462260 free
Timestamp of repository gentoo: Wed, 28 Apr 2021 19:00:01 +0000
Head commit of repository gentoo: 4522a2e970ce5a45d8f59202662b925ccf1fede0
Timestamp of repository dotnet: Tue, 27 Apr 2021 21:50:05 +0000
Head commit of repository dotnet: 22c6957abc50b6419aa2a422683c007309e320c5

sh bash 5.1_p4
ld GNU gold (Gentoo 2.36.1 p3 2.36.1) 1.16
ccache version 4.2.1 [enabled]
app-shells/bash:          5.1_p4::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.32.1::gentoo
dev-lang/python:          2.7.18_p8::gentoo, 3.8.8_p1::gentoo, 3.9.2_p1::gentoo
dev-lang/rust:            1.51.0-r2::gentoo
dev-util/ccache:          4.2.1::gentoo
dev-util/cmake:           3.20.1::gentoo
sys-apps/baselayout:      2.7-r2::gentoo
sys-apps/openrc:          0.42.1-r1::gentoo
sys-apps/sandbox:         2.23::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.3-r1::gentoo
sys-devel/binutils:       2.36.1-r1::gentoo
sys-devel/gcc:            11.1.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24

ajm
    location: /var/db/repos/ajm
    masters: gentoo

dotnet
    location: /var/db/repos/dotnet
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/dotnet.git
    masters: gentoo

Installed sets: @baseDesktop, @baseSystem, @commandLine, @llvmProject, @miscellaneous, @netTools, @progLangs, @typeFaces, @virtualMachines
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CC="clang"
CFLAGS="-march=native -O3 -pipe -flto"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXX="clang++"
CXXFLAGS="-march=native -O3 -pipe -flto"
DISTDIR="/zdata/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O3 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O3 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org https://ftp.fau.de/gentoo/ https://gentoo.mirror.garr.it/ https://mirror.leaseweb.com/gentoo/ https://mirror.netcologne.de/gentoo/ https://ftp.halifax.rwth-aachen.de/gentoo/ https://ftp.snt.utwente.nl/pub/os/linux/gentoo/ https://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O3 -Wl,--as-needed -fuse-ld=lld"
MAKEOPTS="-j5"
PKGDIR="/zdata/portage/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
RUSTFLAGS="-C target-cpu=native"
USE="acl amd64 berkdb bzip2 clang cli crypt dri elogind fortran gdbm gold iconv ipv6 libglvnd libtirpc lto ncurses nls nptl openmp pam pcre readline seccomp split-usr ssl tcpd threads unicode wayland xattr zlib zstd" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en_US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="AMDGPU BPF X86" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="amdgpu radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexander Julian Moch 2021-04-28 19:45:25 UTC
Created attachment 703467 [details]
build.log
Comment 2 Alexandra Parker 2021-04-28 21:43:29 UTC
I think this is because Meson actually has glib-mkenums templates built in that have the volatile keyword, e.g.:

/usr/lib/python3.9/site-packages/mesonbuild/modules/gnome.py
Comment 3 Alexandra Parker 2021-04-28 21:48:36 UTC
Ah, this was fixed in Meson 0.58:

https://github.com/mesonbuild/meson/commit/42ba8efaf220bceca7850f2ffe0d84ee426f7b34
Comment 4 Sam James archtester gentoo-dev Security 2021-04-28 21:50:55 UTC
(In reply to Alex Parker from comment #3)
> Ah, this was fixed in Meson 0.58:
> 
> https://github.com/mesonbuild/meson/commit/
> 42ba8efaf220bceca7850f2ffe0d84ee426f7b34

CCing meson maintainers.
Comment 5 Sam James archtester gentoo-dev Security 2021-04-28 21:51:58 UTC
(In reply to Sam James from comment #4)
> (In reply to Alex Parker from comment #3)
> > Ah, this was fixed in Meson 0.58:
> > 
> > https://github.com/mesonbuild/meson/commit/
> > 42ba8efaf220bceca7850f2ffe0d84ee426f7b34
> 
> CCing meson maintainers.

(Note that it's fixed in 0.57.0.)
Comment 6 penguinolog 2021-04-29 09:12:31 UTC
Not reproduced with meson 0.57.2
Comment 7 Alexander Julian Moch 2021-04-29 10:04:09 UTC
I can confirm the bump to meson-0.57.2 fixes the build issues with nautilus and gtksourceview.
Comment 8 Geoff Leach 2021-04-29 17:05:36 UTC
Also confirming  meson-0.57.2 builds gtksourceview-4.6.1 and nautilus-0.40.
Comment 9 Jack 2021-05-01 23:21:23 UTC
Where are you getting meson 0.57.2?  0.56.2 is the latest I see in portage, other then 9999.
Comment 10 Alexandra Parker 2021-05-02 00:58:24 UTC
(In reply to Jack from comment #9)
> Where are you getting meson 0.57.2?  0.56.2 is the latest I see in portage,
> other then 9999.

i bumped meson in my local overlay
Comment 11 Larry the Git Cow gentoo-dev 2021-05-03 16:11:31 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cbde2c4fa6503964ce55b01fca31e67ce4e3b58c

commit cbde2c4fa6503964ce55b01fca31e67ce4e3b58c
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2021-05-03 16:09:01 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2021-05-03 16:11:25 +0000

    gnome-base/nautilus: require >=dev-util/meson-0.57.2
    
    Closes: https://bugs.gentoo.org/786540
    Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>

 gnome-base/nautilus/nautilus-40.0.ebuild | 1 +
 gnome-base/nautilus/nautilus-40.1.ebuild | 1 +
 2 files changed, 2 insertions(+)