Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 786447 - app-editors/scite-5.1.1 stabilization
Summary: app-editors/scite-5.1.1 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ervin Peters
URL:
Whiteboard: was: app-editors/scite-4.4.4-r10 - /....
Keywords: CC-ARCHES
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-04-28 13:14 UTC by Toralf Förster
Modified: 2021-10-09 16:35 UTC (History)
5 users (show)

See Also:
Package list:
app-editors/scite-5.1.1
Runtime testing required: ---
nattka: sanity-check+


Attachments
emerge-info.txt (emerge-info.txt,17.92 KB, text/plain)
2021-04-28 13:14 UTC, Toralf Förster
no flags Details
app-editors:scite-4.4.4-r10:20210428-112744.log (app-editors:scite-4.4.4-r10:20210428-112744.log,38.01 KB, text/plain)
2021-04-28 13:14 UTC, Toralf Förster
no flags Details
emerge-history.txt (emerge-history.txt,292.92 KB, text/plain)
2021-04-28 13:14 UTC, Toralf Förster
no flags Details
environment (environment,71.86 KB, text/plain)
2021-04-28 13:14 UTC, Toralf Förster
no flags Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,30.42 KB, application/x-bzip)
2021-04-28 13:14 UTC, Toralf Förster
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-04-28 13:14:07 UTC
                 from ScintillaGTKAccessible.cxx:68:
ScintillaGTKAccessible.cxx: In function ‘GType scintilla_object_accessible_get_type(GType)’:
/usr/include/glib-2.0/glib/gatomic.h:117:19: error: argument 2 of ‘__atomic_load’ must not be a pointer to a ‘volatile’ type
  117 |     __atomic_load (gapg_temp_atomic, &gapg_temp_newval, __ATOMIC_SEQ_CST); \
      |     ~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/usr/include/glib-2.0/glib/gthread.h:260:7: note: in expansion of macro ‘g_atomic_pointer_get’
  260 |     (!g_atomic_pointer_get (location) &&                             \

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma-20210420-165442

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-10.3.0
 [2] x86_64-pc-linux-gnu-11.1.0 *
clang version 12.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/12/bin
/usr/lib/llvm/12
12.0.0
Python 3.8.9
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.51.0
  [2]   rust-1.51.0 *
The Glorious Glasgow Haskell Compilation System, version 8.10.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Wed Apr 28 10:50:12 UTC 2021

emerge -qpvO app-editors/scite
[ebuild  N    ] app-editors/scite-4.4.4-r10  USE="-lua" LUA_SINGLE_TARGET="lua5-1"
Comment 1 Toralf Förster gentoo-dev 2021-04-28 13:14:08 UTC
Created attachment 703239 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-04-28 13:14:10 UTC
Created attachment 703242 [details]
app-editors:scite-4.4.4-r10:20210428-112744.log
Comment 3 Toralf Förster gentoo-dev 2021-04-28 13:14:11 UTC
Created attachment 703245 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2021-04-28 13:14:13 UTC
Created attachment 703248 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2021-04-28 13:14:14 UTC
Created attachment 703251 [details]
etc.portage.tar.bz2
Comment 6 Ionen Wolkens gentoo-dev 2021-04-28 22:05:01 UTC
(these need both gcc11 and glib-2.68 to reproduce, see bug #769533 for a similar issue)
Comment 7 Sam James archtester gentoo-dev Security 2021-07-29 02:16:31 UTC
ping Ervin?
Comment 8 Sam James archtester gentoo-dev Security 2021-09-02 23:05:09 UTC
ping
Comment 9 Ervin Peters 2021-09-04 06:44:46 UTC
pong.
also CONFIRMED with gcc-11.2.0 
I work on an update to current scite-5.1.1.
Comment 10 Ervin Peters 2021-09-04 07:29:56 UTC
scite-5.1.1 does not have this issue. See PR#22211

Since gcc-11 is ~ARCH I suggest to switch to scite-5.1.1 and I will myself schedule a stable request on the begin of oct.
Comment 11 Larry the Git Cow gentoo-dev 2021-09-10 07:22:33 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=944c2547a0ac1729be6ecdf9d1af0e2d09cce038

commit 944c2547a0ac1729be6ecdf9d1af0e2d09cce038
Author:     Ervin Peters <coder@ervnet.de>
AuthorDate: 2021-09-04 07:15:31 +0000
Commit:     Joonas Niilola <juippis@gentoo.org>
CommitDate: 2021-09-10 07:22:23 +0000

    app-editors/scite: version bump to 5.1.1
    
    Upstream Bugfixes extracted lexer lib,
    compatible with gcc-11 (bug #786447)
    
    Bug: https://bugs.gentoo.org/786447
    Signed-off-by: Ervin Peters <coder@ervnet.de>
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Closes: https://github.com/gentoo/gentoo/pull/22211
    Signed-off-by: Joonas Niilola <juippis@gentoo.org>

 app-editors/scite/Manifest           |   1 +
 app-editors/scite/scite-5.1.1.ebuild | 124 +++++++++++++++++++++++++++++++++++
 2 files changed, 125 insertions(+)
Comment 12 Andreas K. Hüttel archtester gentoo-dev 2021-09-18 20:08:44 UTC
Can 5.1.1 be stabilized now? Please cc arches if yes.
Comment 13 Ervin Peters 2021-09-19 17:42:34 UTC
(In reply to Andreas K. Hüttel from comment #12)
> Can 5.1.1 be stabilized now? Please cc arches if yes.

I've nothing serious against it except the 30 days rule.

cc'd arches: please stabilize app-editors/scite-5.1.1

Thanks
Comment 14 Sam James archtester gentoo-dev Security 2021-09-19 22:10:24 UTC
x86 done
Comment 15 Sam James archtester gentoo-dev Security 2021-09-19 22:11:12 UTC
amd64 done
Comment 16 Sam James archtester gentoo-dev Security 2021-09-21 16:35:02 UTC
ppc done

all arches done