Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 783927 - app-i18n/canna-3.7_p3-r3, app-i18n/im-freewnn-0.0.2-r3: stabilisation and cleanup old
Summary: app-i18n/canna-3.7_p3-r3, app-i18n/im-freewnn-0.0.2-r3: stabilisation and cle...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: CJK Team
URL:
Whiteboard:
Keywords: CC-ARCHES, STABLEREQ
Depends on:
Blocks:
 
Reported: 2021-04-18 22:01 UTC by Andreas Sturmlechner
Modified: 2021-04-26 10:34 UTC (History)
2 users (show)

See Also:
Package list:
app-i18n/canna-3.7_p3-r3 dev-libs/libspt-1.1-r4 app-i18n/im-freewnn-0.0.2-r3 amd64 ppc ppc64 x86
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2021-04-18 22:01:34 UTC
app-i18n/im-canna-0.3.2.2-r1 added in commit 67718a84fd0403c2b36fe8225302dcbfead1de57 sounds like an important fix.

app-i18n/im-freewnn-0.0.2-r3 added in commit c8186106910e089a73288876cca11b5c41787782 sounds like an important fix.

Both weren't stabilised after almost 4 years.

Various fixes were made to all app-i18n/canna revisions in place, but why not stabilise once in a while? The latest revisions of these ebuilds certainly have served their time in ~arch long enough, unless there is a reason for avoiding stabilisations that I am missing?

EAPI-7 bumps and getting rid of ltprune would be nice.
Comment 1 NATTkA bot gentoo-dev 2021-04-18 22:04:28 UTC Comment hidden (obsolete)
Comment 2 NATTkA bot gentoo-dev 2021-04-18 22:08:28 UTC Comment hidden (obsolete)
Comment 3 NATTkA bot gentoo-dev 2021-04-19 22:44:22 UTC Comment hidden (obsolete)
Comment 4 Alessandro Barbieri 2021-04-19 23:44:03 UTC
There is still this bug https://bugs.gentoo.org/675888
Comment 5 Ionen Wolkens gentoo-dev 2021-04-20 00:25:11 UTC
(In reply to Alessandro Barbieri from comment #4)
> There is still this bug https://bugs.gentoo.org/675888
I had a look at this package while working on imake stuff and wasn't able to reproduce that, do you mean it happens for you? If so, does current stable work or fails as well?

"env gcc" is its own issue (there's multi-layered toolchain issues with this package), but as far as I know should build fine in a standard environment
Comment 6 Alessandro Barbieri 2021-04-20 02:19:46 UTC
ok, I'll investigate because it build (-r3) on my test chroot
Comment 7 Rolf Eike Beer archtester 2021-04-20 17:17:55 UTC
sparc stable
Comment 8 Sam James archtester gentoo-dev Security 2021-04-20 23:29:28 UTC
arm64 done
Comment 9 Sam James archtester gentoo-dev Security 2021-04-21 18:52:35 UTC
amd64 done
Comment 10 Sam James archtester gentoo-dev Security 2021-04-22 12:15:17 UTC
ppc64 done
Comment 11 Sam James archtester gentoo-dev Security 2021-04-22 12:16:51 UTC
ppc done
Comment 12 Sam James archtester gentoo-dev Security 2021-04-26 10:34:27 UTC
x86 done

all arches done