Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 782106 - www-client/chromium-91.0.4469.4: emerge conflict with glibc-2.33
Summary: www-client/chromium-91.0.4469.4: emerge conflict with glibc-2.33
Status: RESOLVED DUPLICATE of bug 769989
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-11 13:31 UTC by Jan Baklo
Modified: 2021-04-11 14:07 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Baklo 2021-04-11 13:31:48 UTC
time emerge -a --update --newuse --deep --with-bdeps=y @world

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] sys-libs/glibc-2.32-r8 [2.33]
[ebuild     U #] www-client/chromium-91.0.4469.4 [91.0.4464.5]

Would you like to merge these packages? [Yes/No] 

>>> Verifying ebuild manifests

>>> Running pre-merge checks for sys-libs/glibc-2.32-r8
 * Checking general environment sanity.
 * Sanity check to keep you from breaking your system:
 *  Downgrading glibc is not supported and a sure way to destruction.
 * ERROR: sys-libs/glibc-2.32-r8::gentoo failed (pretend phase):
 *   Aborting to save your system.
 * 
 * Call stack:
 *              ebuild.sh, line 125:  Called pkg_pretend
 *   glibc-2.32-r8.ebuild, line 733:  Called sanity_prechecks
 *   glibc-2.32-r8.ebuild, line 619:  Called die
 * The specific snippet of code:
 *   			[[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
 * 
 * If you need support, post the output of `emerge --info '=sys-libs/glibc-2.32-r8::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-2.32-r8::gentoo'`.
 * The complete build log is located at '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/temp/build.log'.
 * The ebuild environment file is located at '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/temp/die.env'.
 * Working directory: '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/homedir'
 * S: '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/work/glibc-2.32'

>>> Failed to emerge sys-libs/glibc-2.32-r8, Log file:

>>>  '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/temp/build.log'

>>> Running pre-merge checks for www-client/chromium-91.0.4469.4
 * Checking for at least 3 GiB RAM ...                                                                                               [ ok ]
 * Checking for at least 8 GiB disk space at "/mnt/system/tmp/portage/www-client/chromium-91.0.4469.4/temp" ...                      [ ok ]

 * Messages for package sys-libs/glibc-2.32-r8:

 * Sanity check to keep you from breaking your system:
 *  Downgrading glibc is not supported and a sure way to destruction.
 * ERROR: sys-libs/glibc-2.32-r8::gentoo failed (pretend phase):
 *   Aborting to save your system.
 * 
 * Call stack:
 *              ebuild.sh, line 125:  Called pkg_pretend
 *   glibc-2.32-r8.ebuild, line 733:  Called sanity_prechecks
 *   glibc-2.32-r8.ebuild, line 619:  Called die
 * The specific snippet of code:
 *   			[[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
 * 
 * If you need support, post the output of `emerge --info '=sys-libs/glibc-2.32-r8::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/glibc-2.32-r8::gentoo'`.
 * The complete build log is located at '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/temp/build.log'.
 * The ebuild environment file is located at '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/temp/die.env'.
 * Working directory: '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/homedir'
 * S: '/mnt/system/tmp/portage/sys-libs/glibc-2.32-r8/work/glibc-2.32'
Task was destroyed but it is pending!
task: <Task pending name='Task-3' coro=<PipeLogger._io_loop() running at /usr/lib/python3.9/site-packages/portage/util/_async/PipeLogger.py:78> wait_for=<Future pending cb=[<TaskWakeupMethWrapper object at 0x7f3f30c42820>()]> cb=[PipeLogger._io_loop_done()]>
Task was destroyed but it is pending!
task: <Task pending name='Task-2' coro=<BuildLogger._main() running at /usr/lib/python3.9/site-packages/portage/util/_async/BuildLogger.py:86> wait_for=<Future pending cb=[AsynchronousTask.async_wait.<locals>.<lambda>() at /usr/lib/python3.9/site-packages/_emerge/AsynchronousTask.py:42, <TaskWakeupMethWrapper object at 0x7f3f2f1f4670>()]> cb=[BuildLogger._main_exit()]>
Task was destroyed but it is pending!
task: <Task pending name='Task-1' coro=<PipeLogger._io_loop() running at /usr/lib/python3.9/site-packages/portage/util/_async/PipeLogger.py:78> wait_for=<Future pending cb=[<TaskWakeupMethWrapper object at 0x7f3f2f1f4e80>()]> cb=[PipeLogger._io_loop_done()]>


Reproducible: Always
Comment 1 Jonas Stein gentoo-dev 2021-04-11 13:41:17 UTC
Thank you for the report. We need to have all information at hand before ticket assignment. That is why I ask you to 
* attach the logs and 
* paste the emerge info 
as described on https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket

Please reopen this ticket (Status:UNCONFIRMED) afterwards.
Comment 2 Ionen Wolkens gentoo-dev 2021-04-11 13:59:23 UTC
chromium with glibc-2.33 currently result in bug #769989 and the version limitation was temporarily added to stop people that use chromium from upgrading glibc (not to make people downgrade, don't do that). There's a patch but upstream has expressed that the patch is incomplete so the issue been dragging a bit.
Comment 3 Sam James archtester gentoo-dev Security 2021-04-11 14:07:05 UTC

*** This bug has been marked as a duplicate of bug 769989 ***