Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 779973 - games-board/xscrabble-2.10-r3: calls LD and co directly
Summary: games-board/xscrabble-2.10-r3: calls LD and co directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2021-04-04 11:01 UTC by Agostino Sarubbo
Modified: 2021-04-15 06:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.49 KB, text/plain)
2021-04-04 11:01 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-04-04 11:01:00 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: games-board/xscrabble-2.10-r3 fails to compile.
Discovered on: amd64 (internal ref: ci)
Comment 1 Agostino Sarubbo gentoo-dev 2021-04-04 11:01:02 UTC
Created attachment 697149 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-04-04 11:01:03 UTC
Possible context of error(s):

sh: line 1: ld: command not found
imake: No such file or directory
/usr/bin/install: cannot stat 'src/xscrab': No such file or directory
install-xattr: failed to stat src/xscrab: No such file or directory
/usr/bin/install: cannot stat 'src/xscrabble': No such file or directory
install-xattr: failed to stat src/xscrabble: No such file or directory
chmod: cannot access '/var/tmp/portage/games-board/xscrabble-2.10-r3/image/usr/bin/xscrabble': No such file or directory
 * QA Notice: command not found:
 * 	sh: line 1: ld: command not found
Comment 3 Larry the Git Cow gentoo-dev 2021-04-07 08:11:41 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=553481e83cc750fa0af9ff1a2f15ecfd9090491a

commit 553481e83cc750fa0af9ff1a2f15ecfd9090491a
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-04-07 07:34:57 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-04-07 08:10:33 +0000

    games-board/xscrabble: fix Prefix install, respect AR and RANLIB
    
    Not yet figured out LD, though.
    
    Bug: https://bugs.gentoo.org/779973
    Signed-off-by: Sam James <sam@gentoo.org>

 games-board/xscrabble/xscrabble-2.10-r3.ebuild | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)
Comment 4 Sam James archtester gentoo-dev Security 2021-04-10 08:35:04 UTC

*** This bug has been marked as a duplicate of bug 729630 ***
Comment 5 Larry the Git Cow gentoo-dev 2021-04-15 06:39:24 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3c8913d7268e8dd1d33b1126963108f476eb6b2e

commit 3c8913d7268e8dd1d33b1126963108f476eb6b2e
Author:     Ionen Wolkens <sudinave@gmail.com>
AuthorDate: 2021-04-14 09:38:33 +0000
Commit:     Joonas Niilola <juippis@gentoo.org>
CommitDate: 2021-04-15 06:38:52 +0000

    games-board/xscrabble: fix build with -native-symlinks
    
    Closes: https://bugs.gentoo.org/779973
    Signed-off-by: Ionen Wolkens <sudinave@gmail.com>
    Signed-off-by: Joonas Niilola <juippis@gentoo.org>

 games-board/xscrabble/xscrabble-2.10-r3.ebuild | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)