Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77936 - openoffice-ximian segment fault on "setup"
Summary: openoffice-ximian segment fault on "setup"
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: Sparc Linux
: High major (vote)
Assignee: Gentoo Office Team
Depends on:
Reported: 2005-01-13 22:09 UTC by Zhang Weiwu
Modified: 2005-11-20 16:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Zhang Weiwu 2005-01-13 22:09:49 UTC
This openoffice is keyword-masked stable on sparc

Emerge success, after emerge, run any of openoffice application (like xoofice) will get segment fault.

Not sure if it is openoffice bug or gentoo bug.

Reproducible: Always
Steps to Reproduce:
1. emerge openoffice-ximian (successful on my UltraSparc2)
2. xooffice
3. you see the error message

Actual Results:  

/home/zhangweiwu> xooffice
Gnome session manager detected - session management disabled
running setup...
/usr/bin/xooffice: line 172:  2566 Segment Fault       
/opt/Ximian-OpenOffice/program/setup ${UPDATEFLAG}
-R:/etc/ximian-openoffice/autoresponse-1.1.2.conf >&/dev/null
setup failed.. abort
Comment 1 Andreas Proschofsky (RETIRED) gentoo-dev 2005-01-14 06:49:40 UTC
Could you please check if this could be your problem:
Comment 2 Zhang Weiwu 2005-01-14 07:10:12 UTC
Andreas, I think, perhaps not. 

I am using dev-java/blackdown-jdk-1.4.1-r1 which is an earlier version than the one mensioned "working correctly" in #73083

The bug could be because of JDK, only I don't know how to make sure of it. I can hardly replace it with another JDK, I am on sparc, AFAIK blackdown-jdk is the only one. 

Do you suggest me emerge an older version and try again? 
Comment 3 Andreas Proschofsky (RETIRED) gentoo-dev 2005-01-15 10:29:05 UTC
No, blackdown should be fine. Could you try the advice in the bug I mentioned and see if the java path in


is the correct one for your system?
Comment 4 Gustavo Zacarias (RETIRED) gentoo-dev 2005-01-17 05:20:27 UTC
I recently committed regular openoffice-1.1.4 & openoffice-ximian-1.3.7 to ~sparc.
They built just fine for me with java enabled, can you give one of those a spin?
Also please post your emerge --info since, for example, ~sparc glibc is known to break blackdown-jdk.
Comment 5 Zhang Weiwu 2005-01-17 07:25:19 UTC
Thank you for your suggestion Gustavo Zacarias. It will take me several days to emerge your version of openoffice, so I prefer first re-compile glibc (the same verison. I cannot recall if I compiled glibc- with ~sparc, so I now re-emerge it without ~sparc), and try other people's suggestion, adjust jdk and so like. If all fails, I'll try your 1.3.7;)
Comment 6 Gustavo Zacarias (RETIRED) gentoo-dev 2005-01-17 07:49:13 UTC
Basically glibc-2.3.4* is broken for blackdown on sparc, if you have glibc- you don't need to re-emerge it.
I have quickpkg'ed my openoffice builds if you wanna try those for a quick spin.
Comment 7 Zhang Weiwu 2005-01-17 18:06:07 UTC
Cool, Gustavo. The question is how do I get the package? By p2p or can you give me / mail me a link?

Thank you. By the way, this morning I came back to the office and emerge glibc is finished, but bug is there still. 
Comment 8 Gustavo Zacarias (RETIRED) gentoo-dev 2005-01-18 05:10:53 UTC
Download and place the one you want into /usr/portage/packages/All and use emerge -k.
Comment 9 Zhang Weiwu 2005-01-18 08:39:16 UTC
I prefer to emerge openoffice-ximian from source. I started to do it now, the result will be out the day after tomorrow. 

Because I am running gnome, emerge kde-env and kde-libs takes time too. 
Comment 10 Zhang Weiwu 2005-01-20 16:41:21 UTC
I emerged your ~sparc xoo but now it failed with exactly the same error message. 

Andreas: I checked but this file on my box


Does not refer to anything like black-down, so I don't know how to follow your suggestion in 73083

Here is my javarc


Comment 11 Andreas Proschofsky (RETIRED) gentoo-dev 2005-01-20 16:50:01 UTC
Another possible reason for setup crashing is a problem with one your fonts
Comment 12 Zhang Weiwu 2005-01-20 19:45:46 UTC
I think perhaps it's not a font problem. I only have one font that is not in Gentoo port tree (actually, I never emerged a font). And I removed that font and openoffice still crash. 

All my fonts are very common. 
Comment 13 Andreas Proschofsky (RETIRED) gentoo-dev 2005-01-23 23:51:00 UTC
Another idea: Do you have a mounted /proc filesystem?
Comment 14 Zhang Weiwu 2005-01-24 00:37:28 UTC
Yes I have. 

Currently I am adjusting CFLAGS and trying differen options (like -java and -O1). Each trial will take several days, and it's very close to Chinese new year, too many things to sort out, I would be very slow. However I will keep putting up my trial result in this bug tracker. 
Comment 15 Andreas Proschofsky (RETIRED) gentoo-dev 2005-01-31 01:31:51 UTC
There is nothing we can do without more info, please reopen if you get it again.
Comment 16 Zhang Weiwu 2005-02-18 04:28:27 UTC
I failed again. Error message attached. However, I am stupid enough to find that after compiled several days, that I am only compiling 1.3.5-r1 rather than expected 1.3.7 for wrong ACCEPT_KEYWORDS. 

I don't have much faith in try it again. I think I should just close this bug and install the binary Gustavo Zacarias provided. In case I need to compile it again and have problem again, I will reopen this bug to report further information?
Comment 17 Gustavo Zacarias (RETIRED) gentoo-dev 2005-02-18 04:47:40 UTC
We are up to openoffice-ximian-1.3.8 in ~sparc starting yesterday night.
I just finished uploading the quickpkg.
Note that this one is built with mostly everything on, so it'll probably pull gnome & kde.
Comment 18 Zhang Weiwu 2005-02-18 16:57:14 UTC
Today I installed the pkg 1.3.7 you provided with URI, and again, it crashed with segment fault. 

I hope I am the only one who has this problem. Is it my system has some problem or triggered a hidden bug? 
Comment 19 Gustavo Zacarias (RETIRED) gentoo-dev 2005-02-23 18:01:37 UTC
Are you using some locale/LINGUAS different than the default?
Just curious, i just use english and haven't had any problems.
Comment 20 Zhang Weiwu 2005-02-23 18:34:34 UTC
You are right I guess! I login as root where root LOCAL is set to en_US, and openoffice launched successfully. 

Currently I am using zh_CN.UTF-8
/home/zhangweiwu> locale

Any further suggestions? I must use zh_CN and I already have tone of file and documents in UTF-8, so I dislike to move to zh_CN.GB18030 or other locale. 

And I heard some people are using zh_CN in UTF-8 under the zh_CN.EUC locale. Not sure if it's true. 
Comment 21 Zhang Weiwu 2005-02-23 18:47:05 UTC
Nope. I failed again. With segment falult

It seems only root can run xopenoffice. I currently run openoffice fine with a sudo to root. Run xopenoffice in any other users, even if locale is English, it fail with segment fault. 

this doesn't work and still produce seg fault.
mv -r /root/.xopenoffice /root/.xversionrc /home/zhangweiwu
Comment 22 Andreas Proschofsky (RETIRED) gentoo-dev 2005-11-01 14:13:17 UTC
As openoffice-2.0.0 is now marked ~sparc could you please try with this and
report back if it works now, should generally go a lot better than older versions
Comment 23 Andreas Proschofsky (RETIRED) gentoo-dev 2005-11-20 12:03:27 UTC
Shouldn't be a problem anymore with 2.0.0, also would need some feedback,
otherwise there is nothing we can do
Comment 24 Zhang Weiwu 2005-11-20 16:39:22 UTC
The bug should be closed because I only meet this bug on sparc with 1.x but now
my sparc is broken and I don't use 1.x anymore, thus not being able to reproduce
this bug.