Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 779196 - dev-php/awl-0.62 fails tests with php8.0
Summary: dev-php/awl-0.62 fails tests with php8.0
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Till Schäfer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-30 06:25 UTC by Agostino Sarubbo
Modified: 2024-06-30 19:03 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,9.21 KB, text/plain)
2021-03-30 06:25 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-03-30 06:25:44 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-php/awl-0.62 fails tests.
Discovered on: amd64 (internal ref: ci)
Comment 1 Agostino Sarubbo gentoo-dev 2021-03-30 06:25:46 UTC
Created attachment 696147 [details]
build.log

build log and emerge --info
Comment 2 Thomas Deutschmann (RETIRED) gentoo-dev 2021-03-30 12:19:23 UTC
It's only failing with php8.0:

> 1) myCalendarTest::test2
> TypeError: implode(): Argument #2 ($array) must be of type ?array, string given
> 
> /var/tmp/portage/dev-php/awl-0.62/work/tests/myCalendarTest.php:61
Comment 3 Till Schäfer 2021-03-31 07:39:39 UTC
created upstream bug report. I am not sure is this is causing real world problems. Thus, I will wait a few days, whether upstream provides a quick patch before depending on PHP < 8 here.
Comment 4 Till Schäfer 2021-10-04 11:15:58 UTC
I will leave it this way so far. Davical with AWL is working without troubles with PHP-8 here since some time.
Comment 5 Michael Orlitzky gentoo-dev 2024-06-30 19:03:02 UTC
We don't have dev-php/phpunit any more, so this is a moot point.