Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 779151 (libmicrohttpd-0.9.71) - [TRACKER] Packages broken with >=net-libs/libmicrohttpd-0.9.71
Summary: [TRACKER] Packages broken with >=net-libs/libmicrohttpd-0.9.71
Status: UNCONFIRMED
Alias: libmicrohttpd-0.9.71
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL: https://lists.gnu.org/archive/html/li...
Whiteboard:
Keywords: Tracker
Depends on: 730918 779004 779154 779169
Blocks:
  Show dependency tree
 
Reported: 2021-03-29 20:13 UTC by Karlson2k
Modified: 2021-09-08 13:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karlson2k 2021-03-29 20:13:53 UTC
GNU libmicrohttpd introduced some API changes that break compilation of C++ code and may generate warnings in C code.

See https://lists.gnu.org/archive/html/libmicrohttpd/2020-06/msg00013.html

This bug should be used as tracker for packages broken with >=net-libs/libmicrohttpd-0.9.71.
Comment 1 Karlson2k 2021-03-29 20:20:38 UTC
app-admin/conky supports new MHD versions
Comment 2 Karlson2k 2021-03-29 20:23:37 UTC
app-metrics/collectd-5.12.0-r1 supports new MHD versions.
Comment 3 Karlson2k 2021-03-29 20:52:06 UTC
sys-apps/systemd works fine with new MHD API from systemd version 246. All systemd versions in Gentoo repo work fine.
Comment 4 Karlson2k 2021-03-29 21:02:17 UTC
>=net-wireless/kismet-2020.12.3 wrongly has dependency on MHD. This and later versions use C++ Beast library. Anyway net-wireless/kismet compiles fine with new MHD.
Comment 5 Karlson2k 2021-03-29 21:29:31 UTC
media-tv/kodi works with with new MHD versions
Comment 6 Karlson2k 2021-03-29 22:02:47 UTC
Seems that net-p2p/retroshare doesn't use libmicrohttpd and uses restbed instead.
Comment 7 Karlson2k 2021-03-30 12:03:50 UTC
net-misc/oidc-agent works fine with new MHD API. The code was not adapted even in the upstream git, but new MHD version produce the only one harmless compiler warning.
Comment 8 Karlson2k 2021-03-30 12:05:17 UTC
NOTE: While libmicrohttpd changed API, the ABI remains the same. So dependent packages do not need to be re-compiled.
Comment 9 Karlson2k 2021-03-30 12:19:26 UTC
net-misc/bfgminer is C programme, so code works fine with the new API (harmless warning only). Code compiles fine.
However net-misc/bfgminer itself is broken in Gentoo repo currently, linker problem related to -fnocommon, see https://bugs.gentoo.org/775560.
Comment 10 Karlson2k 2021-03-30 12:21:39 UTC
(In reply to Karlson2k from comment #9)
> net-misc/bfgminer is C programme, so code works fine with the new API
> (harmless warning only). Code compiles fine.

Correction. Tested package is net-misc/bfgminer-5.5.0[proxy_getwork, proxy]
Comment 11 Karlson2k 2021-03-30 12:46:09 UTC
net-libs/libnpupnp was adopted to the new MHD API, no build errors or warnings.
Comment 12 Karlson2k 2021-03-30 12:59:31 UTC
net-libs/czmq works fine with the new MHD API.
Comment 13 Karlson2k 2021-03-30 14:41:28 UTC
net-analyzer/greenbone-security-assistant 9.0.1 and 20.8.1 compiled fine with the new MHD API.

Version 9.0.1 was not adapted to the new API, but as it's C code, only warnings are issued.
Version 20.8.1 was adapted to the new API and compiled without warnings.
Comment 14 Karlson2k 2021-03-30 14:47:27 UTC
media-video/motion compiles fine with the new API.
Version 4.3.1 was compiled with warning (C code), version 4.3.2 was compiled without warning.
Comment 15 Karlson2k 2021-03-30 14:55:06 UTC
media-sound/upmpdcli compiles without any warning.
Comment 16 Karlson2k 2021-03-30 15:05:10 UTC
media-sound/sc2mpd-1.1.7 was not adapted to the new API and currently depends on <=net-libs/libmicrohttpd-0.9.70.

Version 1.1.8 (available upstream) adapted to the new API.
Comment 17 Karlson2k 2021-03-30 16:08:13 UTC
media-plugins/gmpc-mserver-0.20.0 compiled with the new API.
Produced some warnings about incompatible pointer types, but compiled just fine.
Comment 18 Karlson2k 2021-03-30 16:25:50 UTC
I've checked all dependent packages and found that only three packages are not ready for the new MHD version:
* dev-cpp/libjson-rpc-cpp-1.3.0[http-server]
* net-p2p/xmr-stak-2.10.8[webserver]
* net-p2p/xmr-stak-rx[webserver], versions 1.0.4 and 1.0.5

None of these packages have stable build in Gentoo repo. No packages depend on these packages. The net-p2p/xmr-stak package is masked and scheduled for removal.

The rest two packages can be enforced to compile with '-fpermissive' flag, but I suggest instead make them depend on '<libmicrohttpd-0.9.70'.

All other packages are ready for stabilization of libmicrohttpd-0.9.72 (I actually checked with this version).