Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77910 - sys-kernel/linux-headers/linux-headers- fails to emerge
Summary: sys-kernel/linux-headers/linux-headers- fails to emerge
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High blocker (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2005-01-13 16:19 UTC by James Stockton
Modified: 2005-01-29 10:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description James Stockton 2005-01-13 16:19:34 UTC
sys-kernel/linux-headers/linux-headers- fails to emerge

Reproducible: Always
Steps to Reproduce:
1. add sys-kernel/linux-headers ~amd64 to package.keywords
2. emerge linux-headers

Actual Results:  
>>> emerge (1 of 1) sys-kernel/linux-headers- to /
>>> Downloading
           => `/usr/portage/distfiles/linux-'
Connecting to[]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 35,628,066 [application/x-tar]

35,628,066    51.86K/s    ETA 00:00

23:57:00 (53.29 KB/s) - `/usr/portage/distfiles/linux-' saved

>>> md5 src_uri ;-) linux-
>>> md5 src_uri ;-) linux-
>>> Unpacking source...
>>> Unpacking linux- to
 * Applying linux- (-p0+)...                     
                                        [ ok ] * Applying
linux-headers-2.6.0-fb.patch (-p0+)...                                         
                            [ ok ] * Applying
linux-headers-2.6.0-sysctl_h-compat.patch (-p0+)...                            
                            [ ok ] * Applying
linux-headers-2.6.7-generic-arm-prepare.patch (-p0+)...                        
                            [ ok ] * Applying
linux-headers- (-p0+)...                                
                            [ ok ] * Applying
linux-headers- (-p0+)...                                
                            [ ok ] * Applying
linux-headers- (-p0+)...                           
                            [ ok ] * Applying
linux-headers- (-p0+)...                          
                            [ ok ] * Applying
linux-headers-soundcard-ppc64.patch (-p0+)...                                  
                            [ ok ]>>> Source unpacked.
make[1]: Entering directory
/bin/sh: -c: line 1: unexpected EOF while looking for matching ``'
/bin/sh: -c: line 2: syntax error: unexpected end of file
make[2]: *** [scripts/basic/fixdep] Error 2
make[1]: *** [scripts_basic] Error 2
make[1]: Leaving directory

!!! ERROR: sys-kernel/linux-headers- failed.
!!! Function compile_headers, Line 270, Exitcode 2
!!! defconfig failed
!!! If you need support, post the topmost build error, NOT this status message.

Portage 2.0.51-r12 (default-linux/amd64/2004.3, gcc-3.4.3,
glibc-, 2.6.9-gentoo-r14 x86_64)
System uname: 2.6.9-gentoo-r14 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4 [2.3.4 (#1, Oct 28 2004, 08:02:56)]
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.4
sys-devel/autoconf:  2.59-r5
sys-devel/automake:  1.8.5-r1
sys-devel/libtool:   1.5.2-r7
virtual/os-headers:  [Not Present]
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=k8 -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=k8 -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox"
USE="amd64 acpi alsa berkdb bitmap-fonts crypt emul-linux-x86 f77 font-server
fortran gif gpm ipv6 jp2 jpeg lzw lzw-tiff multilib ncurses nls opengl oss pam
perl png python readline ssl tcpd tiff truetype truetype-fonts type1-fonts usb
userlocales xml2 xpm xrandr xv zlib"
Comment 1 James Stockton 2005-01-13 16:35:43 UTC
I will try to find a fix to save you the work.
Comment 2 Micheal Marineau (RETIRED) gentoo-dev 2005-01-13 17:36:38 UTC

*** This bug has been marked as a duplicate of 77907 ***
Comment 3 Micheal Marineau (RETIRED) gentoo-dev 2005-01-13 17:38:59 UTC
Opps, sorry, missfire with the mouse there...
Comment 4 John Mylchreest (RETIRED) gentoo-dev 2005-01-14 05:57:50 UTC
this should have been solved.
Comment 5 James Stockton 2005-01-14 15:34:01 UTC
Still doesn't work.
Comment 6 James Stockton 2005-01-14 16:49:48 UTC
Working now.
Comment 7 James Stockton 2005-01-14 16:50:07 UTC
Comment 8 Andreas Pokorny 2005-01-15 03:44:02 UTC
What was the cause of this bug, how did you fix it? 
The bug still occurs here!
Comment 9 Sebastian Spaeth 2005-01-26 02:32:53 UTC
Sorry, this is not fixed for me! With a just freshly synced tree on amd64 I get the exact same error. Please reopen this bug.
Comment 10 Sebastian Spaeth 2005-01-29 10:57:22 UTC
Additional info: it worked after first emerging 
linux-headers- and then going up to