Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 777909 - media-video/avidemux-2.7.8 version bump incl media-libs/avidemux-core-2.7.8 and media-libs/avidemux-plugins-2.7.8
Summary: media-video/avidemux-2.7.8 version bump incl media-libs/avidemux-core-2.7.8 a...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: media-video herd
URL: http://fixounet.free.fr/avidemux
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2021-03-23 19:36 UTC by SpikyAtLinux
Modified: 2021-11-07 00:01 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
bumped ebuild (avidemux-2.7.8.ebuild,3.78 KB, text/plain)
2021-05-18 07:39 UTC, Petr Zima
Details
bumped ebuild (avidemux-core-2.7.8.ebuild,2.52 KB, text/plain)
2021-05-18 07:41 UTC, Petr Zima
Details
bumped ebuild (avidemux-plugins-2.7.8.ebuild,4.09 KB, text/plain)
2021-05-18 07:42 UTC, Petr Zima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SpikyAtLinux 2021-03-23 19:36:39 UTC
There´s a new version of avidemux, could you bump it, please. There are lot of changes.

Found on https://www.fosshub.com/Avidemux.html

 # Change Log

Avidemux is Free/OpenSource - DONT PAY FOR IT ON THE MICROSOFT STORE, THAT WOULD JUST FEED PARASITES UNRELATED TO US

Changes in Avidemux v2.7.6 – v2.7.8

New Features

Many new video filters added by courtesy of a href="https://github.com/szlldm"szlldm/a

A dedicated MOV muxer is now available, replacing silent fallback to

MOV muxing mode within the MP4 muxer.

A subset of color info relevant for HDR support is retained in copy

mode when both input and output video are stored in Matroska / WebM

containers. Settings to add or override color info have been added to

MKV and WebM muxers.

The indexer in the MPEG-TS demuxer now detects resolution changes in

MPEG-2 and H.264 streams which are entirely unsupported and suggests

aborting indexing. If the user chooses to continue, it records file

offsets of all resolution changes to the log. This allows advanced

users to split the file at these offsets using other tools like

head and tail into chunks which can be processed

with Avidemux.

YUV varieties of the lossless Ut Video codec are supported now for

decoding and encoding via bundled FFmpeg libraries.

Uncompressed 24-bit audio is now supported for a subset of file formats.

Limited support for 7.1 channel layout.

Decode and stream copy support for XLL substream in DTS audio tracks.

Audio properties are now updated on resuming playback. This allows to

start saving after an audio format change. When audio format changes

during playback, the FFmpeg-based audio decoder will output silence

and keep format rather than producing garbage.

An option to keep the identity of markers A and B instead of swapping

them automatically has been added to Preferences.

The keyboard shortcut for "Delete" action has been made customizable

with alternative keyboard shortcuts enabled.

Other Enhancements

Multi-threaded video decoding is now available for the bundled FFmpeg.

On powerful multi-core CPUs, this can drastically improve decoding

performance. A maximum of 8 threads can be created, but a conservative

custom upper limit of 4 is recommended. Values above 8 cause decoding

failures. Multi-threaded decoding and HW accelerated decoding are

mutually exclusive, changes require application restart to have

effect.

The maximum supported resolution has been increased to 8192x8192

The bundled FFmpeg has been updated to the 4.2.4 release.

Non-standard display aspect ratios can be configured in MP4 muxer by

specifying display width.

MP4 muxer accepts now MPEG-1 and MPEG-2.

The configuration dialog of the x265 video encoder plugin enjoyed

massive cleanup and refactoring by a href="https://github.com/xyzzy42"Trent Piepho /a, more Adaptive

Quatization Variance methods have been added.

Python interface has been substantially extended, includes now methods

to query segment properties, the number and filenames of loaded

videos, PTS of keyframes, methods to seek to time with preview

updated, to open file dialogs filtered by extension and a built-in

method to split filename extension from a given path.

Scripting shell now supports unicode characters.

On macOS, files can be loaded via Finder context menu or by dropping

them onto Avidemux icon in the dock.

On Linux, Jobs GUI and the CLI executable can be launched from

AppImage by creating a symlink with _jobs or _cli in filename

respectively and running the AppImage via this symlink.

Bugfixes

Rate control was broken in some video encoders, especially in VP9 and

in NVENC-based encoders, fixed now.

Multiple issues in cut point checks for H.264 and HEVC streams in copy

mode, leading to incorrect check results, were identified and

resolved.

The first two frames of external AC3 or EAC3 audio tracks are not

dropped anymore. This regression from enhanced protection against

false positives, added 3 years ago, has been finally identified and

fixed.

Indexing of MPEG-TS files with HEVC video was broken when video stream

lacked access unit delimiters. The issue was identified and fixed

right after 2.7.7 had been tagged as released and is the reason why

version 2.7.7 was superseded by 2.7.8.

VU meter was grossly ahead of audio output on Windows, now it is just

a tiny little bit ahead.

Numerous other fixes and overall polish.

Best regards

Reproducible: Always
Comment 1 Kobboi 2021-04-28 18:43:45 UTC
This would also fix bug #768210 (tested via simple ebuild bump)
Comment 2 Petr Zima 2021-05-18 07:39:25 UTC
Created attachment 709614 [details]
bumped ebuild

Simple rename works, included patch applies cleanly, confirming that it fixes also #768210.
Comment 3 Petr Zima 2021-05-18 07:41:12 UTC
Created attachment 709617 [details]
bumped ebuild

Simple rename, included patch applies cleanly.
Comment 4 Petr Zima 2021-05-18 07:42:48 UTC
Created attachment 709620 [details]
bumped ebuild

Simple rename, included patch applies cleanly + dropped unnecessary spidermonkey dep, see bug #744859.
Comment 5 Andrew Savchenko gentoo-dev 2021-05-21 14:53:47 UTC
It just works on ~amd64, but requires patching on ~x86:

src/libavcodec/cabac_functions.h: In function ‘get_cabac_noinline’:
src/libavcodec/x86/cabac.h:192:5: error: ‘asm’ operand has impossible constraints
  192 |     __asm__ volatile(
      |     ^
lto-wrapper: fatal error: /usr/bin/i686-pc-linux-gnu-gcc returned 1 exit status

At first glance it uses outdated bundled ffmpeg version.
Comment 6 Andrew Savchenko gentoo-dev 2021-05-21 15:08:46 UTC
(In reply to Andrew Savchenko from comment #5)
> It just works on ~amd64, but requires patching on ~x86:
> 
> src/libavcodec/cabac_functions.h: In function ‘get_cabac_noinline’:
> src/libavcodec/x86/cabac.h:192:5: error: ‘asm’ operand has impossible
> constraints
>   192 |     __asm__ volatile(
>       |     ^
> lto-wrapper: fatal error: /usr/bin/i686-pc-linux-gnu-gcc returned 1 exit
> status
> 
> At first glance it uses outdated bundled ffmpeg version.

Looks like a regression in 2.7.8: old avidemux-core-2.7.6 builds fine on ~x86 with gcc-11 (and -std=gnu++14 in the CXXFLAGS) while avidemux-core-2.7.8 gives the problem above.
Comment 7 Marco Scardovi (scardracs) 2021-07-04 14:45:04 UTC
(In reply to Andrew Savchenko from comment #5)
> It just works on ~amd64, but requires patching on ~x86:
> 
> src/libavcodec/cabac_functions.h: In function ‘get_cabac_noinline’:
> src/libavcodec/x86/cabac.h:192:5: error: ‘asm’ operand has impossible
> constraints
>   192 |     __asm__ volatile(
>       |     ^
> lto-wrapper: fatal error: /usr/bin/i686-pc-linux-gnu-gcc returned 1 exit
> status
> 
> At first glance it uses outdated bundled ffmpeg version.

Same error was on https://bugs.gentoo.org/578802 and was fixed using --disable-optimizations. I don't know if it is lto related, could you try with it disabled?
Comment 8 Larry the Git Cow gentoo-dev 2021-11-07 00:01:27 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=841bd92580e87739852b51a4b2c0357a64366e17

commit 841bd92580e87739852b51a4b2c0357a64366e17
Author:     Marco Scardovi <marco@scardovi.com>
AuthorDate: 2021-06-20 18:20:25 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-11-07 00:01:16 +0000

    media-libs/avidemux-plugins: bump to 2.7.8
    
    Drop spidermonkey as it isn't required anymore.
    
    Closes: https://bugs.gentoo.org/744859
    Closes: https://bugs.gentoo.org/777909
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Signed-off-by: Marco Scardovi <marco@scardovi.com>
    Signed-off-by: Sam James <sam@gentoo.org>

 media-libs/avidemux-plugins/Manifest               |   1 +
 .../avidemux-plugins/avidemux-plugins-2.7.8.ebuild | 165 +++++++++++++++++++++
 2 files changed, 166 insertions(+)