Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 77718 - Missing g++ program when bootstraping
Summary: Missing g++ program when bootstraping
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All All
: High blocker (vote)
Assignee: Gentoo Toolchain Maintainers
URL: http://forums.gentoo.org/viewtopic.ph...
Whiteboard:
Keywords:
: 77709 77777 77828 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-12 10:42 UTC by Michal Margula
Modified: 2005-01-14 05:34 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Margula 2005-01-12 10:42:46 UTC
More information you can find in those two threads:

http://forums.gentoo.org/viewtopic.php?t=278555
http://forums.gentoo.org/viewtopic.php?t=278226

After trying to bootstrap a system we get ''g++: command not found''. And that is true, there is no g++ anywhere. So either stage1 for x86 is broken, and missing that binary from gcc, or bootstrap.sh is broken because it doesn't build gcc in first place. No idea.

Anyway it prevents from installing gentoo at all (but it worked a month ago...). My emerge info:

Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, unavailable, 2.4.27 i686)
=================================================================
System uname: 2.4.27 i686 Intel(R) XEON(TM) CPU 2.00GHz
Gentoo Base System version 1.4.16
Autoconf:
Automake:
Binutils: sys-devel/binutils-2.14.90.0.8-r1
Headers:
Libtools:
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 acl apache2 apm arts avi berkdb bitmap-fonts crypt cups encode foomaticdb fortran ftp gdbm gif gnome gpm gtk gtk2 ipv6 jpeg kde libwww mad mikmod motif mpeg ncurses nls oggvorbis opengl oss pam pdflib perl php png python qt quicktime readline sdl spell ssl svga tcpd truetype userlocales xml2 xmms xv zlib"
Comment 1 SpanKY gentoo-dev 2005-01-12 15:46:20 UTC
stage1 isnt supposed to have g++

once youve bootstrapped your system, what happens if you run `gcc-config 1 ; g++`
Comment 2 Michal Margula 2005-01-12 18:43:46 UTC
I have spotted four people on forums already. They have same issue.

Output of 'gcc-config 1 ; g++' after failed bootstrap.sh is:

gandalf portage # gcc-config 1 ; g++
 * Switching to i386-pc-linux-gnu-3.3.4 compiler...                                                                    [ ok ]bash: g++: command not found
Comment 3 Jeremy Huddleston (RETIRED) gentoo-dev 2005-01-12 19:26:52 UTC
So, did bootstrap.sh complete successfully?  Can you 'emerge -pv gcc' so I can see what use flags the bootstrap used?
Comment 4 Douglas R. Hoffman 2005-01-12 20:17:27 UTC
The bootstrap fails for me.  The dependancy tree for gcc it's self, forces db to be compiled which requires c++.  sucks eh?

As a work around, I've manually forced a gcc compile prior to the bootstrap via 'USE="static" emerge --no-deps gcc'

so the order that works for me is as follows

01. explode 2004.3-stage1
02. bind proc
03. chroot into it
04. env-update
05. source /etc/profile
06. emerge sync
07. tweek my make.conf
08. emerge --nodeps linux26-headers
09. emerge --nodeps gcc
10. cd /usr/portage
11. scripts/bootstrap.sh
12. emerge system
...
Comment 5 Douglas R. Hoffman 2005-01-12 20:23:50 UTC
correction:

09. USE="static" emerge --nodeps gcc

emerge info dump:

Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.10-gentoo-r4 i686)
=================================================================
System uname: 2.6.10-gentoo-r4 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r2
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"CXXFLAGS="-O3 -march=pentium4 -pipe -fomit-frame-pointer"DISTDIR="/usr/portage/distfiles"FEATURES="autoaddcvs autoconfig buildpkg ccache distlocks sandbox sfperms"GENTOO_MIRRORS="http://mirror.ce.rit.edu/gentoo http://128.213.5.34/gentoo/ http://gentoo.oregonstate.edu/ http://www.ibiblio.org/pub/Linux/distributions/gentoo"MAKEOPTS="-j2"PKGDIR="/usr/portage/packages"PORTAGE_TMPDIR="/tmp"PORTDIR="/usr/portage"PORTDIR_OVERLAY=""SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"USE="X alsa apm avi berkdb cdr crypt cups divx4linux encode esd fbcon gif gpm gtk gtk2 icc imlib jpeg kde libg++ libwww mad mbox mikmod mmx mmx2 motif mpeg mysql ncurses nptl opengl pam perl png python quicktime readline real samba sdl slang spell sse sse2 ssl tcpd tetex threads truetype usb x86 xml2 xmms xv zlib"
Comment 6 SpanKY gentoo-dev 2005-01-12 20:28:35 UTC
what was the full stage name you d/l-ed ?

what does `ls /usr/` show before you run bootstrap ?
Comment 7 Kasper K. Grubbe 2005-01-12 20:38:02 UTC
stage1-x86-2004.3.tar.bz2 for me.

My bootstrap failed but /usr/ shows:
cdimage gentoo # ls /usr/
X11R6  diet  i586-pc-linux-gnu  info  local  portage  share  tmp
bin    doc   include            lib   man    sbin     src
Comment 8 SpanKY gentoo-dev 2005-01-12 20:47:40 UTC
might be crosscompiling gone bad

i'll check it out in a bit
Comment 9 SpanKY gentoo-dev 2005-01-13 07:06:23 UTC
*** Bug 77828 has been marked as a duplicate of this bug. ***
Comment 10 Michal Margula 2005-01-13 09:13:32 UTC
In my case bootstrap never finishes, it stops on db compilation.
Comment 11 Douglas R. Hoffman 2005-01-13 11:10:47 UTC
ok to answer SpanKY

1. http://bugs.gentoo.org/show_bug.cgi?id=77709 also appears to be a duplicate of this bug

2. stage1-x86-2004.3.tar.bz2 (md5: 1fa657675542653f0eee1418a061b290) is what I downloaded

3. ls -lA /usr (this is after the emerge system in my modified procedure detailed above)
-rw-r--r--    1 root root     0 Jan 12 17:26 .keep
drwxr-xr-x    7 root root   168 Jan 12 23:47 X11R6
drwxr-xr-x    2 root root 33608 Jan 13 09:49 bin
lrwxrwxrwx    1 root root     9 Jan 12 17:26 doc -> share/doc
drwxr-xr-x    5 root root   120 Jan 12 16:45 i686-pc-linux-gnu
drwxr-xr-x   81 root root  8456 Jan 13 09:44 include
lrwxrwxrwx    1 root root    10 Jan 12 17:26 info -> share/info
drwxr-xr-x    3 root root    72 Jan 13 03:31 kde
drwxr-xr-x   42 root root 27160 Jan 13 09:49 lib
drwxr-xr-x    2 root root    80 Jan 13 08:16 libexec
drwxr-xr-x    8 root root   240 Jan 12 17:26 local
lrwxrwxrwx    1 root root     9 Jan 12 17:26 man -> share/man
drwxr-xr-x  141 root root  4176 Jan 12 17:26 portage
drwxr-xr-x    3 root root    72 Jan 13 02:46 qt
drwxr-xr-x    2 root root  3680 Jan 13 02:09 sbin
drwxr-xr-x   80 root root  2136 Jan 13 13:08 share
drwxr-xr-x    3 root root   136 Jan 12 18:16 src
lrwxrwxrwx    1 root root    10 Jan 12 17:26 tmp -> ../var/tmp
Comment 12 Sven Vermeulen (RETIRED) gentoo-dev 2005-01-13 11:36:41 UTC
*** Bug 77709 has been marked as a duplicate of this bug. ***
Comment 13 Sven Vermeulen (RETIRED) gentoo-dev 2005-01-13 12:15:14 UTC
*** Bug 77777 has been marked as a duplicate of this bug. ***
Comment 14 Chris Mathis 2005-01-13 12:41:53 UTC
I can confirm that   USE="static" emerge --nodeps gcc   works.
Comment 15 SpanKY gentoo-dev 2005-01-13 12:59:50 UTC
ok, i tracked the issue back to a new eclass that had a bad DEPEND in it (multilib.eclass)

i fixed the eclass and that resolved this issue for me
Comment 16 Mark 2005-01-13 13:10:03 UTC
USE="static" emerge --nodeps gcc < -Doesn't work for me. I'm on AMD64 and I'm told that I need a 32bit sandbox. Is there a AMD64 equivalent ?
Comment 17 Danielle 2005-01-14 05:34:31 UTC
Can static be used safely?  When can it be used?

The description for static found by entering:
less /usr/portage/profiles/use.desc
says not to use it during bootstrapping.

I think I am bootstrapping when I get the +gcc error.

Danielle