Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77709 - Bootstrap fails whe installing Gentoo 2004.3
Summary: Bootstrap fails whe installing Gentoo 2004.3
Status: RESOLVED DUPLICATE of bug 77718
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2005-01-12 09:56 UTC by Stefano Steel
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Stefano Steel 2005-01-12 09:56:24 UTC
When i run the bootstrap script in /usr/portage/scripts it want to install a series of packages like db, groff,man that usually were installed in stage 2 (emerge system).
These packages fail to compile because i don't have g++ installed (or at least it seems, i must have the gcc-binutils-glibc toolchain broken, maybe it's related to the recent upgrade of gcc?).

Reproducible: Always
Steps to Reproduce: /usr/portage
Actual Results:  
groff give me this error:
configure: error: a working C++ compiler is required

!!! ERROR: sys-apps/groff-1.19.1-r2 failed.
!!! Function src_compile, Line 85, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

sorry if i can't post all the log but i'm on another computer posting this bug :(

db on the other and give me a similar error (i suppose for tha same reason: no
g++ available)
./libtool: line 1: g++: command not found
make: *** [cxx_db.lo] Error 1

!!! ERROR: sys-libs/db-4.1.25_p1-r4 failed.
!!! Function src_compile, Line 96, Exitcode 1
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

Expected Results:  
finish the bootstrap

i'm on another computer so i can't post the 'emerge info' output, sorry...

anyway i remember some settings:

CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"

i tried with different USE flags, even with USE="-*" but i get the same error
with groff (not with db beacuse it's not installed without the berkdb flag)
Comment 1 Daniel Drake (RETIRED) gentoo-dev 2005-01-12 14:57:51 UTC
Did you merge gcc with USE=nocxx ?
Comment 2 Stefano Steel 2005-01-13 00:16:51 UTC
no, anyway the bootstrap script tries to emerge groff and db before gcc, linux-headers, glibc and all the other packages...

this morning i will retry installing Gentoo to see what happens.
Comment 3 Stefano Steel 2005-01-13 03:14:02 UTC
no way, same error as yesterday
Comment 4 Tupone Alfredo gentoo-dev 2005-01-13 05:33:36 UTC
I got the same problem trying to boostrap an amd64
Comment 5 Douglas R. Hoffman 2005-01-13 11:10:43 UTC
is this a dup of
Comment 6 Sven Vermeulen (RETIRED) gentoo-dev 2005-01-13 11:36:41 UTC

*** This bug has been marked as a duplicate of 77718 ***