Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77522 - linux26-headers-2.6.8.1-r2 build failed.
Summary: linux26-headers-2.6.8.1-r2 build failed.
Status: RESOLVED DUPLICATE of bug 77486
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-11 07:42 UTC by Sin Yu
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sin Yu 2005-01-11 07:42:44 UTC
linux26-headers-2.6.8.1-r2 failed to emerge on my box. 

Reproducible: Always
Steps to Reproduce:
1.emerge sync
2.emerge linux26-headers

Actual Results:  
>>> emerge (1 of 1) sys-kernel/linux26-headers-2.6.8.1-r2 to /
>>> md5 src_uri ;-) linux-2.6.8.1.tar.bz2
>>> md5 src_uri ;-) linux-2.6.8.1-sh-headers.patch.bz2
>>> Unpacking source...
>>> Unpacking linux-2.6.8.1.tar.bz2 to
/var/tmp/portage/linux26-headers-2.6.8.1-r2/work
>>> Unpacking linux-2.6.8.1-sh-headers.patch.bz2 to
/var/tmp/portage/linux26-headers-2.6.8.1-r2/work
 * Applying linux-2.6.8.1-sh-headers.patch ...                            [ ok ]
 CLEAN   scripts/package
Makefile:415: .config: No such file or directory
  CHK     include/linux/version.h
  UPD     include/linux/version.h
>>> version.h compiled successfully.
.......
>>> Source unpacked.
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/split-include
  HOSTCC  scripts/basic/docproc
  SHIPPED scripts/kconfig/zconf.tab.h
  HOSTCC  scripts/kconfig/conf.o
  HOSTCC  scripts/kconfig/mconf.o
  SHIPPED scripts/kconfig/zconf.tab.c
  SHIPPED scripts/kconfig/lex.zconf.c
  HOSTCC  -fPIC scripts/kconfig/zconf.tab.o
  HOSTLLD -shared scripts/kconfig/libkconfig.so
  HOSTLD  scripts/kconfig/conf
scripts/kconfig/conf -d arch/x86/Kconfig
can't find file arch/x86/Kconfig
make[1]: *** [defconfig] Error 1


Expected Results:  
There are two error messages.

the first is warning .config missing.
the second problem is scripts/kconfig/conf -d arch/x86/Kconfig
*but* there is not x86 directory in linux kernel source tree.

ortage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.3.4, glibc-2.3.4.20040808-r1,
2.6.9-gentoo-r1 i686)
=================================================================
System uname: 2.6.9-gentoo-r1 i686 AMD Sempron(TM) 2200+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.90.0.1.1-r3
Headers:  sys-kernel/linux26-headers-2.6.8.1
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -mcpu=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://gentoo.osuosl.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aalib acl adns alsa apm arts avi berkdb bitmap-fonts crypt cscope
cups encode esd fam flac foomaticdb fortran gdbm ggi gif gnome gpm gstreamer gtk
gtk2 imagemagick imlib ipv6 java jpeg junit kde ldap libwww mad mikmod motif
mozilla mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png postgres
python qt quicktime readline samba sdl slang spell ssl svga tcltk tcpd tetex
tiff truetype xml xml2 xmms xv zlib"
Comment 1 Sin Yu 2005-01-11 07:53:52 UTC
I change tc-ninja_magic_to_arch in toolchain-funcs.eclass, use i386 instead x86, the portage can be merged successfully.
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-11 08:59:37 UTC

*** This bug has been marked as a duplicate of 77486 ***