Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 774360 - sys-firmware/intel-microcode: consider dropping RESTRICT="bindist mirror"
Summary: sys-firmware/intel-microcode: consider dropping RESTRICT="bindist mirror"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-05 21:13 UTC by Ogelpre
Modified: 2022-03-16 10:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ogelpre 2021-03-05 21:13:45 UTC
My systems have only IPv6 internet connection. Downloading of the Intel microcode fails, because they are not mirrored.

Reproducible: Always

Steps to Reproduce:
1. emerge -1 sys-firmware/intel-microcode
Actual Results:  
 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] sys-firmware/intel-microcode-20210216_p20210221::gentoo  USE="split-ucode -hostonly -initramfs -vanilla" 3.424 KiB

Total: 1 package (1 reinstall), Size of downloads: 3.424 KiB

>>> Verifying ebuild manifests
>>> Running pre-merge checks for sys-firmware/intel-microcode-20210216_p20210221
>>> Emerging (1 of 1) sys-firmware/intel-microcode-20210216_p20210221::gentoo
>>> Failed to emerge sys-firmware/intel-microcode-20210216_p20210221, Log file:
>>>  '/var/tmp/portage/sys-firmware/intel-microcode-20210216_p20210221/temp/build.log'
>>> Jobs: 0 of 1 complete, 1 failed                 Load avg: 0.08, 0.02, 0.01
>>> Downloading 'https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/archive/microcode-20210216.tar.gz'
--2021-03-05 22:08:48--  https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/archive/microcode-20210216.tar.gz
Resolving github.com... 140.82.121.4
Connecting to github.com|140.82.121.4|:443... failed: Network is unreachable.
!!! Couldn't download 'microcode-20210216.tar.gz'. Aborting.
 * Fetch failed for 'sys-firmware/intel-microcode-20210216_p20210221', Log file:
 *  '/var/tmp/portage/sys-firmware/intel-microcode-20210216_p20210221/temp/build.log'

 * Messages for package sys-firmware/intel-microcode-20210216_p20210221:

 * Fetch failed for 'sys-firmware/intel-microcode-20210216_p20210221', Log file:
 *  '/var/tmp/portage/sys-firmware/intel-microcode-20210216_p20210221/temp/build.log'
 * 
 * The following package has failed to build, install, or execute postinst:
 * 
 *  (sys-firmware/intel-microcode-20210216_p20210221:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/sys-firmware/intel-microcode-20210216_p20210221/temp/build.log'


Expected Results:  
The download should work on an ipv6 only network

Is there a reason why the Intel microcode is not mirrored?
Comment 1 Ionen Wolkens gentoo-dev 2021-03-05 21:43:07 UTC
(In reply to Ogelpre from comment #0)
> Is there a reason why the Intel microcode is not mirrored?
Was blocked because of bug #664134, however that restrictive license is no longer used and reading intel-ucode license I personally see no issue (but I'm no expert).
Comment 2 gengreen 2021-03-29 14:37:54 UTC
Even if your network could reach the link :

 >>> * Package:    sys-firmware/intel-microcode-20210216_p20210221
 >>> * Repository: gentoo
 >>> * Maintainer: base-system@gentoo.org
 >>> * USE:        abi_x86_64 amd64 elibc_musl kernel_linux split-ucode userland_GNU
 >>> * FEATURES:   network-sandbox preserve-libs sandbox userpriv usersandbox
 >>> Downloading 'https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/archive/microcode-20210216.tar.gz'
 >>> % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
>>> 100   168  100   168    0     0     87      0  0:00:01  0:00:01 --:--:--    87
>>> !!! Fetched file: microcode-20210216.tar.gz VERIFY FAILED!
>>> !!! Reason: Filesize does not match recorded size
>>> !!! Got:      168
>>> !!! Expected: 3506111
>>> Refetching... File renamed to '/usr/portage/distfiles/microcode-20210216.tar.gz._checksum_failure_.n895mtz5'

>>> !!! Couldn't download 'microcode-20210216.tar.gz'. Aborting.
>>> * Fetch failed for 'sys-firmware/intel-microcode-20210216_p20210221', Log file:
>>> *  '/var/log/portage/build/sys-firmware/intel-microcode-20210216_p20210221:20210328-083329.log'


curl -o out https://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/archive/microcode-20210216.tar.gz

>>> <html><body>You are being
<a href="https://codeload.github.com/intel/Intel-Linux-Processor-Microcode-Data-Files/tar.gz/microcode-20210216">redirected</a>.</body></html>

Replacing the url in the ebuild did the tricks (on my local homemade repos)
Comment 3 Thomas Deutschmann gentoo-dev 2021-03-29 15:29:20 UTC
Comment #2 is invalid. When using cURL you need to tell cURL to follow redirects (--location).
Comment 4 Ionen Wolkens gentoo-dev 2022-03-15 20:11:35 UTC
(In reply to Ionen Wolkens from comment #1)
> (In reply to Ogelpre from comment #0)
> > Is there a reason why the Intel microcode is not mirrored?
> Was blocked because of bug #664134, however that restrictive license is no
> longer used and reading intel-ucode license I personally see no issue (but
> I'm no expert).
Maybe a good time to visit this if d.g.o is going to be having issues? e.g. nevermind EAPI=8 mirror restriction lifting for d.g.o, this doesn't need RESTRICT="mirror" at all given it reverted to the old license and the problematic license is no longer in the tree.
Comment 5 Larry the Git Cow gentoo-dev 2022-03-15 20:19:24 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bb77ecbe6e87d2c2d33e2ecda99483b8dc005ecf

commit bb77ecbe6e87d2c2d33e2ecda99483b8dc005ecf
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-03-15 20:17:27 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-03-15 20:19:14 +0000

    sys-firmware/intel-microcode: drop RESTRICT="mirror"
    
    dev.gentoo.org is currently experiencing issues so users may
    not be able to reach it right now.
    
    It's clear from the original bug that led to the imposition
    of the restriction that the issue is gone
    
    Bug: https://bugs.gentoo.org/664134
    Closes: https://bugs.gentoo.org/774360
    Thanks-to: Ionen Wolkens <ionen@gentoo.org>
    Signed-off-by: Sam James <sam@gentoo.org>

 .../intel-microcode/intel-microcode-20201112_p20201116-r1.ebuild      | 4 ++--
 .../intel-microcode/intel-microcode-20210216_p20210221.ebuild         | 4 ++--
 .../intel-microcode/intel-microcode-20210216_p20210514.ebuild         | 4 ++--
 .../intel-microcode/intel-microcode-20210608_p20210608.ebuild         | 4 ++--
 .../intel-microcode/intel-microcode-20210608_p20210830.ebuild         | 4 ++--
 .../intel-microcode/intel-microcode-20220207_p20220207.ebuild         | 2 +-
 6 files changed, 11 insertions(+), 11 deletions(-)
Comment 6 Ulrich Müller gentoo-dev 2022-03-16 06:29:00 UTC
Reopening, because the ebuild still has a bindist restriction. It is a binary package, so if it can be mirrored then it can also be distributed.

(In reply to Larry the Git Cow from comment #5)
>     dev.gentoo.org is currently experiencing issues so users may
>     not be able to reach it right now.

This is not a valid reason for dropping mirror restriction. Just saying. :)

AFAICS, both mirror and bindist should have been dropped long ago (in 2018) when the license was reverted to the original "intel-ucode".
Comment 7 Larry the Git Cow gentoo-dev 2022-03-16 06:33:09 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0d2889e6612232d5c376ab6753054167fd454ac0

commit 0d2889e6612232d5c376ab6753054167fd454ac0
Author:     Ulrich Müller <ulm@gentoo.org>
AuthorDate: 2022-03-16 06:31:55 +0000
Commit:     Ulrich Müller <ulm@gentoo.org>
CommitDate: 2022-03-16 06:31:55 +0000

    sys-firmware/intel-microcode: Drop bindist restriction
    
    Closes: https://bugs.gentoo.org/774360
    Signed-off-by: Ulrich Müller <ulm@gentoo.org>

 .../intel-microcode/intel-microcode-20201112_p20201116-r1.ebuild        | 2 +-
 sys-firmware/intel-microcode/intel-microcode-20210216_p20210221.ebuild  | 2 +-
 sys-firmware/intel-microcode/intel-microcode-20210216_p20210514.ebuild  | 2 +-
 sys-firmware/intel-microcode/intel-microcode-20210608_p20210608.ebuild  | 2 +-
 sys-firmware/intel-microcode/intel-microcode-20210608_p20210830.ebuild  | 2 +-
 sys-firmware/intel-microcode/intel-microcode-20220207_p20220207.ebuild  | 2 +-
 6 files changed, 6 insertions(+), 6 deletions(-)
Comment 8 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-03-16 10:43:30 UTC
(In reply to Ulrich Müller from comment #6)
> Reopening, because the ebuild still has a bindist restriction. It is a
> binary package, so if it can be mirrored then it can also be distributed.
> 
> (In reply to Larry the Git Cow from comment #5)
> >     dev.gentoo.org is currently experiencing issues so users may
> >     not be able to reach it right now.
> 
> This is not a valid reason for dropping mirror restriction. Just saying. :)
> 

I meant it as motivation to fix the bug finally, the reason to drop it was in the next few lines! But point taken.

> AFAICS, both mirror and bindist should have been dropped long ago (in 2018)
> when the license was reverted to the original "intel-ucode".

Thanks for doing it!