Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77382 - iRate 0.5 [ebuild request]
Summary: iRate 0.5 [ebuild request]
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://irate.sf.net
Whiteboard:
Keywords:
: 28026 159669 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-10 08:12 UTC by Matija "hook" Šuklje
Modified: 2016-09-13 19:32 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
the ebuild from http://www.zugaina.org/gentoo/portage/net-p2p/irate-cvs/irate-cvs-0.4.ebuild (irate-cvs-0.4.ebuild,1.18 KB, text/plain)
2005-02-21 10:25 UTC, Freyr Gunnar Ólafsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matija "hook" Šuklje 2005-01-10 08:12:01 UTC
I know there's a 0.2 request already - but somehow i can't change that one :P

* their stable package is already 0.3.x (testing and unstable being even higher)
* their "project" homepage (where also all the downloads are) is now: http://irate.sf.net
* their "home" homepage (just looking spiffy :P) is now: http://www.irateradio.com

Any chance of seeing it soon(ish) in portage? ;) It seems like a very nice idea.
Comment 1 Freyr Gunnar Ólafsson 2005-02-21 10:25:46 UTC
Created attachment 51797 [details]
the ebuild from http://www.zugaina.org/gentoo/portage/net-p2p/irate-cvs/irate-cvs-0.4.ebuild

There are also a noatun irate plugin, and a xmms irate plugin ebuilds at that
url.
Comment 2 Chani 2005-11-03 15:10:57 UTC
why does it require gcj? iirc I installed a different java compiler a long time
ago because gcj simply wouldn't work. how do I get around this?
Comment 3 Chani 2005-11-03 16:09:37 UTC
oh well, even with gcj it doesn't work. maybe I'll try downloading the source
myself.
here's the error, in case anyone understands it:

gcj -g -pipe -O2 -fjni -o libswt.o -c  swt.jar
org/eclipse/swt/graphics/ImageLoader.java: In class
`org.eclipse.swt.graphics.ImageLoader':
org/eclipse/swt/graphics/ImageLoader.java: In method
`org.eclipse.swt.graphics.ImageLoader.load(java.lang.String)':
org/eclipse/swt/graphics/ImageLoader.java:149: error: verification error at PC=38
org/eclipse/swt/graphics/ImageLoader.java:149: error: might transfer control
into subroutine
make[1]: *** [libswt.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/irate-cvs-0.4/work/irate/lib'
make: *** [lib/libswt.o] Error 2

!!! ERROR: net-p2p/irate-cvs-0.4 failed.
!!! Function src_compile, Line 39, Exitcode 2
Comment 4 Jon Hood (RETIRED) gentoo-dev 2006-06-17 21:57:35 UTC
Not a chance of this getting in portage until their source code gets cleaned up. I tried the February 2006 code snapshot, and it doesn't build either with ant nor with gcj. Until this package stabalizes and gets a better building process, it's not going into portage. Please reopen this bug when another stable version is available.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-01-02 01:24:25 UTC
*** Bug 159669 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2007-01-02 01:25:21 UTC
*** Bug 28026 has been marked as a duplicate of this bug. ***
Comment 7 Heiko Baums 2008-04-14 09:49:45 UTC
Unfortunately I can't reopen this bug, but there's a new version 0.5 out since January 7, 2008.

See:
http://sourceforge.net/project/showfiles.php?group_id=77232
Comment 8 Santiago M. Mola (RETIRED) gentoo-dev 2008-04-14 10:02:30 UTC
Reopening
Comment 9 Matija "hook" Šuklje 2008-04-14 14:56:04 UTC
Changed the summary to match the version.
Comment 10 Marek Szuba gentoo-dev 2016-09-13 10:54:15 UTC
The upstream of this project is now not only dead but in fact quite thoroughly gone. No Web page, no SourceForge project, no Berlios SVN repository... All that is left of it is a few mentions on sites such as the late FreshMeat. In light of the above, I think it is safe to forgo the usual 30-day waiting period and close this bug right away.
Comment 11 Heiko Baums 2016-09-13 19:32:51 UTC
I agree. But 30 days? Did you see when this bug was reported? ;)
Actually I've forgotten this program anyway.