Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77234 - mono.pc not being installed during mono emerge
Summary: mono.pc not being installed during mono emerge
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-09 08:00 UTC by Sean Dague
Modified: 2005-01-10 20:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Dague 2005-01-09 08:00:39 UTC
after installing mono, pkg-config --libs mono returns the following error:

underhill mono # pkg-config --libs mono
Package mono was not found in the pkg-config search path.
Perhaps you should add the directory containing `mono.pc'
to the PKG_CONFIG_PATH environment variable
No package 'mono' found

I doubt this is amd64 specific, but that is the only gentoo platform I have to test it.

Because of this bug I can't build tomboy, a mono app, on top of it.

Reproducible: Always
Steps to Reproduce:
1. emerge mono
2. pkg-config --libs mono
3.

Actual Results:  
underhill mono # pkg-config --libs mono
Package mono was not found in the pkg-config search path.
Perhaps you should add the directory containing `mono.pc'
to the PKG_CONFIG_PATH environment variable
No package 'mono' found

Expected Results:  
dargo:~> pkg-config --libs mono
-Wl,--export-dynamic -pthread -lmono -lpthread -lm -lgmodule-2.0 -ldl
-lgthread-2.0 -lglib-2.0
Comment 1 Peter Johanson (RETIRED) gentoo-dev 2005-01-09 19:05:17 UTC
The 1.0.2 series does not have support for the JIT on amd64, so things like tomboy, gtk-sharp, etc are less than feasible. This *may* be why mono.pc is not installed (since the JIT is a no-go on that platform on 1.0.x). I've got the dev 1.1.x installed currently, but I'll test on x86 this week to see if 1.0.x installs it on this (JIT supported) platform.
Comment 2 Peter Johanson (RETIRED) gentoo-dev 2005-01-10 20:05:18 UTC
I can confirm that mono.pc *does* get installed by mono-1.0.5-r1 on x86. The logic is clear in ${S}/Makefile.am:

if JIT_SUPPORTED                                                                
pkgconfig_DATA= mono.pc mint.pc                                                 
else                                                                            
pkgconfig_DATA= mint.pc                                                         
endif

for mono-1.0.x, amd64 != JIT_SUPPORTED. If you'd like to try a version of mono with an amd64 JIT, you can try the mono-1.1.x ebuilds in my overlay found at: http://dev.gentoo.org/~latexer/files/

However, *PLEASE* don't report bugs if using these. Things are known to break/requiring newer versions with these versions of mono.

Marking this bug CANTFIX, when mono-1.2 is out, amd64 will stop being a second class citizen in the mono world. Until then, SOL. ):