Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77218 - some cleanups to media-plugins/bmp-midi-0.01
Summary: some cleanups to media-plugins/bmp-midi-0.01
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-09 04:46 UTC by Stefan Briesenick (RETIRED)
Modified: 2005-01-09 05:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
bmp-midi-0.01.ebuild (bmp-midi-0.01.ebuild,1.28 KB, text/plain)
2005-01-09 04:46 UTC, Stefan Briesenick (RETIRED)
Details
bmp-midi-0.01.ebuild.patch (bmp-midi-0.01.ebuild.patch,1014 bytes, patch)
2005-01-09 05:09 UTC, Stefan Briesenick (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Briesenick (RETIRED) gentoo-dev 2005-01-09 04:46:16 UTC
- adding src_compile() -> --disable-static
- cleanup of 'dodoc'
- fixing obsolete libtool symlink stuff + fixing corresponding .la

IMHO are all libtool .la in this special case really useless, because no one uses libtool to link against such plugin .so's. They could be removed from all bmp-plugins. But most of them (not all) installs them. So we should discuss this issue and then (perhaps) can change all ebuilds. This should be not a big task. A 'rm ${D}/usr/lib/bmp/*/*.la' in src_install() should do the job.


Reproducible: Always
Steps to Reproduce:
Comment 1 Stefan Briesenick (RETIRED) gentoo-dev 2005-01-09 04:46:50 UTC
Created attachment 48010 [details]
bmp-midi-0.01.ebuild
Comment 2 Stefan Schweizer (RETIRED) gentoo-dev 2005-01-09 04:51:31 UTC
please attach a unified diff
Comment 3 Stefan Briesenick (RETIRED) gentoo-dev 2005-01-09 05:09:34 UTC
Created attachment 48012 [details, diff]
bmp-midi-0.01.ebuild.patch

sorry ;)
Comment 4 Tony Vroon gentoo-dev 2005-01-09 05:44:24 UTC
Please contact <mldoering@gmx.net>, the upstream maintainer of this package, with your change request. Ebuilds are used to package software, and do not, unless  necessary for compatability or security reasons, change the way the software is installed.
With regard to the .la files, the plugins install them so somebody might stand up and say, I'm going to use libtool for this. In that case, Gentoo would have to revert a tree-wide "clean up".

Your dodoc change has been picked up. Please contact upstream for your other requests.
Comment 5 Stefan Briesenick (RETIRED) gentoo-dev 2005-01-09 05:54:37 UTC
eh, ok, but what about my "--disable-static"?
Comment 6 Stefan Briesenick (RETIRED) gentoo-dev 2005-01-09 05:59:49 UTC
you really don't need .a files. It's a DSO plugin architecture.