Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77190 - gentoo-sources-2.4.28-r5 failed
Summary: gentoo-sources-2.4.28-r5 failed
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High major (vote)
Assignee: John Mylchreest (RETIRED)
: 77432 77492 77945 78441 81732 81950 82443 82585 82644 83782 84426 85538 (view as bug list)
Depends on:
Reported: 2005-01-08 17:19 UTC by Carsten Lohrke (RETIRED)
Modified: 2005-04-14 04:01 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---

04-01.GRSecurity-2.0.2.err (04-01.GRSecurity-2.0.2.err,341.36 KB, text/plain)
2005-01-08 17:19 UTC, Carsten Lohrke (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Carsten Lohrke (RETIRED) gentoo-dev 2005-01-08 17:19:22 UTC
* Applying 04-01.GRSecurity-2.0.2.patch (-p0+)...
patch: pch.c:614: intuit_diff_type: Assertion `i0 != NONE' failed.                                                              [ !! ]
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-08 17:19:54 UTC
Created attachment 47988 [details]
Comment 2 Van Gale 2005-01-09 00:59:45 UTC
I get the same error.
Comment 3 Tim Yamin (RETIRED) gentoo-dev 2005-01-09 01:01:31 UTC
Try LC_ALL=C emerge gentoo-sources.
Comment 4 Tim Yamin (RETIRED) gentoo-dev 2005-01-09 02:28:04 UTC
<plasmaroo> Try LC_ALL="C" emerge gentoo-sources
<dlange> It worked.

Reassigning to johnm, this is a bug in kernel-2.eclass...
Comment 5 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-10 16:26:05 UTC
*** Bug 77432 has been marked as a duplicate of this bug. ***
Comment 6 Van Gale 2005-01-10 20:42:14 UTC
LC_ALL=C worked for me
Comment 7 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-11 04:02:47 UTC
*** Bug 77492 has been marked as a duplicate of this bug. ***
Comment 8 John Mylchreest (RETIRED) gentoo-dev 2005-01-12 09:47:12 UTC
should be fixed in the latest commit to cvs. Please emerge sync and test
Comment 9 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-13 04:43:37 UTC
I tried to unpack using rev. 1.81 of the kernel-2.eclass and the problem persists.
Comment 10 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-14 03:56:46 UTC
*** Bug 77945 has been marked as a duplicate of this bug. ***
Comment 11 Ghislain Bourgeois 2005-01-14 05:25:48 UTC
This bug keeps me from making a livecd-stage1 with Catalyst. We really need this at my office, so I would like to know if I can have a work-around until this bug is solved.
Comment 12 John Mylchreest (RETIRED) gentoo-dev 2005-01-16 04:30:36 UTC
unipatch actually sets LC_ALL=C at the very start of the function (as opposed to just the sort), and this is where all the patching logic is done.

This should have solved your issue.
Can you confirm that this problem still happens using kernel-2.eclass cvs revision 1.84

if this still fails, please attach a full log of the unpack.
Comment 13 Chris Gottbrath 2005-01-16 14:51:03 UTC
FWIW I had the same problem and the LC_ALL workaround worked for me. 
Comment 14 Ghislain Bourgeois 2005-01-17 06:21:43 UTC
Synced and tried again, works here too.
Comment 15 John Mylchreest (RETIRED) gentoo-dev 2005-01-17 10:51:13 UTC
can I please ask what locale you are using?
echo $LANG might tell you.
I cannot re-create here.
Comment 16 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-17 17:11:27 UTC
*** Bug 78441 has been marked as a duplicate of this bug. ***
Comment 17 Ghislain Bourgeois 2005-01-18 08:10:03 UTC
I was using locale fr_CA
Comment 18 Ghislain Bourgeois 2005-01-18 08:20:36 UTC
Unsetting every environment variables refering to fr_CA did the trick.
Comment 19 g_os 2005-01-23 07:53:24 UTC
Same error with: $LANG=fr_FR@euro
LC_ALL=C emerge gentoo-sources works fine. Thanks.
Comment 20 Philippe Laflamme 2005-01-24 19:52:32 UTC
Same error with $LANG=en_US.ISO-8859-1

# export LANG=
# emerge gentoo-sources

Worked fine. Thanks.
Comment 21 Simon Cooper 2005-02-10 06:15:33 UTC
I get the same error emerging mm-sources_rc3-r2 (ebuild copied from rc2_r2), but none of the solutions here worked:

tachyon mm-sources # LANG= LC_ALL="C" FEATURES="-sandbox" emerge mm-sources
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-kernel/mm-sources-2.6.11_rc3-r2 to /
>>> md5 src_uri ;-) patch-2.6.11-rc3.bz2
>>> md5 src_uri ;-) linux-2.6.10.tar.bz2
>>> md5 src_uri ;-) 2.6.11-rc3-mm2.bz2
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-2.6.10.tar.bz2 to /var/tmp/portage/mm-sources-2.6.11_rc3-r2/work
 * Applying patch-2.6.11-rc3.patch (-p0+) ...                             [ ok ]
 * Applying 2.6.11-rc3-mm2.patch (-p0+) ...
patch: pch.c:621: intuit_diff_type: Assertion `i0 != NONE' failed.        [ !! ]
 * Please attach /var/tmp/portage/mm-sources-2.6.11_rc3-r2/temp/2.6.11-rc3-mm2.err to any bug you may post.

!!! ERROR: sys-kernel/mm-sources-2.6.11_rc3-r2 failed.
!!! Function unipatch, Line 548, Exitcode 0
Comment 22 Carsten Lohrke (RETIRED) gentoo-dev 2005-02-12 06:45:07 UTC
*** Bug 81732 has been marked as a duplicate of this bug. ***
Comment 23 Tim Yamin (RETIRED) gentoo-dev 2005-02-14 01:00:56 UTC
*** Bug 81950 has been marked as a duplicate of this bug. ***
Comment 24 Carsten Lohrke (RETIRED) gentoo-dev 2005-02-18 05:59:02 UTC
*** Bug 82443 has been marked as a duplicate of this bug. ***
Comment 25 Carsten Lohrke (RETIRED) gentoo-dev 2005-02-19 08:26:49 UTC
*** Bug 82585 has been marked as a duplicate of this bug. ***
Comment 26 Andreas Thalhammer 2005-02-19 11:27:37 UTC
Bug is still there...
I'm having LANG=de_AT@euro

LANG= LC_ALL="C" emerge sys-kernel/gentoo-sources works... Is this going to be the default behaviour from now on?
Comment 27 Simone Scanzoni 2005-02-19 16:54:43 UTC
I had the same problem with gentoo-sources-2.4.28-r6 and gentoo-sources-2.4.28-r7 .
I simply unset LANG and it worked.
LANG wasn't present in shells started logging as root from virtual consoles (so it is enough to emerge from there too), it was a legacy from the user's shell from which I ran su (I appended export LANG="it_IT@euro" in ~/.bashrc ).
Comment 28 Carsten Lohrke (RETIRED) gentoo-dev 2005-02-23 10:18:05 UTC
*** Bug 82644 has been marked as a duplicate of this bug. ***
Comment 29 Timo Goedel 2005-02-26 10:51:04 UTC
No problem here with gentoo-sources-2.4.28-r5 but same problem with gentoo-sources-2.4.28-r7! (r6 not tried)

I'm having LANG="de_DE@euro"
Simply unsetting LANG didn't resolved the problem here!

But then I set LC_ALL="de_DE@euro" and it worked! Maybe, it doesn't have to be strictly LC_ALL=C, but the LC_ALL variable have just to be set to something! I think the most users have just set LANG to specify their locale (like me before :-) ). Maybe it helps generally to set LC_ALL too?!?
Comment 30 Attila Stehr 2005-03-02 04:06:20 UTC
Comment #29 from Timo Goedel confirmed.
LC_ALL="de_DE@euro" does it!
thx Timo!
Comment 31 Carsten Lohrke (RETIRED) gentoo-dev 2005-03-02 08:23:16 UTC
*** Bug 83782 has been marked as a duplicate of this bug. ***
Comment 32 Wolfgang Herder 2005-03-07 01:59:48 UTC
Problem persists in -r8
LANG= emerge gentoo-sources works
Comment 33 Carsten Lohrke (RETIRED) gentoo-dev 2005-03-07 15:44:07 UTC
*** Bug 84426 has been marked as a duplicate of this bug. ***
Comment 34 Juergen Nantke 2005-03-07 23:54:21 UTC
Setting LANG= worked for me with 2.4.28-r8
Original LANG was de_DE@euro
Comment 35 Carsten Lohrke (RETIRED) gentoo-dev 2005-03-16 12:11:53 UTC
*** Bug 85538 has been marked as a duplicate of this bug. ***
Comment 36 emile 2005-03-16 13:02:48 UTC
I filed <a href="">Bug 85538</a> with a similar but not identical patching issue.  I have tried the methods outlined here (LANG= LC_ALL="C" emerge -g gentoo-sources) and the problem I described in 85538 persists.
Comment 37 John Mylchreest (RETIRED) gentoo-dev 2005-04-14 04:01:16 UTC
fixed in cvs. if anyone experiences any more problems please let me know and re-open the bug.