Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 770919 - theseer-Autoload ebuild failed during prepare phase
Summary: theseer-Autoload ebuild failed during prepare phase
Status: RESOLVED DUPLICATE of bug 759835
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-16 11:31 UTC by Jean-Claude Aciman
Modified: 2021-02-16 14:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log, emerge --info, emerge -pqv, environment (theseer-Autoload..tar.gz,12.59 KB, application/gzip)
2021-02-16 11:31 UTC, Jean-Claude Aciman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Claude Aciman 2021-02-16 11:31:41 UTC
Created attachment 686922 [details]
build.log, emerge --info, emerge -pqv, environment

Failed during prepare phase:

build.log: 

* Package:    dev-php/theseer-Autoload-1.26.0
 * Repository: gentoo
 * Maintainer: php-bugs@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   network-sandbox preserve-libs sandbox userpriv usersandbox
 * Applying theseer-Autoload-1.26.0-autoload.php.patch ...
 [ ok ]
Cannot load Xdebug - it was already loaded
phpab 1.26.0 - Copyright (C) 2009 - 2021 by Arne Blankerts and Contributors

Scanning directory src

Autoload file src/autoload.php generated.

/var/tmp/portage/dev-php/theseer-Autoload-1.26.0/temp/environment: line 481:    37 Segmentation fault      (core dumped) ./phpab.php --output src/autoload.php --template "${FILESDIR}"/autoload.php.tpl --basedir src src
 * ERROR: dev-php/theseer-Autoload-1.26.0::gentoo failed (prepare phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line 125:  Called src_prepare
 *   environment, line 489:  Called die
 * The specific snippet of code:
 *       ./phpab.php --output src/autoload.php --template "${FILESDIR}"/autoload.php.tpl --basedir src src || die
 * 

All required files are in the attachment.
Thank you to solve this issue.
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2021-02-16 13:32:09 UTC
Do you have xdebug installed?
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2021-02-16 13:33:04 UTC
I mean dev-php/xdebug installed and threads USE on dev-lang/php?

That is known to cause issues
Comment 3 Jean-Claude Aciman 2021-02-16 14:06:20 UTC
(In reply to Brian Evans from comment #1)
> Do you have xdebug installed?

Yes, I do have XDebug installed on my machine.
Does that mean that I must de-install XDebug to build theseer-Autoload successfuly? (or, maybe remove the threads USE flag on php?).
Can I in that case reinstall XDebug after I built theseer-Autoload?
Thank you for letting me informed.
Kind regards.
Jean-Claude
Comment 4 Jean-Claude Aciman 2021-02-16 14:17:24 UTC
(In reply to Brian Evans from comment #2)
> I mean dev-php/xdebug installed and threads USE on dev-lang/php?
> 
> That is known to cause issues

Effectively,
I ran an emerge --unmerge xdebug, then
I ran an emerge -qav theseer-Autoload (with success), and finally
I ran an emerge -qav xdebug

Then all is now ok.

Thank you for the informations.
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2021-02-16 14:47:48 UTC

*** This bug has been marked as a duplicate of bug 759835 ***