Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 77 - GnuCash Will not run after merge
Summary: GnuCash Will not run after merge
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Martin Schlemmer (RETIRED)
: 4053 (view as bug list)
Depends on:
Reported: 2002-01-07 21:29 UTC by Andrew J Forgue
Modified: 2003-02-04 19:42 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Andrew J Forgue 2002-01-07 21:29:13 UTC
Doing A fresh merge of GnuCash installed 
 Guile, slib2d2, swig with no errors.

When Running GNUCash it generates this error:


bash-2.04$ gnucash

It appears you do not have the 'slib' scheme library installed.
You need slib2c4 or later to run GnuCash.

Obtain slib at:

If you have slib installed, you may need to create
a symbolic link named 'slib' from the guile directory
(usually /usr/share/guile) to the directory where slib
is installed.

You may also need to run GnuCash once as root.

Some deprecated features have been used.  Set the environment
variable GUILE_WARN_DEPRECATED to "detailed" and rerun the
program to get more information.  Set it to "no" to suppress
this message.


As root it gives the same result.

Slib IS Installed:

bash-2.04$ ls /var/db/pkg/dev-libs/
expat-1.95.1-r1  libole2-0.2.4      libxml-1.8.16      pilot-link-0.9.6-r3
g-wrap-1.3.1     libpcre-3.7        libxml2-2.4.12     popt-1.5
glib-1.2.10-r1   librep-0.14        libxslt-1.0.9      rep-gtk-0.15-r2
gmp-3.1.1-r1     libunicode-0.4-r1  openssl-0.9.6b-r1  !!slib-2.4.2!!


This appears to be a merge issue, or at worst a version conflict between gnucash
and something else.

After merge/unmerge of all gnucash dependencies - this error still persists.
Comment 1 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-08 17:24:15 UTC
these kind of errors should go to the component which the program fits into. The
ebuild-component is for submitting ebuilds.
Comment 2 protrans 2002-01-10 00:01:54 UTC
I had different error msgs with gnucash:
after emerging gnucash-1.6.5-r1.ebuild successfully, I had the following on star
tup of gnucash:

ERROR: In procedure dynamic-link:
ERROR: file: "libgw-runtime", message: "file not found"

Some deprecated features have been used.  Set the environment
variable GUILE_WARN_DEPRECATED to "detailed" and rerun the
program to get more information.  Set it to "no" to suppress
this message.

After setting the above variable, I got:

`scm_sysintern' is deprecated. Use `scm_define' instead.
ERROR: In procedure dynamic-link:
ERROR: file: "libgw-runtime", message: "file not found"

Hope that helps,

Joseph H. Yao
Comment 3 Martin Bergstrand 2002-01-29 15:38:38 UTC
I got both problems above.
After merging gnuchash it complained about the missing libgw.
I remergerd g-wrap and got the missing slib message.
Tried to remerge slib but to no avail.
Comment 4 Carl Perry (RETIRED) gentoo-dev 2002-02-03 00:26:48 UTC
the slib ebuild is not installing "guile.init" - which is needed to complete the
slib installation.  I installed this manually, and ran the supplied command in
slib's README - same error starting gnucash.  I think the guile.init should be
added to the ebuild script.  It doesn't _seem_ to fix anything, but the fact
that is not there could be a problem.
Comment 5 George Shapovalov (RETIRED) gentoo-dev 2002-02-09 13:58:44 UTC
This issue has been resolved lately, as far as I can tell (and I have gnucash
running now fine). This is a (common) case of "too new" dependency: g-wrap
requires guile-1.4, NOT 1.5.x to build correctly. 
Another small thing not reported so widely is that guppy ebuild contains
dependency on guile-1.5, while it will build fine with guile-1.4. Therefore the
followinf changes to 2 ebuild files will provide the most clean fix of this
problem for now (until gnucash people update g-wrap modules to use recent guile)

in dev-libs/g-wrap/g-wrap-1.3.1.ebuild:
     ">=dev-util/guile-1.4"  ->  "=dev-util/guile-1.4"
in gnome-extra/guppi/guppi-0.40.3.ebuild:
     ">=dev-util/guile-1.5"  ->  ">=dev-util/guile-1.4"
should take care of the problem.

Another suggestion was to emerge both versions of guile, however here you must
be very careful about the order in which you emerge things. Therefore, unless
you need guile-1.5 for something else, the former seems to be cleaner solution
for now.
Comment 6 Carl Perry (RETIRED) gentoo-dev 2002-02-10 15:21:23 UTC
Even with those changes, emerge still tries to merge guile-1.5, and complains
that guild-1.4 is not found.  I had to make the following changes:

in dev-libs/g-wrap/g-wrap-1.3.1.ebuild: "=dev-util/guile-1.4-r3"
in gnome-extra/guppi/guppi-0.40.3.ebuild: "=dev-util/guile-1.4-r3"

The dependancies were then satisfied.  However, starting gnucash now states:
ERROR: In procedure dynamic-link:
ERROR: file not found

All dynamic libs (found via ldd) were found.
Comment 7 David Mott 2002-02-27 11:02:20 UTC
I resolved this issue tonight and thought I would add some comments. (Finally)

1. g-wrap follows linux kernel numbering scheme so that if 2nd digit is 
odd=unstable, even=stable. Therefore I reverted back to g-wrap-1.2.1 (simply 
by renaming the 1.3.1 ebuild!)

2. Followed Carl's instructions to modify the g-wrap(1.2.1) and guppi ebuild 
to use guile-1.4-r3

3. After merging gnucash I remerged g-wrap(1.2.1) and that fixed my problems.
Comment 8 Carl Perry (RETIRED) gentoo-dev 2002-02-27 17:17:48 UTC
It may have worked for David, but it didn't work for me :(

I'm back to the "It appears you do not have the 'slib' scheme library
installed." error.
Comment 9 Carl Perry (RETIRED) gentoo-dev 2002-02-27 17:24:02 UTC
Scratch that, it just needed to be run once as root.  Like it says.  Duh.

I also discovered that you cannot unmerge g-wrap 1.3.1 first, as you get an
error.  This could be due to some other library depending on g-wrap 1.3.1, but
I'm unsure.  Is there some easy way to "rebuild everything that gnucash depends on"?

Also, I have a patch available if someone wants it for CVS.
Comment 10 George Shapovalov (RETIRED) gentoo-dev 2002-03-15 13:41:43 UTC
Hi Carl, 
Its been a while since you posted your comment, but this issue has not come up
again until now. If you still have the patch I think you should attach it to
this bug, so that people can just grab it from here even if it does not get
incorporated into the portage tree.
Comment 11 Jon Nelson (RETIRED) 2002-03-16 00:39:39 UTC
Well, I built it successfully tonight.
The only change I have that is different from "stock", is that I built guile
1.4something and installed that.  guppi complains about wanting guile 1.5, but
the guppi docs say that guile 1.3 or better is needed, not 1.5

Anyway, *all I did* was emerge guile 1.4, and then rebuild gnucash.
After that, all was good.

(Oh, I masked guile >= 1.5 in my /etc/make.profile/packages file)
I know, guppi complains. SO what.
Comment 12 Martin Schlemmer (RETIRED) gentoo-dev 2002-03-19 14:56:07 UTC
Unmerge guile,g-wrap,slib,guppi,gnucash and maybe swig, and remerge
gnucash, then it should work now .. at least, it did here.
Comment 13 Jeff Simon 2002-03-29 19:40:43 UTC
I am getting similar errors. Mine is this:

ERROR: no such module (g-wrapped gw-runtime)

I've rsynced and remerged and nothing seems to get it to work. It would help if
I know which program was giving the error. I'm pretty sure it's not Gnucash.
Comment 14 set_48035 2002-03-31 16:55:44 UTC
     I also just merged gnucash, and had the problem:
ERROR: no such module (g-wrapped gw-runtime)
     When invoking gnucash, but it went away after I remerged

Comment 15 Jon Nelson (RETIRED) 2002-03-31 21:55:35 UTC
Same here (with 1.0 as of 31 March 2002).
Emerged gnucash.
No happy.
rm /usr/portage/packages/All/g-wrap*
emerge --buildpkg g-wrap

gnucash works.
Comment 16 Martin Schlemmer (RETIRED) gentoo-dev 2002-04-01 14:37:48 UTC
Anybody with problems please remerge g-wrap.  It had the libtool "relink" bug,
which should be fixed in g-wrap-1.2.1-r1.
Comment 17 Martin Schlemmer (RETIRED) gentoo-dev 2002-04-25 15:47:25 UTC
This is still working for me (new build, fresh merge).  Any comments ?
Comment 18 Martin Schlemmer (RETIRED) gentoo-dev 2002-05-27 17:33:15 UTC
This seems to be still working, resolving.
Comment 19 Martin Schlemmer (RETIRED) gentoo-dev 2002-06-24 18:36:14 UTC
*** Bug 4053 has been marked as a duplicate of this bug. ***