Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 768705 - sys-devel/gdb-10.1 with sys-libs/uclibc-ng[-ipv6] - remote-utils.cc: In function 'void remote_prepare(const char*)': remote-utils.cc:293:60: error: 'in6addr_any' was not declared in this scope
Summary: sys-devel/gdb-10.1 with sys-libs/uclibc-ng[-ipv6] - remote-utils.cc: In funct...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: uclibc-porting
  Show dependency tree
 
Reported: 2021-02-04 20:28 UTC by ernsteiswuerfel
Modified: 2021-02-11 23:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (gdb-10.1:20210203-003305.log,262.42 KB, text/plain)
2021-02-04 20:28 UTC, ernsteiswuerfel
Details
emerge --info (file_768705.txt,5.27 KB, text/plain)
2021-02-04 20:29 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel archtester 2021-02-04 20:28:51 UTC
Created attachment 685797 [details]
build.log

[...]
i686-unknown-linux-uclibc-g++  -Os -march=pentium4 -pipe    -I. -I. -I./../gdb/regformats -I./.. -I./../include -I./../gdb -I./../gnulib/import -I../gnulib/import -I./.. -I..   -pthread -Wall -Wpointer-arith -Wno-unused -Wunused-value -Wunused-variable -Wunused-function -Wno-switch -Wno-char-subscripts -Wempty-body -Wunused-but-set-parameter -Wunused-but-set-variable -Wno-sign-compare -Wno-error=maybe-uninitialized -Wno-mismatched-tags -Wsuggest-override -Wimplicit-fallthrough=3 -Wduplicated-cond -Wshadow=local -Wdeprecated-copy -Wdeprecated-copy-dtor -Wredundant-move -Wmissing-declarations -Wstrict-null-sentinel -Wformat -Wformat-nonliteral  -DGDBSERVER -c -o remote-utils.o -MT remote-utils.o -MMD -MP -MF ./.deps/remote-utils.Tpo remote-utils.cc
remote-utils.cc: In function 'void remote_prepare(const char*)':
remote-utils.cc:293:60: error: 'in6addr_any' was not declared in this scope; did you mean 'in_addr_t'?
  293 |       ((struct sockaddr_in6 *) iter->ai_addr)->sin6_addr = in6addr_any;
      |                                                            ^~~~~~~~~~~
      |                                                            in_addr_t
make[2]: *** [Makefile:542: remote-utils.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/sys-devel/gdb-10.1/work/gdb-10.1/gdbserver'
make[1]: *** [Makefile:9031: all-gdbserver] Error 2
make[1]: Leaving directory '/var/tmp/portage/sys-devel/gdb-10.1/work/gdb-10.1'
make: *** [Makefile:854: all] Error 2
 * ERROR: sys-devel/gdb-10.1::gentoo failed (compile phase):
Comment 1 ernsteiswuerfel archtester 2021-02-04 20:29:21 UTC
Created attachment 685800 [details]
emerge --info
Comment 2 Mike Gilbert gentoo-dev 2021-02-07 18:35:23 UTC
I assume this is failing because your libc is built without ipv6 support.

gdb doesn't have an "ipv6" USE flag, so there might not be any way to make this work.
Comment 3 Sergei Trofimovich (RETIRED) gentoo-dev 2021-02-11 23:53:50 UTC
gdb assumes both ipv4 and ipv6 available at the same time.

I suggest filing an upstream bug at https://sourceware.org/bugzilla/enter_bug.cgi?product=gdb and asking if it's an environment gdb wants to support.