Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 768666 - lxqt-base/lxqt-meta: tray widget is broken
Summary: lxqt-base/lxqt-meta: tray widget is broken
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: LxQt maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-04 17:48 UTC by Vitaly Zdanevich
Modified: 2021-02-09 16:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
On nm-applet hover the panel is hidden (out.gif,893.12 KB, image/gif)
2021-02-04 17:48 UTC, Vitaly Zdanevich
Details
Default list of available widgets (screen.jpg,216.53 KB, image/jpeg)
2021-02-04 17:49 UTC, Vitaly Zdanevich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitaly Zdanevich 2021-02-04 17:48:38 UTC
Created attachment 685749 [details]
On nm-applet hover the panel is hidden

Out of the box there is an issue with nm-applet and autohide. And in available widgets I see `statusnotifier` but this is Unknown and do nothing. Member of LXQt organization on Github said "Something should be wrong with the package your distro provides. Ask you distro about that!" https://github.com/lxqt/lxqt/issues/1812#issuecomment-773454576 

This issue is related to https://bugs.gentoo.org/744382
Comment 1 Vitaly Zdanevich 2021-02-04 17:49:19 UTC
Created attachment 685752 [details]
Default list of available widgets
Comment 2 Vitaly Zdanevich 2021-02-04 17:57:18 UTC
Reply from https://github.com/lxqt/lxqt/issues/1812#issuecomment-773492421:

"
Status Notifier Plugin is a part of the Panel itself, not a separate app.

As I said, you may want to ask your distro as to why Status Notifier Plugin isn't included. Your distro should have a forum for asking questions.
"
Comment 3 Chiitoo gentoo-dev 2021-02-04 18:41:06 UTC
Did you build with USE="statusnotifier"?
Comment 4 Vitaly Zdanevich 2021-02-04 20:09:26 UTC
Rebuild with USE="statusnotifier", now in Widgets I see Status Notifier Plugin (statusnotifier), but how can I get not obsolete tray that is not autohide the panel when I hover the Wi-Fi ico from nm-applet?
Comment 5 Chiitoo gentoo-dev 2021-02-04 20:26:10 UTC
Try disabling the 'tray' widget, and see if you still get the nm-applet to show up.

It may choose to show up in the 'tray' one if you have both enabled.

If you don't see it, it might not support 'statusnotifier'.
Comment 6 Vitaly Zdanevich 2021-02-04 23:13:19 UTC
Disabled the `tray` widget - looks like `statusnotifier` is 0px :(

Developers of nm-applet should fix something?
Comment 7 Chiitoo gentoo-dev 2021-02-05 12:22:20 UTC
Just to be sure, it's 'gnome-extra/nm-applet'?

I just tried it myself, and to me, too, it seems to be able to use 'tray' only.

Yes, it would look like changes are needed in 'nm-applet' itself.
Comment 8 Vitaly Zdanevich 2021-02-05 13:30:00 UTC
Filled issue at https://gitlab.gnome.org/GNOME/network-manager-applet/-/issues/124
Comment 9 Vitaly Zdanevich 2021-02-09 16:57:27 UTC
I found that on Gentoo I need to build nm-applet with USE flag appindicator. Description of this flag: "Build in support for notifications using the libindicate or libappindicator plugin". Also USE statusnotifier for lxqt-base/lxqt-panel and alter autostart from nm-applet to nm-applet --indicator.

Maybe you can automate this a little bit: when gnome-extra/nm-applet is built with USE appindicator and LXQt is installed and lxqt-base/lxqt-panel is built with USE statusnotifier: alter startup from `nm-applet` to `nm-applet --indicator`. Also maybe show in the console message after different variants on installations. I spent hours because of this defect, lets make it better for other people.