Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 768105 - net-misc/clusterssh-4.30.600 : Cant load /.../Tk.so for module Tk: /.../Tk.so: undefined symbol: Perl_is_uni_space at /usr/lib64/p
Summary: net-misc/clusterssh-4.30.600 : Cant load /.../Tk.so for module Tk: /.../Tk.so...
Status: RESOLVED DUPLICATE of bug 763903
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Cluster Team
URL:
Whiteboard:
Keywords: PMASKED, PullRequest
Depends on:
Blocks:
 
Reported: 2021-01-31 19:48 UTC by Toralf Förster
Modified: 2021-11-12 07:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,17.60 KB, text/plain)
2021-01-31 19:48 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,370.23 KB, text/plain)
2021-01-31 19:48 UTC, Toralf Förster
Details
environment (environment,107.23 KB, text/plain)
2021-01-31 19:48 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,27.26 KB, application/x-bzip)
2021-01-31 19:48 UTC, Toralf Förster
Details
net-misc:clusterssh-4.30.600:20210131-192649.log (net-misc:clusterssh-4.30.600:20210131-192649.log,3.30 KB, text/plain)
2021-01-31 19:48 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,25.83 KB, application/x-bzip)
2021-01-31 19:48 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-01-31 19:48:01 UTC
Building App-ClusterSSH
Generating: ccon
Can't load '/usr/lib64/perl5/vendor_perl/5.32/x86_64-linux/auto/Tk/Tk.so' for module Tk: /usr/lib64/perl5/vendor_perl/5.32/x86_64-linux/auto/Tk/Tk.so: undefined symbol: Perl_is_uni_space at /usr/lib64/perl5/5.32/x86_64-linux/DynaLoader.pm line 193.

 at /var/tmp/portage/net-misc/clusterssh-4.30.600/work/App-ClusterSSH-4.03_06/bin_PL/../lib/App/ClusterSSH.pm line 23.
Compilation failed in require at /var/tmp/portage/net-misc/clusterssh-4.30.600/work/App-ClusterSSH-4.03_06/bin_PL/../lib/App/ClusterSSH.pm line 23.

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-20210123-231458

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-10.2.0 *
clang version 11.0.1
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/11/bin
/usr/lib/llvm/11
11.0.1
Python 3.8.7
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby27 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.48.0 *
The following VMs are available for generation-2:
1)	JamVM JDK 2.0.0 [jamvm]
*)	AdoptOpenJDK 8.272_p10 [openjdk-bin-8]
Available Java Virtual Machines:
  [1]   jamvm 
  [2]   openjdk-bin-8  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.8.4

  timestamp(s) of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sun Jan 31 18:55:30 UTC 2021

emerge -qpvO net-misc/clusterssh
[ebuild  N    ] net-misc/clusterssh-4.30.600  USE="-test"
Comment 1 Toralf Förster gentoo-dev 2021-01-31 19:48:02 UTC
Created attachment 685326 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-01-31 19:48:04 UTC
Created attachment 685329 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-01-31 19:48:05 UTC
Created attachment 685332 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-01-31 19:48:06 UTC
Created attachment 685335 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-01-31 19:48:07 UTC
Created attachment 685338 [details]
net-misc:clusterssh-4.30.600:20210131-192649.log
Comment 6 Toralf Förster gentoo-dev 2021-01-31 19:48:08 UTC
Created attachment 685341 [details]
temp.tar.bz2
Comment 7 Larry the Git Cow gentoo-dev 2021-11-12 01:21:33 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=80b0cd235fabed1caaf20c3718818a39b08f90ec

commit 80b0cd235fabed1caaf20c3718818a39b08f90ec
Author:     Jaco Kroon <jaco@uls.co.za>
AuthorDate: 2021-11-11 13:29:02 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-11-12 01:21:21 +0000

    net-misc/clusterssh: Bump to 4.16.
    
    About versioning: https://wiki.gentoo.org/wiki/Project:Perl/Version-Scheme
    
    Right, so with clusterssh using X.YY_ZZ, it's impossible to go larger
    than 99 already.  As such, the benefit of using 4.160 (and then using
    DIST_VERSION to wangle that back to 4.16 doesn't make sense for me).
    
    Currently there is no third digit here, so in a future version I'll set
    it up to double op on the versions, eg, 5.0 will likely be 5.00
    upstream, and 5.0.1 or 4.16.1 will be 5.00_01 or 4.16.01 upstream (which
    can be dealt with smartly using sprintf constructing DIST_VERSION).
    
    Closes: https://bugs.gentoo.org/598420
    Closes: https://bugs.gentoo.org/819306
    Closes: https://bugs.gentoo.org/775947
    Bug: https://bugs.gentoo.org/768105
    Package-Manager: Portage-3.0.28, Repoman-3.0.3
    Signed-off-by: Jaco Kroon <jaco@uls.co.za>
    Signed-off-by: Sam James <sam@gentoo.org>

 net-misc/clusterssh/Manifest               |  1 +
 net-misc/clusterssh/clusterssh-4.16.ebuild | 48 ++++++++++++++++++++++++++++++
 2 files changed, 49 insertions(+)
Comment 8 Jaco Kroon 2021-11-12 07:49:28 UTC
Issue in one of the dependencies (which has been resolved) of clusterssh, not clusterssh itself.

*** This bug has been marked as a duplicate of bug 763903 ***