Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 767823 - media-video/mkvtoolnix-51.0.0 w/ gcc11: numeric_traits.h:64:53: error: static assertion failed
Summary: media-video/mkvtoolnix-51.0.0 w/ gcc11: numeric_traits.h:64:53: error: static...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL: https://gitlab.com/mbunkus/mkvtoolnix...
Whiteboard:
Keywords:
: 768348 (view as bug list)
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-01-29 09:00 UTC by Geoff Leach
Modified: 2021-09-19 07:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gcc build log (log-emerge-mkvtoolnix.2,342.57 KB, text/plain)
2021-01-29 09:00 UTC, Geoff Leach
Details
clang build log (log-emerge-mkvtoolnix.3,89.87 KB, text/plain)
2021-01-29 09:04 UTC, Geoff Leach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoff Leach 2021-01-29 09:00:43 UTC
Created attachment 685026 [details]
gcc build log

Build logs attached, but here's the crux, 

clang

usr/lib/gcc/x86_64-pc-linux-gnu/11.0.0/include/g++-v11/ext/numeric_traits.h:64:
7: fatal error: 
      static_assert failed due to requirement '__is_integer_nonstrict<unsigned
      __int128>::__value' "invalid specialization"
      static_assert(__is_integer_nonstrict<_Value>::__value,
      ^             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
gcc

/usr/lib/gcc/x86_64-pc-linux-gnu/11.0.0/include/g++-v11/ext/numeric_traits.h:64:53: error: static assertion failed: invalid specialization
   64 |       static_assert(__is_integer_nonstrict<_Value>::__value,
      |                                                     ^~~~~~~
compilation terminated due to -Wfatal-errors.
Comment 1 Geoff Leach 2021-01-29 09:04:51 UTC
Created attachment 685029 [details]
clang build log
Comment 2 Ionen Wolkens gentoo-dev 2021-01-29 16:14:14 UTC
clang issue happens because it's trying to use the selected gcc11's libstdc++ (works fine if select gcc10 then use clang)

That aside, sounds like upstream already fixed this.
Comment 3 Ionen Wolkens gentoo-dev 2021-02-02 17:36:13 UTC
*** Bug 768348 has been marked as a duplicate of this bug. ***
Comment 4 Geoff Leach 2021-04-24 08:38:13 UTC
Problem gone by mkvtoolnix-56.1.0, closing.
Comment 5 Larry the Git Cow gentoo-dev 2021-09-19 07:12:52 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1e6a189ff59cd772bc17898f11d0b5f95da4fa8b

commit 1e6a189ff59cd772bc17898f11d0b5f95da4fa8b
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2021-09-19 07:08:52 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2021-09-19 07:12:37 +0000

    media-video/mkvtoolnix: Remove old
    
    Bug: https://bugs.gentoo.org/767823
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>

 media-video/mkvtoolnix/Manifest                 |   1 -
 media-video/mkvtoolnix/mkvtoolnix-51.0.0.ebuild | 130 ------------------------
 2 files changed, 131 deletions(-)