Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 767769 - media-gfx/inkscape-1.0.2 fails to build with gcc-11
Summary: media-gfx/inkscape-1.0.2 fails to build with gcc-11
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mikle Kolyada
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-01-28 15:35 UTC by Geoff Leach
Modified: 2021-03-11 00:05 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (log-emerge-inkscape.5,897.93 KB, text/plain)
2021-01-28 15:35 UTC, Geoff Leach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoff Leach 2021-01-28 15:35:37 UTC
Created attachment 684981 [details]
build log

inkscape-1.0.2 fails to build with gcc-11

/var/tmp/portage/media-gfx/inkscape-1.0.2/work/inkscape-1.0.2_2021-01-15_e86c870
879/src/extension/system.cpp:177:78: error: ‘this’ pointer null [-Werror=nonnull
]
  177 |             gchar const *ext = dynamic_cast<Input *>(in_plug)->get_exten
sion();
      |                                                                         
     ^

I've tried setting -Wno-error=nonnull in CXXFLAGS and even though that option shows up in the compilation line still get an error rather than warning.

With clang-11 compiles and runs ok - just simple test of drawing a line.
Comment 1 Geoff Leach 2021-01-29 02:47:43 UTC
*** Bug 760114 has been marked as a duplicate of this bug. ***
Comment 3 Kobboi 2021-02-10 19:22:06 UTC
(In reply to Geoff Leach from comment #2)
> Fixed upstream
> 
> https://gitlab.com/speleo3/inkscape/-/commit/
> 7c1b8a1587b9c3b473a01b7fe7908102a251899d

Confirmed: the current 9999 ebuild does not exhibit this issue.
Comment 4 Geoff Leach 2021-03-11 00:04:38 UTC
fixed upstream and patch included in inkscape-1.0.2-r1