Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 76770 - Qalculate-gtk does not run (fully), takes all of CPU
Summary: Qalculate-gtk does not run (fully), takes all of CPU
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High major (vote)
Assignee: Gentoo Science Related Packages
Depends on:
Reported: 2005-01-05 08:02 UTC by Andrew Conkling
Modified: 2005-08-13 18:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Qalculate log from strace (log,324.58 KB, text/plain)
2005-01-07 21:23 UTC, Andrew Conkling

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Conkling 2005-01-05 08:02:07 UTC
I have emerged qalculate-gtk but it will not run usably; the interface is presented but none of the buttons/menus work and the process takes all of the CPU.

I've thought about recompiling with lower CFLAGS, but I don't know which package (including dependencies) might be at fault.

Portage 2.0.51-r3 (default-linux/x86/2004.0, gcc-3.3.4, glibc-, 2.6.9-gentoo-r13 i686)
System uname: 2.6.9-gentoo-r13 i686 Intel(R) Pentium(R) 4 CPU 1300MHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O3 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="X aalib acl acpi alsa apm avi berkdb bitmap-fonts bzlib cdr crypt directfb dvd encode fam fbcon gdbm gif gpm gtk gtk2 imagemagick imlib java jpeg libg++ libwww mad mmx mpeg ncurses nls opengl pam pdflib perl png readline samba sdl slang spell sse ssl svg svga tcltk tcpd truetype unicode x86 xml2 xpm xv zlib"
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2005-01-06 01:30:21 UTC
Please give qalculate-0.7.1 a try. If there's trouble with old qalculate-gtk we should perhaps mark the new one stable, even if not much tested. Please give it a try and report.

Comment 2 Patrick Kursawe (RETIRED) gentoo-dev 2005-01-06 06:31:25 UTC
Maybe the test-request status fits better here...
Comment 3 Andrew Conkling 2005-01-06 18:32:54 UTC
Well, qalculate works now, but the problem remains if I try to update the exchange rates (which it asks on the first time).  But that only happens if I try it in the GTK version; if I do it in the command line version, it updates fine.

My guess is that the older version tried to update exchange rates automatically and that that was a problem.  At this point, I'm assuming the problem is upstream?  Can anyone confirm?

(I'm not marking this verified as I left it requesting a test. ;)
Comment 4 Patrick Kursawe (RETIRED) gentoo-dev 2005-01-07 01:17:59 UTC
Works fine for me in the gtk version. The output in the terminal from where I started it looks like it's using wget. Do you get something there when you try to update?

strace -o log -f qalculate-gtk could also be helpful.
Comment 5 Andrew Conkling 2005-01-07 21:23:03 UTC
Created attachment 47915 [details]
Qalculate log from strace

I'm not sure how this will be helpful, but here's the entire thing, up until I
killed the process.
Comment 6 Patrick Kursawe (RETIRED) gentoo-dev 2005-01-09 23:17:21 UTC
Very strange. Perhaps there's a broken file from an older version around? Please rm -rf ~/.qalculate* and try again.
Comment 7 Andrew Conkling 2005-01-10 12:38:08 UTC
Nope, same deal.  So CFLAGS are not the issue?
Comment 8 Patrick Kursawe (RETIRED) gentoo-dev 2005-03-10 12:45:14 UTC
This is not exactly resolved... re-opening.
Comment 9 Olivier Fisette (RETIRED) gentoo-dev 2005-06-05 05:58:23 UTC
I'll make new ebuilds for libqalculate, qalculate-gtk and qalculate-kde today 
(version 0.8). Once they are in Portage, maybe you could check if the bug is 
still there? 
Comment 10 Olivier Fisette (RETIRED) gentoo-dev 2005-08-13 11:19:02 UTC
No feedback, and no one else has ever had this problem, as far as I can tell. 
Comment 11 Andrew Conkling 2005-08-13 18:46:09 UTC
...And I'm not on Gentoo anymore.  I will say though... I appreciate that y'all 
are diligent about not letting bug reports just sit there indefinitely.  Kudos.