Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 766090 - dev-util/ragel-7.0.3[doc] /bin/sh: line 1: dblatex: command not found
Summary: dev-util/ragel-7.0.3[doc] /bin/sh: line 1: dblatex: command not found
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
: 766201 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-01-19 08:16 UTC by Leonid Kopylov
Modified: 2021-01-20 02:10 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,49.14 KB, text/plain)
2021-01-19 08:17 UTC, Leonid Kopylov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Kopylov 2021-01-19 08:16:42 UTC
# emerge -pqv '=dev-util/ragel-7.0.3::gentoo'
[ebuild     U ] dev-util/ragel-7.0.3 [7.0.0.12] USE="doc%* (-vim-syntax%*)"

# emerge --info '=dev-util/ragel-7.0.3::gentoo'
Portage 3.0.13 (python 3.8.7-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-10.2.0, glibc-2.32-r7, 5.10.8-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.10.8-gentoo-x86_64-Intel-R-_Core-TM-_i7-8559U_CPU_@_2.70GHz-with-glibc2.2.5
KiB Mem:    32751048 total,  24240596 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Tue, 19 Jan 2021 06:00:02 +0000
Head commit of repository gentoo: 7d236a315dd7fb66ed292f881cdc43d2a72de805
sh bash 5.1_p4
ld GNU ld (Gentoo 2.35.1 p2) 2.35.1
ccache version 4.1 [disabled]
app-shells/bash:          5.1_p4::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.32.0-r1::gentoo
dev-lang/python:          2.7.18-r5::gentoo, 3.8.7::gentoo, 3.9.1::gentoo, 3.10.0_alpha3::gentoo
dev-util/ccache:          4.1::gentoo
dev-util/cmake:           3.19.3::gentoo
sys-apps/baselayout:      2.7-r1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.3-r1::gentoo
sys-devel/binutils:       2.35.1-r1::gentoo
sys-devel/gcc:            10.2.0-r5::gentoo
sys-devel/gcc-config:     2.3.2-r1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r7::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts:

edgets
    location: /var/lib/layman/edgets
    sync-type: laymansync
    sync-uri: https://github.com/BlueManCZ/edgets.git
    masters: gentoo
    priority: 50

gentoo-zh
    location: /var/lib/layman/gentoo-zh
    sync-type: laymansync
    sync-uri: git://github.com/microcai/gentoo-zh.git
    masters: gentoo
    priority: 50

gig
    location: /var/lib/layman/gig
    sync-type: laymansync
    sync-uri: https://github.com/Gig-OS/gig.git
    masters: gentoo
    priority: 50

guru
    location: /var/lib/layman/guru
    sync-type: laymansync
    sync-uri: https://anongit.gentoo.org/git/repo/proj/guru.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA google-chrome OPERA-2018 PUEL AnyDesk-TOS geekbench TeamViewer microsoft-edge"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php8.0/ext-active/ /etc/php/cgi-php8.0/ext-active/ /etc/php/cli-php8.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
GENTOO_MIRRORS="http://mirror.isoc.org.il/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="7zip X a52 aac aalib accessibility acl acpi addc addns addressbook ads afp alsa amd64 amr amrenc ancient ao apache2 apng appindicator arb archive aspell audit authdaemond autoipd base bcmath bdplus benchmarks berkdb bidi bittorrent bluetooth bluray bookmarks botan box branding brotli btrfs builder bzip2 cacert cairo calendar canvas ccache cdda cddb cdio cdp cdparanoia cdr cgroup-hybrid charmap charts chm chromaprint chromium cli client clockdiff codec2 collab color-management colord compat conch conntrack context contrib contribdnn corefonts creds cron crypt cryptsetup cscope cue cups curl daap datavis dbus declarative designer device-mapper dia digikam djvu dnd dns doc dos dot doxysearch drafts dri dropbox dtrace dts dvd dvdr dynamic-loading ecm eds efi egl emacs emboss enchant encode eolconv eps epspdf epub equalizer evo examples excel exif experimental extra extras faac faad fam fancy fat fbcon fdk ffmpeg finger fingerprint firebird firewalld firmware flac flickr flint flite fltk fontconfig fontforge fonts fortran fprint freetype fribidi ftp fuse games gconf gd gdbm gedit gegl geoclue geoip geoip2 geolocation gfile gif gimp git glade gles2 glusterfs gme gmp gnome gnome-keyring gnome-online-accounts gnumeric gnuplot go google googledrive gopher gpg gphoto2 gpm grammar graph graphics graphviz gsettings gssapi gstreamer gtk gtk-doc gtk3 gui handwriting handy haptic harfbuzz hddtemp hdf5 hdri heif help highlight howl-compat hpn html http http2 humanities hunspell iconv icu id3tag idn image imagemagick imaging imap imhttp imlib impcap inifile inotify intl introspection ios ipod ipv6 ipython iscsi iscsi-direct iso jadetex java javamail javascript jinja jpeg json junction kate kdesu kerberos kernel-hooks krita kubernetes ladspa lame lapack lapacke lastfm latex layers lcms ldap ldap-bind ldap-sasl ldapdb leaps-timezone libass libcaca libglvnd libkms libnotify libreoffice librtmp libsamplerate libsecret libsoxr libssh libtiger libtirpc libvirt libvisual libzfs lirc live lkrn lm-sensors lmdb localstorage location log4j logrotate lua luatex lvm macosx-notifications mad maildir mailutils man map marble markdown math mathml matplotlib mbox md5sum mdadm mdnsresponder-compat mediaplayer mediawiki mediawiki-experimental memcached metalink metapost metric mikmod minizip mjpeg mms mng mobi mod modplug mongodb moodbar mount mount-locking mp3 mp4 mpc mpeg mpfr mpir mplayer mpx mssql mtp mule multilib multipath musepack music mysql mysqli nas natspec nautilus nbconvert ncurses nethack netlink network-cron networkauth networkmanager nfs nfsv4 nfsv41 nftables nls normalize notebook notification nptl nscd nsplugin ntlm oauth octave odbc odbcmanual offensive office offlinehelp ogg opencv openexr opengl openh264 openldap openmp openntpd opus orientation osg overlays pam pango parse-clocks parted pass passfile pcap pci pcre pcre16 pcre32 pdf pdfannotextractor pdfimport pdo perl phonon physfs playlist playtools plugins plymouth png policykit pop portaudio positioning postgres postproc ppds printsupport projectm pstricks publishers pulseaudio pwhich pyglet pyjwt python qml qrcode qt5 qtmedia quicktime quota radio radius rar raw rdp readline realtime recode redland reencrypt reiser4 reiserfs remote remotecalls rendering rpc rsyslog rtc rtf rtmp rubber samba sample samples sasl savedconfig sbc science screencast script scripts scripttools sctp sdjournal sdl sdl-image seccomp security-key semantic-desktop sendto sensord sensors session sftp share shotwell shout skins skydrive slp smi smime smp smpeg smtp snappy sndfile snmp soap sockets softstore songs sound sox soxr sparse speech speex spell spice spidermonkey split-usr spoof-source sql sqlite squashfs srp srt ssh sshdump ssl sssd startup-notification stunnel sudo svg symengine symlink sync-plugin-portage syslog sysprof systemd taamey taglib tbb tcl tcpd tdb telemetry telnet terminal tex4ht texi2html text tfshark tftp tftpd themes theora thesaurus thetvdb threads tiff timeline tk toolame tools topal tracepath traceroute6 tracker trashquota tre truetype tty-helpers twolame udev udisks umfpack undi unicode upnp upnp-av upower usb usbredir user-session usertools utils v4l vala valadoc vboxwebsrv vcd vhost-user-fs views vim vim-pager vim-syntax virt-network virtualbox virtualkeyboard vlc vmware vnc voices vorbis vte vtk wavpack wayland web webagg webcam webchannel webdav webengine webkit webp webready websockets whiteboarding whoosh widgets wifi winbind wininst wireshark-plugins wks-server wmf wps wxwidgets x11extras x264 x265 xa xattr xcb xemacs xetex xface xfs xft xindy xine xinerama xinetd xkb xml xmlpatterns xmlreader xmlwriter xmp xpm xps xscreensaver xtables xv xvid xwidgets yaml z3 zeroconf zfs zip zlib zsh-completion zstd" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en en-US he ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver scripting-beanshell wiki-publisher scripting-javascript" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python2_7 python3_8" RUBY_TARGETS="ruby25 ruby26 ruby27 ruby30" USERLAND="GNU" VIDEO_CARDS="intel i965 iris vmware vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Leonid Kopylov 2021-01-19 08:17:06 UTC
Created attachment 683641 [details]
build.log
Comment 2 Ionen Wolkens 2021-01-19 08:35:49 UTC
While trying USE=doc, due to missing ghostscript-gpl, I've additionally run into:

sh: line 1: gs: command not found
Comment 3 Larry the Git Cow gentoo-dev 2021-01-19 19:17:14 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5ae67c100a207777fbea1c9cf39a19dfb5ec2b8f

commit 5ae67c100a207777fbea1c9cf39a19dfb5ec2b8f
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-01-19 19:15:52 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-01-19 19:17:10 +0000

    dev-util/ragel: add missing doc deps to 7.0.3
    
    Closes: https://bugs.gentoo.org/766090
    Package-Manager: Portage-3.0.13, Repoman-3.0.2
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-util/ragel/ragel-7.0.3.ebuild | 7 +++++++
 1 file changed, 7 insertions(+)
Comment 4 Sam James archtester gentoo-dev Security 2021-01-19 20:48:28 UTC
*** Bug 766201 has been marked as a duplicate of this bug. ***
Comment 5 Sam James archtester gentoo-dev Security 2021-01-19 20:53:57 UTC
*** Bug 766201 has been marked as a duplicate of this bug. ***
Comment 6 Sam James archtester gentoo-dev Security 2021-01-20 02:10:30 UTC
*** Bug 766201 has been marked as a duplicate of this bug. ***