Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 766069 - dev-util/colm-0.14.6 calls cc directly
Summary: dev-util/colm-0.14.6 calls cc directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2021-01-19 07:34 UTC by Agostino Sarubbo
Modified: 2021-01-20 09:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,96.59 KB, text/plain)
2021-01-19 07:34 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-01-19 07:34:56 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-util/colm-0.14.6 calls cc directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different CC implementation (like clang). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks] and set the CC variable to x86_64-pc-linux-gnu-gcc.
Comment 1 Agostino Sarubbo gentoo-dev 2021-01-19 07:34:59 UTC
Created attachment 683626 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2021-01-19 07:35:01 UTC
Possible context of error(s):

sh: line 1: gcc: command not found
error: colm: there was a problem compiling the output
Comment 4 Agostino Sarubbo gentoo-dev 2021-01-20 07:31:11 UTC
(In reply to Sam James from comment #3)
> https://gitweb.gentoo.org/repo/gentoo.git/commit/dev-util/
> colm?id=702512674608c58428dbc6b2033ad11780bcffbb

https://archives.gentoo.org/gentoo-dev/message/12eac8917110ce7c984501fb495e53a0
Comment 5 Sam James archtester gentoo-dev Security 2021-01-20 09:32:51 UTC
(In reply to Agostino Sarubbo from comment #4)
> (In reply to Sam James from comment #3)
> > https://gitweb.gentoo.org/repo/gentoo.git/commit/dev-util/
> > colm?id=702512674608c58428dbc6b2033ad11780bcffbb
> 
> https://archives.gentoo.org/gentoo-dev/message/
> 12eac8917110ce7c984501fb495e53a0

It was an accident and I went and found the bug and closed it...?