Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 76503 - Xorg, tty crashes with Dell Dimension 8200 when something under Power Management is enabled
Summary: Xorg, tty crashes with Dell Dimension 8200 when something under Power Managem...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2005-01-03 04:08 UTC by Garrett Cooper
Modified: 2006-12-19 00:31 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Photo of Kernel Panic (kernel_panic-2.6.jpg,25.11 KB, image/jpeg)
2005-01-07 14:35 UTC, Kris Kerwin

Note You need to log in before you can comment on or make changes to this bug.
Description Garrett Cooper 2005-01-03 04:08:46 UTC
The issue was as follows:

Every time I tried to start Xorg via the startx command is I would run into a hard freeze where all input was frozen (to my knowledge since I didn't know of sysrq and didn't have it compiled into the kernel prior to then).

If the console was allowed to blank normally that it would result in the same thing.

All cases were involving the use of the nvidia driver and kernel versions beyond-and possibly including-the gentoo-dev-sources 2.6.9-r4 and greater versions. By not compiling in APM support the system appears to be running smoothly now, although I do have errors dealing with Xorg's config.

Reproducible: Sometimes
Steps to Reproduce:
1. Compile APM support into kernel.
2. Install kernel and update all conf files as necessary.
3. Reboot.
4.a. Let console blank.
4.b. Type in startx and press enter.
4.c. Type in startx, enter regular Xorg session and exit.

Actual Results:  
Hard crashes.

Expected Results:  
Not crashed.

bash-2.05b# emerge info
Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-
r1, 2.6.9-gentoo-r13 i686)
System uname: 2.6.9-gentoo-r13 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/
config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="x86 X acl alsa anthy apm arts avi berkdb bitmap-fonts cdr cjk crypt cups 
dvd encode esd fam foomaticdb fortran gdbm gif gpm gtk gtk2 imlib ipv6 jpeg 
libwww mad mikmod motif mpeg ncurses nls nptl oggvorbis opengl oss pam pdflib 
perl png python qt quicktime readline sdl slang spell ssl svga tcpd tiff 
truetype userlocale xml2 xmms xv zlib"


bash-2.05b# cat /root/ 
cd /usr/src/linux; make menuconfig; make; make bzImage modules modules_install;
cp /boot/; cp 
arch/i386/boot/bzImage /boot/gentoo-2.6.9-r13

bash-2.05b# emerge -p --nodeps nvidia-kernel nvidia-glx xorg-x11 opengl-update

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] media-video/nvidia-kernel-1.0.6111-r3
[ebuild   R   ] media-video/nvidia-glx-1.0.6111
[ebuild   R   ] x11-base/xorg-x11-6.8.0-r3
[ebuild   R   ] x11-base/opengl-update-1.8.2

Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-03 12:01:48 UTC
Can you reproduce this with the "nv" driver?
Comment 2 Kris Kerwin 2005-01-07 14:35:29 UTC
Created attachment 47897 [details]
Photo of Kernel Panic


I've been experiencing very similar symptoms with my Dell Inspiron 9100

Interestingly, I do not have APM compiled into my kernel (2.6.9-r13, though r6
exhibits the same problem); I do, however, have ACPI compiled in. Removing ACPI
from the kernel also removes the problem. I wonder if this is the same problem,
or a different one altogether. Both technologies are used for power management
-- do they share some code?

I was lucky enough to switch to a virtual terminal (Ctrl-Alt-F1) just after
logging in, but before the lock up, and caught the output of the kernel panic
in the terminal. I didn't know how to dump the output to a text file (sorry),
since my computer had locked up, but I did take a picture which I've attached. 

Try switching to a terminal to see if you get the same output. Let me know, so
that we can determine if this problem is the same. If it is the same, I have a
few more symptoms that may be of some help in solving the problem.

Thanks, all, for your help;
Kris Kerwin
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-13 16:39:28 UTC
Please reopen when you respond to comment #1.
Comment 4 Garrett Cooper 2005-01-14 13:18:59 UTC
Using nv with Xorg 6.8.0 still hard crashed the system once I finished my session using the newer version of the kernel, gentoo-dev-2.6.10-r4. This only occurs when I compile in Power Management support. Therefore the issue is most likely not one dealing with the nvidia drivers, but rather a kernel/Xorg issue. HOWEVER, considering that APM console blanking also hard crashes my tty when I allow it to blank, it sounds primarily like an issue with the kernel and possibly some other driver.
Comment 5 Kris Kerwin 2005-01-17 17:18:59 UTC
Quoting Garrett Cooper:

"it sounds primarily like an issue with the kernel and possibly some other driver."

This rather intrigues me. I have since found out that my problem is instead one with the ndiswrapper
out-of-tree kernel module that allows many proprietary wireless network cards to work under Linux.
Dell is a large reseller of such cards in many of their machines. The corresponding bug report may 
be found at

For myself, I noticed that ndiswrapper was dependent on ACPI and APM, so removing either one 
disabled ndiswrapper, preventing it from crashing the system. This allowed my situation to at least
mimic yours, if it is not indeed the same.

I'm curious, since we both have Dell machines, and since our problems are indeed so similar, if by some long shot you do use the ndiswrapper module?

Thanks for your help.

Kris Kerwin
Comment 6 Garrett Cooper 2005-01-17 18:54:42 UTC
Hmmm.. I actually run a Dell Dimension 8200 and I do not have a wireless card. I should have listed all my specs...

Dell Dimension 8200
Intel Pentium 4 2.4 GHz 533 MHz FSB
512 Mb 1033 MHz RD Ram
nVidia GeForce4 Ti 4200
Realtek 8139 10/100 MBit Networking
Unknown maker ieee1394 card
Turtle Beach Santa Cruz card
M$ Intellimouse 3.0
Hauppage TV card (PCI without radio)

I'll be sure to post my new kernel config sometime soon.
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2005-01-20 08:33:38 UTC
Ok, can you confirm that this issue exists without using any binary drivers (e.g. ndiswrapper), without the nvidia module even being *loaded* (check with lsmod), using the nv driver under Xorg

Ideally you should test this under 2.6.11-rc1 too, if possible.
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2005-01-28 03:40:18 UTC
Please reopen when you reply to comment #7
Comment 9 Garrett Cooper 2005-01-28 12:02:09 UTC
As you can see, I don't have ndiswrapper

bash-2.05b# cd /usr/src/linux; cat .config | grep -i NDIS

bash-2.05b# emerge -C ndiswrapper

--- Couldn't find ndiswrapper to unmerge.

>>> unmerge: No packages selected for removal.

I will try 2.6.11 soon. I have just been busy with schoolwork and don't want to deal with reconfig'ing right away.
Comment 10 Garrett Cooper 2005-02-03 22:21:00 UTC
I tried development-sources-2.6.11-r3 to see if that caused an issue, but once again X crashed. I also had emerged the latest RC of Xorg in an attempt to see if that was an issue, but it wasn't.

So I've narrowed the issue down to a few things with APM:
[] Enable APM at boot
[] Enable console blanking
[] Use real mode APM BIOS call to power off
Comment 11 Garrett Cooper 2005-02-08 13:12:07 UTC
One thing that I've been considering recently is that it may be an issue with permissions dealing with /dev/apm_bios and udev. Could someone post a valid set of permissions for apm_bios for me to test?
Comment 12 Daniel Drake (RETIRED) gentoo-dev 2005-02-09 07:48:11 UTC
Looks like APM is at fault then
Please file a bug for this at
Comment 13 Garrett Cooper 2006-12-19 00:31:05 UTC
This particular set of symptoms have been resolved in further versions of the kernel / Xorg (last operating version of the Linux kernel was 2.6.18 and was 7.0 latest, as of 2006.12.16).

No longer running Linux though so I cannot comment upon the issue further really or provide debugging information.

Resolving on my own in the upstream ticket.