Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 763333 - sys-kernel/gentoo-sources-5.9+ erratic touchscreen behaviour
Summary: sys-kernel/gentoo-sources-5.9+ erratic touchscreen behaviour
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2021-01-03 21:20 UTC by Anton Gubarkov
Modified: 2021-02-13 19:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Anton Gubarkov 2021-01-03 21:20:23 UTC
It seems to me that patches included into the gentoo-sources 5.9.16 break the stable work of my Wacom touchscreen in thinkpad P52.

The mouse starts to jump to the top left and bottom left corners (triggering the gnome overview even when I have the No Topleft corner extension installed).

It happens even when I'm not even close to the screen with my hands.

I tried to bisect using the vanilla kernel - both v5.9 and v5.10 show as good - no jumping. touch screen works as expected. 

How can I try to bisect the gentoo patches?

Comment 1 Mike Pagano gentoo-dev 2021-01-03 21:25:58 UTC
Is the latest 5.10.X working ?
Comment 2 Anton Gubarkov 2021-01-06 19:04:45 UTC
5.10.4 works fine without this issue.
Comment 3 Mike Pagano gentoo-dev 2021-01-07 17:28:41 UTC
Thanks, I'm going to close this as 5.9.X is EOL'ed and I will be removing it from the tree soon.

If the problem returns with a 5.10.4 or greater kernel please reopen this.
Comment 4 Anton Gubarkov 2021-01-10 15:34:21 UTC
The problem is still here with me with 5.10.5-gentoo
So I re-open this bug.

The mouse pointer jumps to the lower left corner and I can't move it from there.

When I xinput --disable  the  Wacom Pen and multitouch sensor Finger the jumping stops.
Comment 5 Anton Gubarkov 2021-01-11 07:28:57 UTC also seems relevant to this case. The issue with the sticky mouse also can be worked around on my laptop by a touch of the screen.
Comment 6 Mike Pagano gentoo-dev 2021-02-13 19:26:13 UTC
According to your bug, this doesn't seem to be gentoo-sources related, as many other distros are experience the same behavior.

Reassigning as this time.