Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 761685 - dev-libs/boost-1.74.0-r2 internal compiler error
Summary: dev-libs/boost-1.74.0-r2 internal compiler error
Status: RESOLVED DUPLICATE of bug 724314
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-25 19:25 UTC by Dennis Gäbler
Modified: 2020-12-26 10:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Boost build log (build.log,430.48 KB, text/x-log)
2020-12-25 19:25 UTC, Dennis Gäbler
Details
emerge --info output (emerge-info.txt,16.44 KB, text/plain)
2020-12-25 19:26 UTC, Dennis Gäbler
Details
gcc -v output (gcc.txt,1.50 KB, text/plain)
2020-12-25 19:27 UTC, Dennis Gäbler
Details
preprocessed file (compressed) (xml_wgrammar.ii.xz,250.25 KB, application/x-xz)
2020-12-25 19:28 UTC, Dennis Gäbler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Gäbler 2020-12-25 19:25:03 UTC
Created attachment 679473 [details]
Boost build log

As I was told in 620468, I want to report an internal compiler error that I get compiling boost. I followed the corresponding wiki entry and noticed that it happens when I set -march=znver1, it builds fine with -march=x86-64.

This is my expanded march: 
-march=znver1 -mmmx -mno-3dnow -msse -msse2 -msse3 -mssse3 -msse4a -mcx16 -msahf -mmovbe -maes -msha -mpclmul -mpopcnt -mabm -mno-lwp -mfma -mno-fma4 -mno-xop -mbmi -mno-sgx -mbmi2 -mno-pconfig -mno-wbnoinvd -mno-tbm -mavx -mavx2 -msse4.2 -msse4.1 -mlzcnt -mno-rtm -mno-hle -mrdrnd -mf16c -mfsgsbase -mrdseed -mprfchw -madx -mfxsr -mxsave -mxsaveopt -mno-avx512f -mno-avx512er -mno-avx512cd -mno-avx512pf -mno-prefetchwt1 -mclflushopt -mxsavec -mxsaves -mno-avx512dq -mno-avx512bw -mno-avx512vl -mno-avx512ifma -mno-avx512vbmi -mno-avx5124fmaps -mno-avx5124vnniw -mno-clwb -mmwaitx -mclzero -mno-pku -mno-rdpid -mno-gfni -mno-shstk -mno-avx512vbmi2 -mno-avx512vnni -mno-vaes -mno-vpclmulqdq -mno-avx512bitalg -mno-avx512vpopcntdq -mno-movdiri -mno-movdir64b -mno-waitpkg -mno-cldemote -mno-ptwrite -mno-avx512bf16 -mno-enqcmd -mno-avx512vp2intersect --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=znver1
Comment 1 Dennis Gäbler 2020-12-25 19:26:59 UTC
Created attachment 679476 [details]
emerge --info output
Comment 2 Dennis Gäbler 2020-12-25 19:27:12 UTC
Created attachment 679479 [details]
gcc -v output
Comment 3 Dennis Gäbler 2020-12-25 19:28:43 UTC
Created attachment 679482 [details]
preprocessed file (compressed)
Comment 4 Sergei Trofimovich (RETIRED) gentoo-dev 2020-12-26 10:03:36 UTC

*** This bug has been marked as a duplicate of bug 724314 ***