Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 76130 - dev-libs/boost 1.32 puts include files in /usr/include/boost-1_32
Summary: dev-libs/boost 1.32 puts include files in /usr/include/boost-1_32
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Disenchanted (RETIRED)
Depends on:
Reported: 2004-12-30 05:07 UTC by Troels Henriksen
Modified: 2004-12-31 08:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Troels Henriksen 2004-12-30 05:07:59 UTC
Boost 1.32 is currently marked ~x86. 
When emerged, the header files (in a "boost"-directory) are put in /usr/include/boost-1_32, instead of /usr/include. This requires modification of makefiles, and is generelly painful to work with.

Reproducible: Always
Steps to Reproduce:
1. Emerge Boost 1.32.
2. Compile a C++ program using Boost headers, a program that worked with Boost 1.31.

Actual Results:  
The compiler complains about missing header files.

Expected Results:  
The compiler should have compiled the program without any issues.

This problem can be worked around by specifying -I/usr/include/boost-1_32 on the
compiler command line. This, however, is painful to do if you use Automake.

emerge info:

Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-,
2.6.8-gentoo i686)
System uname: 2.6.8-gentoo i686 AMD Athlon(tm) Processor
Gentoo Base System version 1.4.16
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-march=athlon-tbird -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-tbird -O2 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs autoconfig ccache distlocks prelink sandbox sfperms"
GENTOO_MIRRORS=" rsync://"
USE="x86 3dnow X aalib acl alsa apache2 apm athena avi berkdb bitmap-fonts
bonobo cdr crypt cups dga directfb doc dvd emacs encode fam fbcon flac
foomaticdb fortran freetype gb gdbm gif gpm gstreamer gtk2 guile imagemagick
imlib jikes jpeg libwww mad mbox mikmod mmx mono motif mozilla moznocompose
moznoirc moznomail moznoxft mozsvg mpeg msn music ncurses nls nomac offensive
oggvorbis operanom2 pam pdflib perl png ppds prelink python readline samba sdl
slang spell ssl svga tcltk tcpd tetex tiff truetype unicode v4l xft xinerama xml
xml2 xmms xv zlib"
Comment 1 Disenchanted (RETIRED) gentoo-dev 2004-12-30 20:52:16 UTC
a symlink is created from boost-1_32 to boost allowing the usual #include <boost/this/that.hpp> as with 1.31, from other bug reports it appears the link is not made when upgrading, im currently looking into this, the headers will not appear in /usr/include but /usr/include/boost once the symlink is properly created for people upgrading
Comment 2 Disenchanted (RETIRED) gentoo-dev 2004-12-30 21:13:02 UTC
     --layout=system \

will most likely be used as the consensus seems to be everyone wants simpler lib names and file locations
Comment 3 Disenchanted (RETIRED) gentoo-dev 2004-12-31 08:17:31 UTC
/usr/include/boost/ is only location with --layout=system now