Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 760549 - app-office/libreoffice-7.0.3.1: configure: error: Your version of libclucene has contribs-lib missing.
Summary: app-office/libreoffice-7.0.3.1: configure: error: Your version of libclucene ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard: clang-gcc-mix
Keywords:
: 804175 832848 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-17 22:35 UTC by Conrad Kostecki
Modified: 2022-02-18 17:53 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,147.83 KB, text/plain)
2020-12-17 22:35 UTC, Conrad Kostecki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Conrad Kostecki gentoo-dev 2020-12-17 22:35:30 UTC
checking which libjpeg to use... external
checking jpeglib.h usability... yes
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
checking for jpeg_resync_to_restart in -ljpeg... yes
checking which clucene to use... external
checking for libclucene-core... yes
checking for CLucene/analysis/cjk/CJKAnalyzer.h... no
configure: error: Your version of libclucene has contribs-lib missing.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-office/libreoffice-7.0.3.1/work/libreoffice-7.0.3.1/config.log
 * ERROR: app-office/libreoffice-7.0.3.1::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  125:  Called src_configure
 *             environment, line 5776:  Called econf '--with-system-dicts' '--with-system-epoxy' '--with-system-headers' '--with-system-jars' '--with-system-libs' '--enable-build-opensymbol' '--enable-cairo-canvas' '--enable-largefile' '--enable-mergelibs' '--enable-neon' '--enable-python=system' '--enable-randr' '--enable-release-build' '--disable-breakpad' '--disable-bundle-mariadb' '--disable-ccache' '--disable-epm' '--disable-fetch-external' '--disable-gtk3-kde5' '--disable-online-update' '--disable-openssl' '--disable-pdfium' '--disable-vlc' '--with-extra-buildid=Gentoo official package' '--enable-extension-integration' '--with-external-dict-dir=/usr/share/myspell' '--with-external-hyph-dir=/usr/share/myspell' '--with-external-thes-dir=/usr/share/myspell' '--with-external-tar=/var/tmp/portage/app-office/libreoffice-7.0.3.1/distdir' '--with-lang=' '--with-parallelism=9' '--with-system-ucpp' '--with-tls=nss' '--with-vendor=Gentoo Foundation' '--with-x' '--without-fonts' '--without-myspell-dicts' '--with-help=html' '--without-helppack-integration' '--with-system-gpgmepp' '--without-system-jfreereport' '--without-system_apache_commons' '--without-system-sane' '--without-system-qrcodegen' '--disable-report-builder' '--disable-sdremote-bluetooth' '--enable-coinmp' '--enable-cups' '--enable-dbus' '--disable-debug' '--disable-evolution2' '--disable-firebird-sdbc' '--disable-gstreamer-1-0' '--disable-gtk3' '--disable-kf5' '--disable-qt5' '--enable-ldap' '--disable-odk' '--enable-pdfimport' '--enable-postgresql-sdbc' '--enable-skia' '--with-lxml' '--with-system-coinmp' '--with-gdrive-client-id=329227923882.apps.googleusercontent.com' '--with-gdrive-client-secret=vgKG0NNv7GoDpbtoFNLxCUXu' '--with-java' '--without-doxygen' '--disable-dconf' '--disable-gio' '--enable-ext-nlpsolver' '--enable-scripting-beanshell' '--enable-scripting-javascript' '--enable-ext-wiki-publisher' '--without-junit' '--without-system-hsqldb' '--with-ant-home=/usr/share/ant' '-with-jdk-home=/usr/lib64/openjdk-11' '--with-beanshell-jar=//usr/share/bsh/lib/bsh.jar' '--with-rhino-jar=//usr/share/rhino-1.6/lib/js.jar'
 *        phase-helpers.sh, line  680:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  112:  Called die
 * The specific snippet of code:
 *              die "$@"
 *
 * If you need support, post the output of `emerge --info '=app-office/libreoffice-7.0.3.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-office/libreoffice-7.0.3.1::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =libreoffice-7.0.3.1
 * The complete build log is located at '/var/tmp/portage/app-office/libreoffice-7.0.3.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/libreoffice-7.0.3.1/temp/environment'.
 * Working directory: '/var/tmp/portage/app-office/libreoffice-7.0.3.1/work/libreoffice-7.0.3.1'
 * S: '/var/tmp/portage/app-office/libreoffice-7.0.3.1/work/libreoffice-7.0.3.1'
Comment 1 Conrad Kostecki gentoo-dev 2020-12-17 22:35:40 UTC
Portage 3.0.12 (python 3.9.1-final-0, default/linux/amd64/17.1, gcc-10.2.0, glibc-2.32-r5, 5.9.6-gentoo x86_64)
=================================================================
System uname: Linux-5.9.6-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E3-1275_v6_@_3.80GHz-with-glibc2.32
KiB Mem:    65627972 total,  29266808 free
KiB Swap:   67633148 total,  67633148 free
Timestamp of repository gentoo: Tue, 15 Dec 2020 13:45:01 +0000
Head commit of repository gentoo: 85bd5bda28af18f685637c5c15faf579dbaf16fd
sh bash 5.0_p18
ld GNU ld (Gentoo 2.35.1 p2) 2.35.1
distcc 3.3.3 x86_64-pc-linux-gnu [disabled]
ccache version 4.1 [enabled]
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          3.7.9-r1::gentoo, 3.8.7_rc1::gentoo, 3.9.1::gentoo
dev-util/ccache:          4.1::gentoo
dev-util/cmake:           3.19.1-r1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7-r1::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.15.1-r2::gentoo, 1.16.3-r1::gentoo
sys-devel/binutils:       2.35.1-r1::gentoo
sys-devel/gcc:            10.2.0-r3::gentoo
sys-devel/gcc-config:     2.3.2-r1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r5::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: --compress --exclude-from=/etc/portage/rsync_excludes --new-compress
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1

bl4ckb0x
    location: /usr/local/portage
    masters: gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mfpmath=sse,387 -mtune=intel -O3 -frecord-gcc-switches -fomit-frame-pointer -malign-data=abi -mtls-dialect=gnu2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /etc/teamspeak3-server/ts3server.ini /etc/teamspeak3-server/ts3server_mariadb.ini /etc/teamspeak3-server/tsdns_settings.ini /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/apache2-php8.0/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cgi-php8.0/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/php/cli-php8.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mfpmath=sse,387 -mtune=intel -O3 -frecord-gcc-switches -fomit-frame-pointer -malign-data=abi -mtls-dialect=gnu2 -pipe -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build=n --with-bdeps=y"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -mfpmath=sse,387 -mtune=intel -O3 -frecord-gcc-switches -fomit-frame-pointer -malign-data=abi -mtls-dialect=gnu2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms sign strict strict-keepdir unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -mfpmath=sse,387 -mtune=intel -O3 -frecord-gcc-switches -fomit-frame-pointer -malign-data=abi -mtls-dialect=gnu2 -pipe"
GENTOO_MIRRORS="https://packages.hetzner.com/gentoo/"
INSTALL_MASK="/etc/systemd/* /etc/xinetd.d/* /usr/lib/systemd/*"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 -Wl,-O1 -Wl,--sort-common -Wl,-z,now"
LINGUAS="de de_DE"
MAKEOPTS="-j9 -l8"
PKGDIR="/var/cache/binpkgs"
PORTAGE_BUNZIP2_COMMAND="pbunzip2"
PORTAGE_BZIP2_COMMAND="pbzip2"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9e"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--compress --exclude-from=/etc/portage/rsync_excludes --new-compress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X aalib accessibility acl alsa amd64 berkdb bzip2 cairo calendar caps cddb cgi cjk colord cracklib crypt cups curl cvs cxx dbus dga djvu dri dvb elogind encode exif fbcon ffmpeg fftw filecaps flac fontconfig fortran ftp gd gdbm geolocation gif git gmp gnutls gphoto2 gpm graphviz gsm iconv icu idn ieee1394 imap imlib inotify introspection ipv6 java javascript jbig jemalloc jit joystick jpeg jpeg2k kerberos latex lcms ldap libass libcaca libglvnd libnotify libsamplerate lm-sensors lua luajit lz4 lzma lzo maildir mbox mhash mikmod milter mmap modplug motif mp3 mysql mysqli ncurses nls nntp offensive ogg openal openexr opengl openmp opus orc oss pam pcre pdf perl pie png policykit posix postgres postscript pulseaudio python raw readline rtmp samba sasl scanner sdl seccomp session slang smartcard sndfile snmp soap sockets sound sox speex spell split-usr sqlite ssl startup-notification subversion suid svg symlink syslog tcl tcpd theora threads tiff truetype udev unicode usb v4l vaapi vdpau verify-sig vhosts vim-syntax vnc vorbis wavpack wayland webkit webp wmf x264 xattr xcb xcomposite xface xft xinetd xml xmpp xpm xscreensaver xv xvid zeroconf zlib zsh-completion zstd" ABI_X86="32 64" COLLECTD_PLUGINS="apcups battery buddyinfo capabilities cgroups check_uptime connectivity conntrack contextswitch cpu cpufreq cpusleep df disk dns entropy ethstat exec fhcount filecount hddtemp hugepages interface ipc ipmi iptables irq load java mcelog md memory mysql netlink nfs nginx ntpd openldap openvpn pcie_errors ping postgresql processes procevent protocols rrdcached sensors serial smart snmp swap syslog tcpconns thermal turbostat unixsock uptime users wireless" CPU_FLAGS_X86="aes avx avx2 rdrand mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="garmin garmintxt nmea0183" GRUB_PLATFORMS="pc" INPUT_DEVICES="libinput" KERNEL="linux" L10N="de de_DE" LCD_DEVICES="cfontzpacket crystalfontz glcd2usb hd44780 lcd2usb" LIBREOFFICE_EXTENSIONS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher" LUA_TARGETS="lua5-1 lua5-2 lua5-3" NGINX_MODULES_HTTP="access addition auth_basic autoindex brotli browser charset fancyindex fastcgi geo geoip geoip2 gunzip gzip gzip_static headers_more image_filter javascript limit_conn limit_req map metrics proxy realip referer rewrite secure_link sticky stub_status upload_progress upstream_keepalive vhost_traffic_status xslt" NGINX_MODULES_MAIL="imap pop3 smtp" NGINX_MODULES_STREAM="access geo geoip geoip2 javascript limit_conn map realip return ssl_preread" PHP_TARGETS="php7-4" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8 python3_9" RUBY_TARGETS="ruby26 ruby27" SANE_BACKENDS="hp net" USERLAND="GNU" VIDEO_CARDS="i965 intel iris"
Unset:  CC, CPPFLAGS, CTARGET, CXX, PORTAGE_BINHOST
Comment 2 Conrad Kostecki gentoo-dev 2020-12-17 22:35:52 UTC
Created attachment 678646 [details]
config.log
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2020-12-22 19:45:35 UTC
the error message is misleading, this is not the cause

from config.log:
=========================
configure:21747: checking for CLucene/analysis/cjk/CJKAnalyzer.h
configure:21747: x86_64-pc-linux-gnu-clang++ -c -march=native -mtune=intel -frecord-gcc-switches -pipe -O2    conftest.cpp >&5
In file included from conftest.cpp:82:
In file included from /usr/include/CLucene.h:38:
In file included from /usr/include/CLucene/store/RAMDirectory.h:11:
/usr/include/CLucene/util/VoidMap.h:14:11: fatal error: 'tr1/unordered_map' file not found
        #include <tr1/unordered_map>
                 ^~~~~~~~~~~~~~~~~~~
=========================
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2020-12-22 20:10:53 UTC
This is a bit strange. 

It looks like you're building LO with USE=clang, and for whatever reason the clucene test fails then. (Which I did test and not observe.)

Could you please rebuild dev-cpp/clucene and then try again? Maybe it was built ages ago with an old compiler...
Comment 5 Conrad Kostecki gentoo-dev 2020-12-22 21:27:15 UTC
(In reply to Andreas K. Hüttel from comment #4)
> This is a bit strange. 
> 
> It looks like you're building LO with USE=clang, and for whatever reason the
> clucene test fails then. (Which I did test and not observe.)
> 
> Could you please rebuild dev-cpp/clucene and then try again? Maybe it was
> built ages ago with an old compiler...

Okay, I've done a rebuild of 'dev-cpp/clucene'. Last compilation was from beginning 2020, so really old. But libreoffice still fails with the same reason and config.log.

I just run a locate for tr1/unordered_map, I can only find some files for GCC, but apprently CLANG don't has them? Could be my CLANG missing something?

/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include/g++-v10/tr1/unordered_map
/usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include/g++-v10/tr1/unordered_map.h
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2020-12-22 22:08:15 UTC
(In reply to Conrad Kostecki from comment #5)
> (In reply to Andreas K. Hüttel from comment #4)
> > This is a bit strange. 
> > 
> > It looks like you're building LO with USE=clang, and for whatever reason the
> > clucene test fails then. (Which I did test and not observe.)
> > 
> > Could you please rebuild dev-cpp/clucene and then try again? Maybe it was
> > built ages ago with an old compiler...
> 
> Okay, I've done a rebuild of 'dev-cpp/clucene'. Last compilation was from
> beginning 2020, so really old. But libreoffice still fails with the same
> reason and config.log.
> 
> I just run a locate for tr1/unordered_map, I can only find some files for
> GCC, but apprently CLANG don't has them? Could be my CLANG missing something?
> 
> /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include/g++-v10/tr1/unordered_map
> /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/include/g++-v10/tr1/unordered_map.h

Try emerging sys-libs/libcxx and then testing again...

(I did not need that, which is why I am puzzled.)
Comment 7 Conrad Kostecki gentoo-dev 2020-12-22 22:32:08 UTC
(In reply to Andreas K. Hüttel from comment #6)
> Try emerging sys-libs/libcxx and then testing again...
> 
> (I did not need that, which is why I am puzzled.)

Done. Still no change. What files are exactly missing?
For example, '/usr/include/c++/v1/unordered_map' is present.
Comment 8 Conrad Kostecki gentoo-dev 2020-12-24 14:03:25 UTC
I did run further tests. The problem is caused by my use flags for sys-devel/clang.

If I do enable 'default-libcxx' for sys-devel/clang, I can reproduce the configure error here. If both are disabled, it works! I am not sure, why I did worked yesterday. Maybe I did something wrong.
Comment 9 Bogdan 2021-02-14 18:54:26 UTC
I have the same error with libreoffice-7.0.4.2:

  configure: error: Your version of libclucene has contribs-lib missing.

libreoffice compiled with clang.
dev-cpp/clucene compiled with gcc.

clucene is compiled with gcc because it don't compile with clang.
Issue for clucene opened at https://github.com/synhershko/clucene/issues/2
Comment 10 Paolo Pedroni 2021-03-01 16:44:25 UTC
Building clucene with clang (thanks to the patch in https://sourceforge.net/p/clucene/bugs/231/) makes configure complete succesfully.
Comment 11 Andreas Sturmlechner gentoo-dev 2021-07-26 17:23:52 UTC
*** Bug 804175 has been marked as a duplicate of this bug. ***
Comment 12 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2021-11-06 15:12:45 UTC
(In reply to Paolo Pedroni from comment #10)
> Building clucene with clang (thanks to the patch in
> https://sourceforge.net/p/clucene/bugs/231/) makes configure complete
> succesfully.

Current versions of Clucene appear to be buildable by Clang without the patch now
Comment 13 Andreas Sturmlechner gentoo-dev 2022-02-07 12:55:15 UTC
*** Bug 832848 has been marked as a duplicate of this bug. ***
Comment 14 Andreas K. Hüttel archtester gentoo-dev 2022-02-12 00:34:51 UTC
(In reply to John Helmert III from comment #12)
> (In reply to Paolo Pedroni from comment #10)
> > Building clucene with clang (thanks to the patch in
> > https://sourceforge.net/p/clucene/bugs/231/) makes configure complete
> > succesfully.
> 
> Current versions of Clucene appear to be buildable by Clang without the
> patch now

Which means we can close this. Thank you!
Comment 15 Wilke Schwiedop 2022-02-13 09:49:42 UTC
…but guys, the bug really isn't fixed:
In a vanilla gentoo setup without package.env fiddling clucene is still built with gcc so libreoffice[clang] fails to configure.
Comment 16 Red 2022-02-18 17:52:12 UTC
(In reply to Wilke Schwiedop from comment #15)
> …but guys, the bug really isn't fixed:
> In a vanilla gentoo setup without package.env fiddling clucene is still
> built with gcc so libreoffice[clang] fails to configure.

What do I put into package.env to make this work?
Comment 17 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-02-18 17:53:58 UTC
(In reply to Wilke Schwiedop from comment #15)
> …but guys, the bug really isn't fixed:
> In a vanilla gentoo setup without package.env fiddling clucene is still
> built with gcc so libreoffice[clang] fails to configure.

You'd need to share which versions then. Or file a new bug and reference this one, ideally.