Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 760525 - media-video/rav1e-0.3.4: error: could not compile `bitflags`
Summary: media-video/rav1e-0.3.4: error: could not compile `bitflags`
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-17 20:38 UTC by Gleb
Modified: 2020-12-19 07:49 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,63.65 KB, text/x-log)
2020-12-17 20:38 UTC, Gleb
Details
emerge --info '=media-video/rav1e-0.3.4::gentoo' (info.txt,7.29 KB, text/plain)
2020-12-17 20:39 UTC, Gleb
Details
emerge -pqv '=media-video/rav1e-0.3.4::gentoo' (info-pqv.txt,67 bytes, text/plain)
2020-12-17 20:39 UTC, Gleb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb 2020-12-17 20:38:11 UTC
Update from rav1e-0.3.3 to rav1e-0.3.4 failed.

Attached the following:
build.log,
output of emerge -pqv '=media-video/rav1e-0.3.4::gentoo',
output of emerge --info '=media-video/rav1e-0.3.4::gentoo'

Reproducible: Always
Comment 1 Gleb 2020-12-17 20:38:27 UTC
Created attachment 678625 [details]
build.log
Comment 2 Gleb 2020-12-17 20:39:07 UTC
Created attachment 678628 [details]
emerge --info '=media-video/rav1e-0.3.4::gentoo'
Comment 3 Gleb 2020-12-17 20:39:21 UTC
Created attachment 678631 [details]
emerge -pqv '=media-video/rav1e-0.3.4::gentoo'
Comment 4 Sam James archtester gentoo-dev Security 2020-12-18 18:26:26 UTC
Rust version?
Comment 5 Gleb 2020-12-19 04:05:38 UTC
dev-lang/rust-bin (1.47.0-r1(stable)@30/11/20)
virtual/rust (1.47.0@30/11/20)
Comment 6 Gleb 2020-12-19 04:06:56 UTC
gleb@gnpc ~ $ rustc --version
rustc 1.47.0 (18bf6b4f0 2020-10-07)
Comment 7 Gleb 2020-12-19 07:49:27 UTC
That's strange but today's build worked. Previously I tried to build it three times and all builds failed (this was right before I submitted this ticket).

Today I synced the tree again, gcc was updated to 9.3.0-r2 and the next package was rav1e-0.3.4 and it worked fine.

So if there's nothing to do here, then ticket could be closed.