Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 758002 - media-libs/gst-plugins-base: automagic on dev-libs/libgudev (USE=gbm) (was: net-libs/webkit-gtk-2.30.3 fails to compile)
Summary: media-libs/gst-plugins-base: automagic on dev-libs/libgudev (USE=gbm) (was: ...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 760759 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-02 02:30 UTC by Thomas Deutschmann
Modified: 2020-12-24 11:19 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log.gz,418.87 KB, application/x-gzip)
2020-12-02 02:30 UTC, Thomas Deutschmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Deutschmann gentoo-dev Security 2020-12-02 02:30:42 UTC
Created attachment 676177 [details]
build.log

> /usr/lib/gcc/i686-pc-linux-gnu/9.3.0/../../../../i686-pc-linux-gnu/bin/ld: warning: libgudev-1.0.so.0, needed by /usr/lib/libgstgl-1.0.so.0, not found (try using -rpath or -rpath-link)
> /usr/lib/gcc/i686-pc-linux-gnu/9.3.0/../../../../i686-pc-linux-gnu/bin/ld: /usr/lib/libgstgl-1.0.so.0: undefined reference to `g_udev_device_get_device_file'
> /usr/lib/gcc/i686-pc-linux-gnu/9.3.0/../../../../i686-pc-linux-gnu/bin/ld: /usr/lib/libgstgl-1.0.so.0: undefined reference to `g_udev_enumerator_new'
> /usr/lib/gcc/i686-pc-linux-gnu/9.3.0/../../../../i686-pc-linux-gnu/bin/ld: /usr/lib/libgstgl-1.0.so.0: undefined reference to `g_udev_enumerator_add_match_subsystem'
> /usr/lib/gcc/i686-pc-linux-gnu/9.3.0/../../../../i686-pc-linux-gnu/bin/ld: /usr/lib/libgstgl-1.0.so.0: undefined reference to `g_udev_client_new'
> /usr/lib/gcc/i686-pc-linux-gnu/9.3.0/../../../../i686-pc-linux-gnu/bin/ld: /usr/lib/libgstgl-1.0.so.0: undefined reference to `g_udev_enumerator_execute'
> collect2: error: ld returned 1 exit status
> /usr/lib/gcc/i686-pc-linux-gnu/9.3.0/include/stddef.h:424: syntax error, unexpected identifier in '  __float128 __max_align_f128 __attribute__((__aligned__(__alignof(__float128))));' at '__float128'
> ../../../webkitgtk-2.30.3/Source/WebKit/UIProcess/API/glib/WebKitWebView.cpp:2191: Warning: WebKit2: multiple comment blocks documenting 'WebKitWebView::show-option-menu:' identifier (already seen at WebKitWebView.cpp:2155).
> linking of temporary binary failed: Command '['/usr/lib/ccache/bin/i686-pc-linux-gnu-gcc', '-o', '/var/tmp/portage/net-libs/webkit-gtk-2.30.3/work/webkit-gtk-2.30.3_build/Source/WebKit/tmp-introspectttc3ajyp/WebKit2-4.0', '-Wno-deprecated-declarations', '/var/tmp/portage/net-libs/webkit-gtk-2.30.3/work/webkit-gtk-2.30.3_build/Source/WebKit/tmp-introspectttc3ajyp/WebKit2-4.0.o', '-L.', '-Wl,-rpath,.', '-Wl,--no-as-needed', '-L/var/tmp/portage/net-libs/webkit-gtk-2.30.3/work/webkit-gtk-2.30.3_build/lib', '-Wl,-rpath,/var/tmp/portage/net-libs/webkit-gtk-2.30.3/work/webkit-gtk-2.30.3_build/lib', '-lwebkit2gtk-4.0', '-ljavascriptcoregtk-4.0', '-Wl,--export-dynamic', '-lgmodule-2.0', '-pthread', '-lgtk-3', '-lgdk-3', '-lpangocairo-1.0', '-lpango-1.0', '-latk-1.0', '-lcairo-gobject', '-lcairo', '-lgdk_pixbuf-2.0', '-lsoup-2.4', '-lgio-2.0', '-lgobject-2.0', '-lglib-2.0']' returned non-zero exit status 1.
> ninja: build stopped: subcommand failed.
>  * ERROR: net-libs/webkit-gtk-2.30.3::gentoo failed (compile phase):
>  *   ninja -v -j5 -l7.95 failed

Portage 3.0.9 (python 3.7.9-final-0, default/linux/x86/17.0, gcc-9.3.0, glibc-2.32-r2, 5.4.80-gentoo-x86 i686)
=================================================================
System uname: Linux-5.4.80-gentoo-x86-i686-with-gentoo-2.7
KiB Mem:     3106076 total,   1793944 free
KiB Swap:    8387560 total,   8357140 free
Timestamp of repository gentoo: Tue, 01 Dec 2020 18:35:36 +0000
Head commit of repository gentoo: 248ce54c5a898ddca84521f630ad7ce8463dff82

sh bash 5.0_p18
ld GNU ld (Gentoo 2.34 p6) 2.34.0
ccache version 3.7.12 [enabled]
app-shells/bash:          5.0_p18::gentoo
dev-lang/perl:            5.30.3::gentoo
dev-lang/python:          3.6.12::gentoo, 3.7.9::gentoo, 3.8.6::gentoo, 3.9.0::gentoo
dev-util/ccache:          3.7.12::gentoo
dev-util/cmake:           3.17.4-r1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.16.2-r1::gentoo
sys-devel/binutils:       2.34-r2::gentoo
sys-devel/gcc:            9.3.0-r1::gentoo
sys-devel/gcc-config:     2.3.2-r1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.4-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32-r2::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/repo/sync/gentoo.git
    priority: -1000

ABI="x86"
ABI_X86="32"
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
ACCEPT_PROPERTIES="*"
ACCEPT_RESTRICT="*"
ADA_TARGET="gnat_2018"
ARCH="x86"
BINPKG_COMPRESS="bzip2"
BROOT=""
CBUILD="i686-pc-linux-gnu"
CCACHE_DIR="/var/cache/ccache"
CFLAGS="-O2 -pipe -march=pentium4m -mtune=pentium4m -Wno-error=jump-misses-init -Wno-error=sign-compare"
CHOST="i686-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
COLLISION_IGNORE="/lib/modules/*"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CPU_FLAGS_X86="mmx mmxext sse sse2"
CXXFLAGS="-O2 -pipe -march=pentium4m -mtune=pentium4m -Wno-error=jump-misses-init -Wno-error=sign-compare"
DEFAULT_ABI="x86"
EDITOR="/usr/bin/mcedit"
ELIBC="glibc"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
EPREFIX=""
EROOT="/"
ESYSROOT="/"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg ccache cgroup config-protect-if-modified distlocks downgrade-backup ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=i686 -pipe"
GCC_SPECS=""
GRUB_PLATFORMS="efi-32 pc"
GSETTINGS_BACKEND="dconf"
HOME="/root"
INFOPATH="/usr/share/gcc-data/i686-pc-linux-gnu/9.3.0/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.34/info:/usr/share/info:/usr/share/info/emacs-27"
INPUT_DEVICES="libinput"
IUSE_IMPLICIT="abi_x86_32 prefix prefix-guest prefix-stack"
KERNEL="linux"
L10N="en en-US de de-DE"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LC_MESSAGES="C"
LC_PAPER="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LIBDIR_x86="lib"
LINGUAS="en de"
LOGNAME="root"
LUA_SINGLE_TARGET="lua5-1"
LUA_TARGETS="lua5-1"
MAIL="/var/mail/root"
MAKEOPTS="--jobs 5 --load-average 7.95"
MANPAGER="manpager"
MOTD_SHOWN="pam"
MULTILIB_ABIS="x86"
NOCOLOR="true"
OFFICE_IMPLEMENTATION="libreoffice"
OPENCL_PROFILE="ocl-icd"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/lib/llvm/11/bin:/usr/lib/llvm/10/bin"
PHP_TARGETS="php7-2 php7-3 php7-4"
POSTGRES_TARGETS="postgres10 postgres11"
PWD="/root"
PYTHONDONTWRITEBYTECODE="1"
PYTHON_SINGLE_TARGET="python3_7"
PYTHON_TARGETS="python2_7 python3_7"
QT_GRAPHICSSYSTEM="raster"
ROOT="/"
ROOTPATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/lib/llvm/11/bin:/usr/lib/llvm/10/bin"
RUBY_TARGETS="ruby25 ruby26"
SHELL="/bin/bash"
SHLVL="2"
SSH_TTY="/dev/pts/0"
SYSROOT="/"
TERM="tmux-256color"
TMUX="/tmp//tmux-0/default,4665,0"
TMUX_PANE="%2"
TWISTED_DISABLE_WRITING_OF_PLUGIN_CACHE="1"
USER="root"
USERLAND="GNU"
VIDEO_CARDS="vmware"
XDG_CONFIG_DIRS="/etc/xdg"
XDG_DATA_DIRS="/usr/local/share:/usr/share"
XDG_RUNTIME_DIR="/run/user/0"
XDG_SESSION_CLASS="user"
XDG_SESSION_ID="45"
XDG_SESSION_TYPE="tty"
Comment 1 Mart Raudsepp gentoo-dev 2020-12-02 07:41:43 UTC
Something looks to be wrong with your media-libs/gst-plugins-base related to its USE=gbm
Comment 2 Thomas Deutschmann gentoo-dev Security 2020-12-02 16:21:25 UTC
Some details about the build host: I am now using ccache (unrelated) and keep bin packages to avoid rebuilding deps all the time.

> portageq envvar EMERGE_DEFAULT_OPTS
> --quiet-build=n
> --verbose=y
> --with-bdeps=y
> --binpkg-changed-deps=y
> --binpkg-respect-use=y
> --rebuilt-binaries=y
> --usepkg=y
>

Looks like you are right:

> # revdep-rebuild -ip
>  * This is the new python coded version
>  * Please report any bugs found using it.
>  * The original revdep-rebuild script is installed as revdep-rebuild.sh
>  * Please file bugs at: https://bugs.gentoo.org/
>  * Collecting system binaries and libraries
>  * Checking dynamic linking consistency
>  * Assign files to packages
> 
> emerge --pretend --oneshot --complete-graph=y media-libs/gst-plugins-base:1.0
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [binary   R    ] media-libs/gst-plugins-base-1.16.2-1:1.0::gentoo  USE="X egl introspection nls ogg opengl orc pango theora vorbis -alsa -gbm -gles2 -ivorbis -wayland" 0 KiB
> 

So the question is what caused this (maybe a missing dep?)?!
Comment 3 Mart Raudsepp gentoo-dev 2020-12-19 22:52:53 UTC
*** Bug 760759 has been marked as a duplicate of this bug. ***
Comment 4 Mart Raudsepp gentoo-dev 2020-12-24 11:19:27 UTC
The reason was figured out in IRC chat, but looks like not noted here:

It's the # FIXME: Automagic gbm and x11 wsi
that needs care