Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 757 - dev-libs/cyrus-sasl -1.5.27 fails to build
Summary: dev-libs/cyrus-sasl -1.5.27 fails to build
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Donny Davies (RETIRED)
Depends on:
Reported: 2002-02-18 20:59 UTC by Avi Schwartz
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Avi Schwartz 2002-02-18 20:59:34 UTC
These are the USE variable I have set in case it matters:

USE="slang readline gpm berkdb gdbm tcpd pam libwww ssl alsa nls mitshm perl
python java esd gif sdl vorbis ogg
gnome gtk X qt kde motif opengl mozilla objprelink mmx tcltk guile mysql
postgres ldap odbc cups lame bonobo oss arts libg++ sse"

and here are the error messages:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include -I/usr/local/include -Wall -W
-mcpu=i686 -march=i686 -O3 -pipe -Wp,-MD,.deps/common.pp -c common.c  -fPIC
-DPIC -o .libs/common.lo
common.c: In function `_sasl_getconfpath':
common.c:659: `SASL_CONF_PATH_ENV_VAR' undeclared (first use in this function)
common.c:659: (Each undeclared identifier is reported only once
common.c:659: for each function it appears in.)
common.c:661: `CONFIGDIR' undeclared (first use in this function)
make[2]: *** [common.lo] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
make: *** [all-recursive-am] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 29, Exitcode 2
!!! compile problem

!!! emerge aborting on  /usr/portage/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27.ebuild .
Comment 1 Donny Davies (RETIRED) gentoo-dev 2002-02-19 02:01:44 UTC
wow, thats a fast bug report, i just checked this package in 
today, and theres a report already!  cool!

anyway, its very uncool that it doesnt build for you.

please tell me which versions of gcc and glibc you have
installed on your system.

this package compiles fine on two systems of mine, one
with significantly older versions of just about everytning
than the other one.
Comment 2 Avi Schwartz 2002-02-19 08:07:39 UTC
glibc is glibc-2.2.4-r9 and gcc is gcc-2.95.3-r5.This is what is printed by running /lib/ C Library stable release version 2.2.4, by Roland McGrath et al.Copyright (C) 1992-1999, 2000, 2001 Free Software Foundation, Inc.This is free software; see the source for copying conditions.There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR APARTICULAR PURPOSE.Compiled by GNU CC version 2.95.3 20010315 (release).Compiled on a Linux 2.4.16 system on 2002-02-08.Available extensions:        GNU libio by Per Bothner        crypt add-on version 2.1 by Michael Glad and others        linuxthreads-0.9 by Xavier Leroy        BIND-8.2.3-T5B        libthread_db work sponsored by Alpha Processor Inc        NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk
Comment 3 Donny Davies (RETIRED) gentoo-dev 2002-02-19 20:36:14 UTC
Ok ive confirmed with at least 2 more people that cyrus-sasl
compiles and installs just fine with them.

Then only thing I can suggest at this point, is that you change

emake || die
make || die

and see if that solves it.  Could you please try that and lemme
know if that fixes it?  Thanks!
Comment 4 Avi Schwartz 2002-02-19 21:17:49 UTC
Well, I don't know how to say that, but it worked for me suddenly.  After failing 3 times last 
night, I just attempted to rebuild it again and it worked this time.   I have no explanation for that!

I gues you can resolve and close the bug report.

Comment 5 Donny Davies (RETIRED) gentoo-dev 2002-02-20 00:26:30 UTC

it turns out that emake was casuing the problem in this
particular case.

the ebuild now uses make instead.